Bug 1502848 - [RFE] [Sahara] CLI for Plugin-Declared Image Generation for Ambari 2.3
Summary: [RFE] [Sahara] CLI for Plugin-Declared Image Generation for Ambari 2.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On: 1570556 1577372
Blocks: 1337661
TreeView+ depends on / blocked
 
Reported: 2017-10-16 20:26 UTC by Telles Nobrega
Modified: 2018-06-27 13:38 UTC (History)
6 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180228170523.abcc07a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 544625 None stable/queens: MERGED sahara: Adding Ambari 2.4.2.0 to image gen (I272dbab4458c902af404a6365a8a43d56e4ed94e) 2018-03-21 13:47:59 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:31 UTC

Description Telles Nobrega 2017-10-16 20:26:21 UTC
Description of problem:

This is a subset of a major bug #1337661. 

This is specific for Ambari plugin version 2.3

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Luigi Toscano 2018-02-19 15:48:50 UTC
The implementation is a bit different than what happens with the sahara-image-elements generation: we are going to use a unified Ambari 2.4 image to deploy HDP 2.4 and 2.3. The title of the feature is a bit confusing because it conflates together the version of Ambari and the version of the deployed HDP. Right now sahara-image-elements deploys Ambari 2.2.1.0 for HDP 2.4 and Ambari 2.2.0.0 for HDP 2.3, but there is no reason for it, because Ambari 2.4 can deploy both those older versions (and also HDP 2.5, but let's put that aside).

This means that, code-wise, this feature is not different than the last version of https://bugzilla.redhat.com/show_bug.cgi?id=1502851, which includes https://review.openstack.org/#/c/544625/ . The same Ambari image will be used to deploy both versions of HDP.

Comment 7 Luigi Toscano 2018-04-23 17:55:13 UTC
The image generated with Ambari 2.4 can spawn HDP 2.3 clusters when the following bug is fixed:
https://bugzilla.redhat.com/show_bug.cgi?id=1570556

Tested with 
openstack-sahara-8.0.1-0.20180328233736.36531cb

Waiting for the other bug to be solved.

Comment 8 Luigi Toscano 2018-05-13 17:12:27 UTC
Thanks to rhbz#1570556, and with the help of a workaround for the TLS version used (see rhbz#1577372), the Ambari 2.4 image generated by sahara-image-pack can spawn an HDP 2.3 cluster (pre-tested also before the jdk issue hit).


openstack-sahara-tests-0.6.0-2.el7ost
openstack-sahara-8.0.1-0.20180328233739.36531cb.el7ost (with workaround)

Comment 9 Luigi Toscano 2018-05-14 13:14:18 UTC
Ok, we need a proper clean environment. Reopening for now with the blocker.

Comment 10 Luigi Toscano 2018-05-17 23:03:15 UTC
With the fixes for bug 1577372 and bug 1570556 in place, it is now possible to confirm that an Ambari 2.4 image generated by sahara-image-pack can spawn a working HDP 2.3 cluster.

Verified with:
openstack-sahara-8.0.1-0.20180328233740.36531cb.el7ost (name of the source package)

Comment 12 errata-xmlrpc 2018-06-27 13:37:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.