Bug 1570608 - ovirt-ansible-manageiq role fails to deploy Cloudforms appliance
Summary: ovirt-ansible-manageiq role fails to deploy Cloudforms appliance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-ansible-roles
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.0
: ---
Assignee: Ondra Machacek
QA Contact: Petr Kubica
URL: https://github.com/oVirt/ovirt-ansibl...
Whiteboard:
Depends On:
Blocks: 1585232
TreeView+ depends on / blocked
 
Reported: 2018-04-23 10:31 UTC by Moran Goldboim
Modified: 2019-05-08 12:34 UTC (History)
4 users (show)

Fixed In Version: ovirt-ansible-manageiq-1.1.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1585232 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:34:23 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible-manageiq pull 37 0 None None None 2018-04-24 08:11:25 UTC
Red Hat Product Errata RHEA-2019:1064 0 None None None 2019-05-08 12:34:37 UTC

Description Moran Goldboim 2018-04-23 10:31:58 UTC
Description of problem:
Due to the difference between upstream and downstream deployment mechanism for Manageiq/Cloudforms which on downstream requires a init command for the appliance, the role fails on bringing CF up and configure RHV as a provider inside.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.use the default playbook in the examples provided in the ovirt ansible roles RPM
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Kaul 2018-04-24 06:24:44 UTC
Deferring to 4.2.4.
Moran - please attach the requirements docs for the feature (I have not been able to find it).

Comment 2 Moran Goldboim 2018-04-24 06:45:45 UTC
(In reply to Yaniv Kaul from comment #1)
> Deferring to 4.2.4.
> Moran - please attach the requirements docs for the feature (I have not been
> able to find it).

I can't find it as well right now, but this is a supported role from 4.1 release. it's simply doesn't work the same way with CloudForms between upstream and downstream.

a patch (https://github.com/oVirt/ovirt-ansible-manageiq/pull/37) that fixes the problem already there, and validated by me.
QE has approved to consume this change and test it.

not sure why the conditional nack, or pushing it to zstream when we know this function is broken and we have a fix.

Comment 3 Yaniv Kaul 2018-04-24 07:19:56 UTC
We have a proposed fix upstream, that's all.
Moving to POST.

I think the patch is good and I hope it can make it to GA. If not, since it's clearly not a blocker (I don't see the requirements the support for CFME - I don't recall 4.1 supported it as well, it's not even documented anywhere in our d/s docs), it is now targeted to the 1st z-stream.

Comment 6 Petr Kubica 2018-12-11 16:28:19 UTC
Verified in
cfme 5.9.6.5.20181130162459_7977a85
ovirt-ansible-manageiq-1.1.14-0.1.master.20181130085114.el7.noarch
ansible-2.7.2-1.el7.noarch

Comment 8 errata-xmlrpc 2019-05-08 12:34:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1064


Note You need to log in before you can comment on or make changes to this bug.