Bug 1570848 - Starting OpenDaylight fails with "Error installing boot features"
Summary: Starting OpenDaylight fails with "Error installing boot features"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Stephen Kitt
QA Contact: Itzik Brown
URL:
Whiteboard: odl_infra
: 1572663 (view as bug list)
Depends On:
Blocks: 1568976
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:15 UTC by Waldemar Znoinski
Modified: 2018-10-18 07:24 UTC (History)
5 users (show)

Fixed In Version: opendaylight-8.0.0-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:52:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:54:15 UTC

Description Waldemar Znoinski 2018-04-23 14:15:43 UTC
Description of problem:
Starting OpenDaylight fails with "Error installing boot features":

2018-04-23T12:07:29,456 | ERROR | pool-1-thread-2  | BootFeaturesInstaller            | 7 - org.apache.karaf.features.core - 4.1.3 | Error installing boot features
org.apache.karaf.features.internal.service.Deployer$CircularPrerequisiteException: [wrap/0.0.0]
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:272) ~[?:?]
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:287) ~[?:?]
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1248) ~[?:?]
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$1(FeaturesServiceImpl.java:1147) ~[?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]


Version-Release number of selected component (if applicable):
OSP13, opendaylight-8.0.0-7.rpm (it also happened with opendalight RPM built from a patch downstream)
puddle: 2018-04-19.2

How reproducible:
100%

Steps to Reproduce:
1. deploy osp13 + opendaylight + https://github.com/rhos-infra/opendaylight/tree/master/OSP13/roles
2.
3.

Actual results:
osp deployment fails due to opendaylight starting fail

Expected results:
opendaylight to start, osp deployment to work

Additional info:

Comment 1 Stephen Kitt 2018-04-23 14:25:55 UTC
Boot features: standard/[4.1.3,4.1.3], wrap/[0,0.0.0], ssh/[4.1.3,4.1.3], odl-netvirt-openstack/[0.6.0.redhat-7,0.6.0.redhat-7], odl-jolokia/[1.10.0.redhat-7,1.10.0.redhat-7]

Comment 3 Stephen Kitt 2018-04-24 11:21:24 UTC
Good news, I have a fix for this which doesn’t involve backporting SR1...

Comment 8 Mike Kolesnik 2018-04-29 06:44:56 UTC
*** Bug 1572663 has been marked as a duplicate of this bug. ***

Comment 13 Itzik Brown 2018-05-03 11:01:36 UTC
Checked with:
opendaylight-8.0.0-9

Comment 15 errata-xmlrpc 2018-06-27 13:52:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.