Bug 1572663 - ODL not starting
Summary: ODL not starting
Keywords:
Status: CLOSED DUPLICATE of bug 1570848
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: lpeer
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 14:27 UTC by Janki
Modified: 2018-10-24 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-04-29 06:44:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Janki 2018-04-27 14:27:24 UTC
Description of problem:

I have been getting this error today with all kinds of deployment setups, composable, non-composable.

Image tag used:
2018-04-26.1

On node with ODL installed
$ sudo docker ps
CONTAINER ID        IMAGE                                                           COMMAND             CREATED             STATUS                         PORTS               NAMES
68463c65acf2        192.168.24.1:8787/rhosp13/openstack-cron:2018-04-26.1           "kolla_start"       47 minutes ago      Up 47 minutes                                      logrotate_crond
bfba4a3b1d40        192.168.24.1:8787/rhosp13/openstack-opendaylight:2018-04-26.1   "kolla_start"       About an hour ago   Up About an hour (unhealthy)                       opendaylight_api


$ rpm -qa | grep opendaylight
puppet-opendaylight-8.1.0-0.20180321182557.el7ost.noarch
opendaylight-8.0.0-7.el7ost.noarch

$ cat /opt/opendaylight/etc/org.apache.karaf.features.cfg  (all other lines are commented)
featuresRepositories = file:${karaf.home}/etc/b92067dd-5062-4112-a666-69edb8a6fad0.xml
featuresBoot=standard,wrap,ssh,odl-mdsal-trace,odl-netvirt-openstack,odl-jolokia
featuresBootAsynchronous=false

$ sudo netstat -ntlp | grep 8081
-> nothing

karaf.log
Apr 27, 2018 5:36:02 AM org.apache.karaf.main.Main launch
INFO: Installing and starting initial bundles
Apr 27, 2018 5:36:02 AM org.apache.karaf.main.Main launch
INFO: All initial bundles installed and set to start
Apr 27, 2018 5:36:02 AM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Trying to lock /opt/opendaylight/lock
Apr 27, 2018 5:36:02 AM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Lock acquired
Apr 27, 2018 5:36:02 AM org.apache.karaf.main.Main$KarafLockCallback lockAquired
INFO: Lock acquired. Setting startlevel to 100
2018-04-27T05:36:03,499 | INFO  | pool-1-thread-2  | FeaturesServiceImpl              | 7 - org.apache.karaf.features.core - 4.1.3 | Adding features: standard/[4.1.3,4.1.3], wrap/[0,0.0.0], ssh/[4.1.3,4.1.3], odl-mdsal-trace/[1.7.0.redhat-7,1.7.0.redhat-7], odl-netvirt-openstack/[0.6.0.redhat-7,0.6.0.redhat-7], odl-jolokia/[1.10.0.redhat-7,1.10.0.redhat-7]
2018-04-27T05:36:03,566 | ERROR | pool-1-thread-2  | BootFeaturesInstaller            | 7 - org.apache.karaf.features.core - 4.1.3 | Error installing boot features
org.apache.karaf.features.internal.service.Deployer$CircularPrerequisiteException: [wrap/0.0.0]
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:272) ~[?:?]
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:287) ~[?:?]
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1248) ~[?:?]
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$1(FeaturesServiceImpl.java:1147) ~[?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]

I could not even ssh into the karaf (ssh -p 8101 karaf@localhost). So I am suspecting karaf didn't start properly.

I redeployed on the same set of machines with image tag 2018-04-24.1 which had the correct features installed.

Comment 1 Mike Kolesnik 2018-04-29 06:44:56 UTC

*** This bug has been marked as a duplicate of bug 1570848 ***


Note You need to log in before you can comment on or make changes to this bug.