Bug 1570864 - createrepo tracebacks on unsupported compress type
Summary: createrepo tracebacks on unsupported compress type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: createrepo
Version: 6.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: Jan Blazek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:50 UTC by Karel Srot
Modified: 2018-06-19 05:25 UTC (History)
4 users (show)

Fixed In Version: createrepo-0.9.9-28.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1626959 (view as bug list)
Environment:
Last Closed: 2018-06-19 05:25:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1931 0 None None None 2018-06-19 05:25:36 UTC

Description Karel Srot 2018-04-23 14:50:55 UTC
Description of problem:

This is a regression introduced in RHEL-6.9. Previously createrepo was not crashing.

# createrepo --compress-type foo .
Compression foo not available: Please choose from: gz, bz2
Traceback (most recent call last):
  File "/usr/share/createrepo/genpkgmetadata.py", line 307, in <module>
    main(sys.argv[1:])
  File "/usr/share/createrepo/genpkgmetadata.py", line 287, in main
    tmp = os.path.join(conf.outputdir, conf.tempdir)
  File "/usr/lib/python2.6/posixpath.py", line 67, in join
    elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'

It was introduced by the following change:

* Fri Nov 04 2016 Valentina Mukhamedzhanova <vmukhame@redhat.com> - 0.9.9-26 - Fix temporary files cleanup. - Resolves: bug#1297642


How reproducible:
always

Steps to Reproduce:
see above

Actual results:
traceback

Expected results:
previously the default compress type was used (discussed in bug 886589 closed as WONTFIX)

Comment 10 errata-xmlrpc 2018-06-19 05:25:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1931


Note You need to log in before you can comment on or make changes to this bug.