Bug 1571077 - [HTB] Repo "rhel-6-workstation-htb-rpms" should be enabled by default for workstation x86_64.
Summary: [HTB] Repo "rhel-6-workstation-htb-rpms" should be enabled by default for wor...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Fedor
QA Contact: Release Test Team
URL:
Whiteboard:
: 1573573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 05:01 UTC by Liu Song
Modified: 2018-06-05 11:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-05 11:42:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 Liu Song 2018-04-24 05:01:55 UTC
Please take a look at this bug.

Comment 3 Jaroslav Fedor 2018-04-24 13:05:31 UTC
Hi Liu Song, 
This issue can't be resolved at this point because it is a Beta compose what is pushed into HTB repos. Once we will push snapshot there, this should go away.

Comment 4 Liu Song 2018-05-03 01:54:23 UTC
*** Bug 1573573 has been marked as a duplicate of this bug. ***

Comment 5 Jaroslav Fedor 2018-05-04 07:50:55 UTC
This should be resolved in snapshot composes.

Comment 6 Liu Song 2018-05-04 08:29:15 UTC
Jaroslav Fedor, got it. We will start the snapshot testing once the content is ready.

Comment 8 Jaroslav Fedor 2018-05-07 11:17:49 UTC
This has no impact on how repos are populated. Repositories are enabled by default according certificate that is installed with redhat-release pkg. It should contain the right one now.

Comment 9 John Sefler 2018-05-07 12:39:37 UTC
There is a misunderstanding for the purpose of this bug.

The purpose of this bug is to change the Meta Data in https://bugzilla.redhat.com/attachment.cgi?id=1429429 so that repo rhel-6-workstation-htb-rpms will be enabled(ACTIVE) by default.

I assume RCM has the ability to correct the Meta Data.  Is this true?

Comment 10 Jaroslav Fedor 2018-05-07 13:56:29 UTC
Oh, okay, I see what is the issue now. 

I checked and yes, those repos are not enabled.

The thing that concerns me is that these workstation htb repos were not active at all. 
I open a codereview (https://code.engineering.redhat.com/gerrit/#/c/137927/), to fix these changes.

Comment 11 John Sefler 2018-05-08 12:31:26 UTC
(In reply to Jaroslav Fedor from comment #10)
> I checked and yes, those repos are not enabled.

Clarification... ONLY the "rhel-6-workstation-htb-rpms" repo should be ACTIVE (enabled by default)

These other repos should remain DISABLED
   rhel-6-workstation-optional-htb-debug-rpms
   rhel-6-workstation-optional-htb-rpms
   rhel-6-workstation-optional-htb-source-rpms
   rhel-6-workstation-htb-debug-rpms
   rhel-6-workstation-htb-source-rpms

Comment 12 Jaroslav Fedor 2018-05-09 07:48:55 UTC
Hi John, 

Why these 5 repos should be disabled? Disabled means that customers are not able to consume it. Correct me if I am wrong.

Comment 13 Jaroslav Fedor 2018-05-09 10:20:18 UTC
I was tryinh to active repo, but already found duplicated (already active) repos. I reverted the change. 

I submitted a new change that enables only rhel-6-workstation-htb-rpms.


Note You need to log in before you can comment on or make changes to this bug.