Bug 1571237 - Update rhev-apt.exe in virt-v2v
Summary: Update rhev-apt.exe in virt-v2v
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On:
Blocks: 1571240
TreeView+ depends on / blocked
 
Reported: 2018-04-24 11:30 UTC by Richard W.M. Jones
Modified: 2018-10-30 07:46 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.38.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1571240 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:45:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhev-apt-1.38.2-1.log (1.22 MB, text/plain)
2018-05-18 10:01 UTC, mxie@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3021 0 None None None 2018-10-30 07:46:21 UTC

Description Richard W.M. Jones 2018-04-24 11:30:54 UTC
Description of problem:

The version of rhev-apt.exe bundled with libguestfs is old.
This doesn't seem to matter from a code point of view, but
it's a problem because the binary is signed with an out of
date certificate.

Version-Release number of selected component (if applicable):

libguestfs-1.36.10-6.el7_5.2

How reproducible:

Unknown.

Steps to Reproduce:
1. Convert a guest to oVirt or RHV, try to run rhev-apt.exe after
   the guest boots up.
2. Unclear - maybe it will give an error about invalid or out of
   date certificates.

Comment 5 mxie@redhat.com 2018-05-18 10:00:32 UTC
Try to reproduce the bug with builds:
virt-v2v-1.36.10-6.el7_5.2.x86_64
libguestfs-1.36.10-6.el7_5.2.x86_64

Reproduce steps:
Scenario1:
1.1 Convert a windows guest to rhv by virt-v2v
#virt-v2v -ic vpx://root@10.73.75.182/data/10.73.72.61/?no_verify=1 esx6.0-win10-x86_64 --password-file /tmp/passwd -o rhv -os 10.66.144.40:/home/nfs_export 
1.2 Import the guest from export domain to data domain after v2v finishing conversion
1.3 Check rhev-apt.exe status in guest
1.3.1 There is rhev-apt.exe under C:\ drive
1.3.2 rhev-apt is not installed by default in guest
1.3.3 Left click to open properties, click digital signatures->details-> view certificate, valid from 11/27/2012 to 11/28/2015
1.3.4 Could install rhev-apt.exe by manual successfully

Scenario2:
2.1 Import a windows guest from vmware on rhv4.2
2.2 Check rhev-apt.exe status in guest
2.2.1 There is rhev-apt.exe under C:\ drive
2.2.2 rhev-apt has been installed by default in programs 
2.2.3 Left click to open properties, click digital signatures->details-> view certificate, valid from 11/27/2012 to 11/28/2015

Reproduce result:
    Certificate of rhev-apt.exe is out of date and rhev-apt can't be installed by default if v2v convert guest to rhv's export domain



Verify the bug with builds:
virt-v2v-1.38.2-1.el7.x86_64
libguestfs-1.38.2-1.el7.x86_64

Steps:
Scenario1
1.1 Convert a windows guest to rhv by virt-v2v
#virt-v2v -ic vpx://root@10.73.75.182/data/10.73.72.61/?no_verify=1 esx6.0-win2012-x86_64 --password-file /tmp/passwd -o rhv -os 10.66.144.40:/home/nfs_export 
1.2 Import the guest from export domain to data domain after v2v finishing conversion
1.3 Check rhev-apt.exe status in guest
1.3.1 There is rhev-apt.exe under C:\ drive
1.3.2 rhev-apt is not installed by default in guest,pls refer to screenshot"rhev-apt-install-1.38.2-1"
1.3.3 Left click to open properties, click digital signatures->details-> view certificate, valid from 11/29/2015 to 12/29/2018
1.3.4 Could install rhev-apt.exe by manual successfully

Scenario2:
2.1 Import a windows guest from vmware on rhv4.2
2.2 Check rhev-apt.exe status in guest
2.2.1 There is rhev-apt.exe under C:\ drive
2.2.2 rhev-apt has been installed in guest
2.2.3 Left click to open properties, click digital signatures->details-> view certificate, valid from 11/29/2015 to 12/29/2018

Verify result:
    Certificate of rhev-apt.exe is in the period of validity and and rhev-apt also can't be installed by default if v2v convert guest to rhv's export domain


Hi rjones,

    According to the introduction of rhev-apt in v2v man page,RHEV APT should be installed in the Windows guest during conversion. but this application can't be installed by default if v2v convert guest to rhv's export as above test result, pls refer to "rhev-apt-1.38.2-1.log", could you please help to confirm if it is a bug?

   And I have a question not related with this bug, guest's ipv4/ipv6/FDQN can be shown on rhv4.2 only when ovirt-guest-agent service is running in linux guest or rhv-guest-tools-iso is installed in windows guest, details pls refer to https://bugzilla.redhat.com/show_bug.cgi?id=1536937#c7, but v2v doesn't support installing this application during converting guests so far, do you think v2v needs to support this to improve guest performance on rhv? By the way,related packages could be found in " http://bob.eng.lab.tlv.redhat.com/builds/4.2/rhv-4.2.3-4/el7/noarch/ "

Thanks

Comment 6 mxie@redhat.com 2018-05-18 10:01:43 UTC
Created attachment 1438411 [details]
rhev-apt-1.38.2-1.log

Comment 7 Richard W.M. Jones 2018-05-30 12:00:28 UTC
(In reply to mxie@redhat.com from comment #5)
> Verify the bug with builds:
> virt-v2v-1.38.2-1.el7.x86_64
> libguestfs-1.38.2-1.el7.x86_64
> 
> Steps:
> Scenario1
...
> 1.3.2 rhev-apt is not installed by default in guest,pls refer to
> screenshot"rhev-apt-install-1.38.2-1"

I think I'm missing the screenshot.

However the command:

  net start

should show the rhev-apt service running.  If it does not, then
that's a bug.

...
>     According to the introduction of rhev-apt in v2v man page,RHEV APT
> should be installed in the Windows guest during conversion. but this
> application can't be installed by default if v2v convert guest to rhv's
> export as above test result, pls refer to "rhev-apt-1.38.2-1.log", could you
> please help to confirm if it is a bug?

From the log it does look as if rhev-apt was copied in, and also the
firstboot script was created
(c:/Program Files/Guestfs/Firstboot/scripts/0001-configure-rhev-apt.bat).
The script is supposed to start the rhev-apt service, hence "net start"
above should show the service is running after you've logged in.

>    And I have a question not related with this bug, guest's ipv4/ipv6/FDQN
> can be shown on rhv4.2 only when ovirt-guest-agent service is running in
> linux guest or rhv-guest-tools-iso is installed in windows guest, details
> pls refer to https://bugzilla.redhat.com/show_bug.cgi?id=1536937#c7, but v2v
> doesn't support installing this application during converting guests so far,
> do you think v2v needs to support this to improve guest performance on rhv?
> By the way,related packages could be found in "
> http://bob.eng.lab.tlv.redhat.com/builds/4.2/rhv-4.2.3-4/el7/noarch/ "

What's supposed to happen, as I understand it, is:

(1) We convert the guest and tell RHV that the OS type is Windows.

(2) For Windows guests, RHV will attach the RHV guest tools ISO automatically.

(3) Because rhev-apt is running it's supposed to see the ISO (as a CD) and
update things automatically.  This should include installing ovirt-guest-agent
and other things.

If one of these steps goes wrong then it won't work.

It's my understanding that we do not need to install ovirt-guest-agent
explicitly.

Comment 8 mxie@redhat.com 2018-05-31 12:40:07 UTC
> should show the rhev-apt service running.  If it does not, then
> that's a bug.
> 
> ...
> >     According to the introduction of rhev-apt in v2v man page,RHEV APT
> > should be installed in the Windows guest during conversion. but this
> > application can't be installed by default if v2v convert guest to rhv's
> > export as above test result, pls refer to "rhev-apt-1.38.2-1.log", could you
> > please help to confirm if it is a bug?
> 
> From the log it does look as if rhev-apt was copied in, and also the
> firstboot script was created
> (c:/Program Files/Guestfs/Firstboot/scripts/0001-configure-rhev-apt.bat).
> The script is supposed to start the rhev-apt service, hence "net start"
> above should show the service is running after you've logged in.

After v2v converting windows guest to rhv, there is no rhev-apt serivce running by executing command "net start" but there is 0001-configure-rhev-apt.bat in c:/Program Files/Guestfs/Firstboot/scripts-done/, so I have filed a new bug1584678 to track this problem

For ovirt-guest-agent, because it is not related to this bug,so I will send mail to explain my idea later,thanks

Comment 9 mxie@redhat.com 2018-06-06 12:04:12 UTC
Verify the bug with below builds:
virt-v2v-1.38.2-3.el7.x86_64
libguestfs-1.38.2-3.el7.x86_64
libvirt-4.3.0-1.el7.x86_64
qemu-kvm-rhev-2.12.0-3.el7.x86_64


Steps:
Scenario1:
1.1 Convert a win10 guest from ESXi6.5 to rhv4.2 by virt-v2v
# virt-v2v -i vmx esx6.5-win10-x86_64.vmx -o rhv -os 10.66.144.40:/home/nfs_export -of raw -b ovirtmgmt 

1.2 Import guest from export domain to data domain on rhv4.2 after finishing conversion

1.3 Check rhev-apt.exe status in guest
1.3.1 There is rhev-apt.exe under C:\ drive
1.3.2 Left click rhev-apt to open properties, click digital signatures->details-> view certificate, valid from 11/30/2015 to 12/30/2018
1.3.3 There is 0001-configure-rhev-apt.bat in c:/Program Files/Guestfs/Firstboot/scripts-done/
1.3.4 RHEV-apt service is running by command "net start" checking


Scenario2:
2.1 Convert a win2012r2 guest from ESXi6.7 to rhv4.2 by virt-v2v
# virt-v2v -i vmx esx6.7-win2012r2-x86_64.vmx -o rhv -os 10.66.144.40:/home/nfs_export -of qcow2 -b ovirtmgmt

2.2 Import guest from export domain to data domain on rhv4.2 after finishing conversion

2.3 Check rhev-apt.exe status in guest
2.3.1 There is rhev-apt.exe under C:\ drive
2.3.2 Left click rhev-apt to open properties, click digital signatures->details-> view certificate, valid from 11/29/2015 to 12/29/2018
2.3.3 There is 0001-configure-rhev-apt.bat in c:/Program Files/Guestfs/Firstboot/scripts-done/
2.3.4 RHEV-apt service is not running by command "net start" checking

Result:

  Certificate of rhev-apt.exe is in the period of validity in windows guests after v2v converting to rhv4.2 and rhev-apt service could be running in all windows guest except win2012r2 which has bug1584678 to track its problem, so move the bug from ON_QA to VERIFIED

Comment 11 errata-xmlrpc 2018-10-30 07:45:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3021


Note You need to log in before you can comment on or make changes to this bug.