Bug 1571332 - Update boom to new upstream release
Summary: Update boom to new upstream release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Bryn M. Reeves
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 14:29 UTC by Bryn M. Reeves
Modified: 2018-10-30 11:03 UTC (History)
9 users (show)

Fixed In Version: lvm2-2.02.179-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:02:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3193 0 None None None 2018-10-30 11:03:20 UTC

Description Bryn M. Reeves 2018-04-24 14:29:28 UTC
Description of problem:
The boom project has made several minor releases since the version packaged in rhel-7.5 (boom-0.8.2):

  https://github.com/bmr-cymru/boom/releases/tag/0.8.5

These include minor changes currently (particularly for legacy bootloader support, i.e. grub1 on RHEL6), but the project expects to make a new major release before rhel-7.6 which will include further enhancements and fixes relevant to RHEL customers.

Version-Release number of selected component (if applicable):
lvm2-2.02.177-1

How reproducible:
100%

Steps to Reproduce:
1. Check boom tarball in lvm2 SRPM


Actual results:
boom-0.8.2

Expected results:
boom > 0.8.5

Additional info:

Comment 3 Corey Marthaler 2018-08-13 21:13:38 UTC
Marking verified in the latest rpms.

3.10.0-931.el7.x86_64
lvm2-2.02.180-2.el7    BUILT: Wed Aug  1 11:22:48 CDT 2018
lvm2-libs-2.02.180-2.el7    BUILT: Wed Aug  1 11:22:48 CDT 2018
lvm2-cluster-2.02.180-2.el7    BUILT: Wed Aug  1 11:22:48 CDT 2018
lvm2-python-boom-0.9-5.el7    BUILT: Wed Aug  1 11:24:13 CDT 2018


SCENARIO - [boom_sanity]
Create a snapshot and perform some boom sanity only checks as this wont be an actual bootable snapshot
Making origin volume
lvcreate -L 300M snapper -n origin
Making snapshot of origin volume
lvcreate -s /dev/snapper/origin -c 128 -n boom_snap -L 100M

Check 1. Verify fake OS profiles are properly identified (Bug 1540266)
boom create --profile fake_profile --title title --version 3.10-272.el7 --rootlv snapper/boom_snap

Check 2. Verify --rootlv and --root-device varations are both accepted (Bug 1543188)
--rootlv: boom create --title 1 --rootlv /dev/snapper/boom_snap
boom list 968c9e9
BootID  Version                  Name                            RootDevice            
968c9e9 3.10.0-931.el7.x86_64    Red Hat Enterprise Linux Server /dev/snapper/boom_snap
boom delete 968c9e9

--root-lv: boom create --title 2 --root-lv /dev/snapper/boom_snap
boom list a84d726
BootID  Version                  Name                            RootDevice            
a84d726 3.10.0-931.el7.x86_64    Red Hat Enterprise Linux Server /dev/snapper/boom_snap
boom delete a84d726

--rootdevice: boom create --title 3 --rootdevice /dev/snapper/boom_snap
boom list b76596c
BootID  Version                  Name                            RootDevice            
b76596c 3.10.0-931.el7.x86_64    Red Hat Enterprise Linux Server /dev/snapper/boom_snap
boom delete b76596c

--root-device: boom create --title 4 --root-device /dev/snapper/boom_snap
boom list 9bbd2bd
BootID  Version                  Name                            RootDevice            
9bbd2bd 3.10.0-931.el7.x86_64    Red Hat Enterprise Linux Server /dev/snapper/boom_snap
boom delete 9bbd2bd

Check 3. Verify --root-lv and --root-device verify the lv/device exists (Bug 1543186)
boom create --title no-lv --root-lv snapper/nonlv
boom create --title no-dev --root-device /dev/sdxyz
boom create --title 5 --no-dev --root-lv snapper/nonlv
boom delete d0b40bf

Check 4. Verify proper use of user providing --rootlv /dev/* format (Bug 1544914)
boom create --title 6 --rootlv /dev/snapper/boom_snap
Created entry with boot_id f046ac7:
  title 6
  machine-id b2997c74acd84f6b9567dc43cc3db741
  version 3.10.0-931.el7.x86_64
  linux /vmlinuz-3.10.0-931.el7.x86_64
  initrd /initramfs-3.10.0-931.el7.x86_64.img
  options root=/dev/snapper/boom_snap ro rd.lvm.lv=snapper/boom_snap rhgb quiet
boom delete f046ac7

Check 5. Verify proper rd.lvm.lv entry w/ --root-device option (Also listed in Bug 1544914)
boom create --title 7 --root-device /dev/snapper/boom_snap
Created entry with boot_id 2cb40a4:
  title 7
  machine-id b2997c74acd84f6b9567dc43cc3db741
  version 3.10.0-931.el7.x86_64
  linux /vmlinuz-3.10.0-931.el7.x86_64
  initrd /initramfs-3.10.0-931.el7.x86_64.img
  options root=/dev/snapper/boom_snap ro rd.lvm.lv=snapper/boom_snap rhgb quiet
boom delete 2cb40a4

Removing volume snapper/boom_snap
Removing origin snapper/origin

Comment 5 errata-xmlrpc 2018-10-30 11:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3193


Note You need to log in before you can comment on or make changes to this bug.