Bug 1571503 - [abrt] cinnamon: onChanged(): cs_default.py:210:onChanged:AttributeError: 'NoneType' object has no attribute 'get_name'
Summary: [abrt] cinnamon: onChanged(): cs_default.py:210:onChanged:AttributeError: 'No...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 28
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2082dc678679b6fd25d24d1cb29...
: 1575033 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 02:49 UTC by Paul Montalvan
Modified: 2018-06-11 17:00 UTC (History)
4 users (show)

Fixed In Version: cinnamon-3.8.4-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-11 17:00:45 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (595 bytes, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: cgroup (318 bytes, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: cpuinfo (1.35 KB, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: environ (1.44 KB, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: mountinfo (3.50 KB, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details
File: open_fds (1.67 KB, text/plain)
2018-04-25 02:49 UTC, Paul Montalvan
no flags Details

Description Paul Montalvan 2018-04-25 02:49:00 UTC
Description of problem:
it  happens  sudenly 

Version-Release number of selected component:
cinnamon-3.6.8-0.3.20180219gitaee5bb1.fc28

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py default
crash_function: onChanged
exception_type: AttributeError
executable:     /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py
kernel:         4.16.0-0.rc4.git0.1.fc28.i686
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
cs_default.py:210:onChanged:AttributeError: 'NoneType' object has no attribute 'get_name'

Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/modules/cs_default.py", line 210, in onChanged
    print("%s: " % info.get_name())
AttributeError: 'NoneType' object has no attribute 'get_name'

Local variables in innermost frame:
info: None
button: <cs_default.DefaultAppChooserButton object at 0xaa12348c (cs_default+DefaultAppChooserButton at 0x25d0478)>
self: <cs_default.DefaultAppChooserButton object at 0xaa12348c (cs_default+DefaultAppChooserButton at 0x25d0478)>

Comment 1 Paul Montalvan 2018-04-25 02:49:06 UTC
Created attachment 1426333 [details]
File: backtrace

Comment 2 Paul Montalvan 2018-04-25 02:49:07 UTC
Created attachment 1426334 [details]
File: cgroup

Comment 3 Paul Montalvan 2018-04-25 02:49:08 UTC
Created attachment 1426335 [details]
File: cpuinfo

Comment 4 Paul Montalvan 2018-04-25 02:49:09 UTC
Created attachment 1426336 [details]
File: environ

Comment 5 Paul Montalvan 2018-04-25 02:49:11 UTC
Created attachment 1426337 [details]
File: mountinfo

Comment 6 Paul Montalvan 2018-04-25 02:49:13 UTC
Created attachment 1426338 [details]
File: namespaces

Comment 7 Paul Montalvan 2018-04-25 02:49:15 UTC
Created attachment 1426339 [details]
File: open_fds

Comment 8 zethan191 2018-05-04 15:12:32 UTC
*** Bug 1575033 has been marked as a duplicate of this bug. ***

Comment 9 outside_boi 2018-05-05 22:52:45 UTC
Similar problem has been detected:

I watched youtube videos and maybe typed something in a text document when I noticed I got a notice on opening a .png image file. The notice told me something along the lines of: "don't know how to open, open in text editor?"
I opened preferred applications and saw that "Music", "Videos" and "Photos" were set to "" aka nothing. When clicking the drop down I could select the standard applications but an error popped up. I clicked through the menus and ended up here.
Since installation of the OS I  added rpmfusion free repo and installed "compat-ffmpeg28". I also updated the system and tried to enable updates-testing repos multiple times but deselected it after getting erros in dnfdragora which I did not report. These error are gone after deselecting the repos againg btw.
I don't require a solution, I will try to troubleshoot this by internet searching, but I thought this might be interesting and can be attached to a known bug.
Thanks.

reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py default
crash_function: onChanged
exception_type: AttributeError
executable:     /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.5-300.fc28.x86_64
package:        cinnamon-3.8.1-1.fc28
reason:         cs_default.py:210:onChanged:AttributeError: 'NoneType' object has no attribute 'get_name'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 leigh scott 2018-05-06 00:09:07 UTC
Fixed upstream, cinnamon-3.8.2 will include the fix.

https://github.com/linuxmint/Cinnamon/commit/1dcae7b931f006f89a3cc0e595c24850a9a47eb3

Comment 11 Fedora Update System 2018-06-08 12:34:54 UTC
cinnamon-3.8.4-1.fc28 cinnamon-screensaver-3.8.2-1.fc28 cinnamon-menus-3.8.2-1.fc28 cinnamon-settings-daemon-3.8.3-1.fc28 muffin-3.8.2-1.fc28 nemo-3.8.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9c42f385b9

Comment 12 Fedora Update System 2018-06-09 22:03:30 UTC
cinnamon-3.8.4-1.fc28, cinnamon-menus-3.8.2-1.fc28, cinnamon-screensaver-3.8.2-1.fc28, cinnamon-settings-daemon-3.8.3-1.fc28, muffin-3.8.2-1.fc28, nemo-3.8.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9c42f385b9

Comment 13 Fedora Update System 2018-06-11 17:00:45 UTC
cinnamon-3.8.4-1.fc28, cinnamon-menus-3.8.2-1.fc28, cinnamon-screensaver-3.8.2-1.fc28, cinnamon-settings-daemon-3.8.3-1.fc28, muffin-3.8.2-1.fc28, nemo-3.8.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.