Bug 1575033 - [abrt] cinnamon: onChanged(): cs_default.py:210:onChanged:AttributeError: 'NoneType' object has no attribute 'get_name'
Summary: [abrt] cinnamon: onChanged(): cs_default.py:210:onChanged:AttributeError: 'No...
Keywords:
Status: CLOSED DUPLICATE of bug 1571503
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2082dc678679b6fd25d24d1cb29...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 15:12 UTC by zethan191
Modified: 2018-05-05 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 15:12:32 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (613 bytes, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: cgroup (331 bytes, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: cpuinfo (1.08 KB, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: environ (1.42 KB, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: mountinfo (3.47 KB, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: namespaces (129 bytes, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details
File: open_fds (4.30 KB, text/plain)
2018-05-04 15:12 UTC, zethan191
no flags Details

Description zethan191 2018-05-04 15:12:21 UTC
Description of problem:
I was installing vlc through the console and was using cinnamon setting at the same time. Maybe, they were waiting for one another. I am not so sure.

Version-Release number of selected component:
cinnamon-3.8.1-1.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py
crash_function: onChanged
exception_type: AttributeError
executable:     /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.5-300.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
cs_default.py:210:onChanged:AttributeError: 'NoneType' object has no attribute 'get_name'

Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/modules/cs_default.py", line 210, in onChanged
    print("%s: " % info.get_name())
AttributeError: 'NoneType' object has no attribute 'get_name'

Local variables in innermost frame:
info: None
button: <cs_default.DefaultAppChooserButton object at 0x7fa710d234c8 (cs_default+DefaultAppChooserButton at 0x555734546e60)>
self: <cs_default.DefaultAppChooserButton object at 0x7fa710d234c8 (cs_default+DefaultAppChooserButton at 0x555734546e60)>

This is a private, duplicate bug report of bug 1571503. The report has been created because Bugzilla cannot grant access to a comment for a specific group.

Comment 1 zethan191 2018-05-04 15:12:24 UTC
Created attachment 1431441 [details]
File: backtrace

Comment 2 zethan191 2018-05-04 15:12:26 UTC
Created attachment 1431442 [details]
File: cgroup

Comment 3 zethan191 2018-05-04 15:12:27 UTC
Created attachment 1431443 [details]
File: cpuinfo

Comment 4 zethan191 2018-05-04 15:12:28 UTC
Created attachment 1431444 [details]
File: environ

Comment 5 zethan191 2018-05-04 15:12:28 UTC
Created attachment 1431445 [details]
File: mountinfo

Comment 6 zethan191 2018-05-04 15:12:29 UTC
Created attachment 1431446 [details]
File: namespaces

Comment 7 zethan191 2018-05-04 15:12:31 UTC
Created attachment 1431447 [details]
File: open_fds

Comment 8 zethan191 2018-05-04 15:12:32 UTC

*** This bug has been marked as a duplicate of bug 1571503 ***


Note You need to log in before you can comment on or make changes to this bug.