Bug 1571547 - Update emulate512 in VDO section, to have 'on' for boolean true value
Summary: Update emulate512 in VDO section, to have 'on' for boolean true value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1571550
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-04-25 06:16 UTC by SATHEESARAN
Modified: 2018-11-08 05:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1571550 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:38:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 None None None 2018-11-08 05:39:26 UTC

Description SATHEESARAN 2018-04-25 06:16:03 UTC
Description of problem:
-----------------------
With the latest gdeploy, the value of 'enable' is not considered as boolean true.
This leads to failure in configuring VDO volume


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.2-26.el7rhgs

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. With the latest gdeploy, try to configure VDO via cockpit

Actual results:
----------------
Fails to configure VDO volume

Expected results:
-------------------
VDO volume should be configured successfully

Comment 1 SATHEESARAN 2018-04-25 06:19:03 UTC
Additional info:
----------------
Here is the VDO section in the config file:

[vdo1:10.70.45.32]
action=create
devices=sdb
names=vdo_sdb
logicalsize=164840G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=enabled           <---------- This should be 'on'
writepolicy=sync
ignore_vdo_errors=no
slabsize=32G

Here is the snip of the failure:

<snip>
TASK [Create VDO with specified size] ******************************************
failed: [10.70.45.32] (item={u'disk': u'/dev/sdb', u'logicalsize': u'164840G', u'name': u'vdo_sdb'}) => {"changed": false, "item": {"disk": "/dev/sdb", "logicalsize": "164840G", "name": "vdo_sdb"}, "msg": "The value 'enabled' is not a valid boolean.  Valid booleans include: 0, 'on', 'f', 'false', 1, 'no', 'n', '1', '0', 't', 'y', 'off', 'yes', 'true'"}
	to retry, use: --limit @/tmp/tmpkKu6Lm/vdo-create.retry

PLAY RECAP *********************************************************************
10.70.45.32                : ok=0    changed=0    unreachable=0    failed=1   
</snip>

Comment 2 SATHEESARAN 2018-04-25 06:35:20 UTC
Note: only emulate512 value should be changed to 'on'. Do **not** change value of readcache, as value for readcache can be only enabled or disabled

Comment 4 RHEL Program Management 2018-05-28 03:02:59 UTC
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 5 bipin 2018-05-28 09:47:30 UTC
Mistakenly removed qa_ack and acked it once again.
Observed that bugbot has automagically marked this bug as CLOSED - WONTFIX, correcting the same

Comment 11 errata-xmlrpc 2018-11-08 05:38:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.