Bug 1571550 - Update emulate512 in VDO section, to have 'on' for boolean true value
Summary: Update emulate512 in VDO section, to have 'on' for boolean true value
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Gobinda Das
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1571547 cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-04-25 06:21 UTC by SATHEESARAN
Modified: 2018-06-26 08:34 UTC (History)
7 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1571547
Environment:
Last Closed: 2018-06-26 08:34:44 UTC
oVirt Team: Gluster
sasundar: ovirt-4.2?
sasundar: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90615 0 master MERGED Updated VDO section emulate512 to on 2018-05-17 11:58:43 UTC
oVirt gerrit 91340 0 ovirt-4.2 MERGED Updated VDO section emulate512 to on 2018-05-17 12:01:03 UTC

Description SATHEESARAN 2018-04-25 06:21:36 UTC
+++ This bug was initially created as a clone of Bug #1571547 +++

Description of problem:
-----------------------
With the latest gdeploy, the value of 'enable' is not considered as boolean true.
This leads to failure in configuring VDO volume


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.2-26.el7rhgs

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. With the latest gdeploy, try to configure VDO via cockpit

Actual results:
----------------
Fails to configure VDO volume

Expected results:
-------------------
VDO volume should be configured successfully

Comment 1 SATHEESARAN 2018-04-25 06:21:57 UTC
Additional info:
----------------
Here is the VDO section in the config file:

[vdo1:10.70.45.32]
action=create
devices=sdb
names=vdo_sdb
logicalsize=164840G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=enabled           <---------- This should be 'on'
writepolicy=sync
ignore_vdo_errors=no
slabsize=32G

Here is the snip of the failure:

<snip>
TASK [Create VDO with specified size] ******************************************
failed: [10.70.45.32] (item={u'disk': u'/dev/sdb', u'logicalsize': u'164840G', u'name': u'vdo_sdb'}) => {"changed": false, "item": {"disk": "/dev/sdb", "logicalsize": "164840G", "name": "vdo_sdb"}, "msg": "The value 'enabled' is not a valid boolean.  Valid booleans include: 0, 'on', 'f', 'false', 1, 'no', 'n', '1', '0', 't', 'y', 'off', 'yes', 'true'"}
	to retry, use: --limit @/tmp/tmpkKu6Lm/vdo-create.retry

PLAY RECAP *********************************************************************
10.70.45.32                : ok=0    changed=0    unreachable=0    failed=1   
</snip>

Comment 2 SATHEESARAN 2018-04-25 06:34:40 UTC
Note: only emulate512 value should be changed to 'on'. Do **not** change value of readcache, as value for readcache can be only enabled or disabled

Comment 6 Sandro Bonazzola 2018-06-26 08:34:44 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.