Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1571963 - [upstream][v2v] Migration fails if the VM name is too long (65 characters in this case)
Summary: [upstream][v2v] Migration fails if the VM name is too long (65 characters in ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
Depends On:
Blocks: 1581749
TreeView+ depends on / blocked
 
Reported: 2018-04-25 19:37 UTC by Kedar Kulkarni
Modified: 2018-06-05 14:21 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1581749 (view as bug list)
Environment:
Last Closed: 2018-05-29 15:46:28 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (458.64 KB, image/png)
2018-04-25 19:37 UTC, Kedar Kulkarni
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/ManageIQ miq_v2v_ui_plugin issues 258 0 None None None 2018-05-22 14:13:26 UTC

Description Kedar Kulkarni 2018-04-25 19:37:23 UTC
Created attachment 1426829 [details]
Screenshot

Description of problem:
Trying to migrate VM with long name fails in state 5 (as per logs)

Version-Release number of selected component (if applicable):
master.20180424003235_96b2aa1

How reproducible:
Believe 100%

Steps to Reproduce:
1.Create a VMware VM with long name (65 characters) 
2.Setup MIQ appliance for migration
3.Try to migrate the VM 
4. see automation.log

Actual results:
VM is migrated to RHV but migration plan failed

Expected results:
Migration should not fail, as I believe up to 65 characters is VM name limit, if not please elaborate what is acceptable limit.

Additional info:

Comment 2 Brett Thurber 2018-04-29 06:03:51 UTC
Upstream issues created:  https://github.com/priley86/miq_v2v_ui_plugin/issues/258

Comment 3 Allen W 2018-04-30 16:07:23 UTC
OoooooOOOooOOoooo I'll jump on this one, we have a solution employed elsewhere in the app, truncate with ellipses and throw up a tooltip with the rest of the name...

Comment 4 Allen W 2018-04-30 16:11:43 UTC
yep comment for the wrong bz :sob: 

comment intended for https://bugzilla.redhat.com/show_bug.cgi?id=1571948

Comment 6 Kedar Kulkarni 2018-05-23 14:44:05 UTC
Cloned to https://bugzilla.redhat.com/show_bug.cgi?id=1581749

Closing with Insufficient data, since its not a bug for CFME.

Comment 7 Michal Skrivanek 2018-05-24 08:57:45 UTC
IIUC the current behavior is that when VM has >65 chars (same applies to unsupported chars) the migration succeeds but the VM cannot be started (as it is not supported by RHV)
The fix on RHV side is about properly fail such VM import

It will _not_ make it work as this bugs description assumes. There is a fix required on CFME side to follow the same validation as RHV has, or we need to agree on some reliable mapping from the original name - that's probably a bit more complicated as disks would need to be renamed as well and those are created by virt-v2v itself now.

Comment 8 Brett Thurber 2018-05-29 15:46:28 UTC
Don't expect this will be fixed in a planned release at this time.  Will revisit if it is identified as an issue or blocker with more tool usage.


Note You need to log in before you can comment on or make changes to this bug.