Bug 1571992 - 3.10.0-0.27.0: openshift_portal_net not honored - serviceNetworkCIDR in master-config.yaml does not have correct value
Summary: 3.10.0-0.27.0: openshift_portal_net not honored - serviceNetworkCIDR in mast...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Mike Fiedler
URL:
Whiteboard:
: 1566629 1575919 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 21:46 UTC by Mike Fiedler
Modified: 2018-07-30 19:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
inventory, ansible log, master-config (276.23 KB, application/x-gzip)
2018-04-25 21:48 UTC, Mike Fiedler
no flags Details
inventory to reproduce on 3.10.0-0.47.0 (6.17 KB, text/plain)
2018-05-16 17:11 UTC, Mike Fiedler
no flags Details
resulting master-config from 3.10.0-0.47.0 (5.96 KB, text/plain)
2018-05-16 17:11 UTC, Mike Fiedler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:10 UTC

Description Mike Fiedler 2018-04-25 21:46:41 UTC
Description of problem:

Installed a 3.10.0-0.27.0 cluster with the following network variables:

openshift_portal_net=172.24.0.0/14
osm_cluster_network_cidr=172.20.0.0/14

openshift-ansible runs successfully, but after the install master-config.yaml on the master contains the default for serviceNetworkCIDR:

networkConfig:
  clusterNetworkCIDR: 172.20.0.0/14
  clusterNetworks:
  - cidr: 172.20.0.0/14
    hostSubnetLength: 9
  externalIPNetworkCIDRs:
  - 0.0.0.0/0
  hostSubnetLength: 9
  networkPluginName: redhat/openshift-ovs-networkpolicy
  serviceNetworkCIDR: 172.30.0.0/16

Note that the osm_cluster_network value was picked up OK

Version-Release number of the following components:
root@ip-172-31-16-156: ~ # rpm -q openshift-ansible
openshift-ansible-3.10.0-0.27.0.git.0.abed3b7.el7.noarch
root@ip-172-31-16-156: ~ # rpm -q ansible
ansible-2.4.3.0-1.el7ae.noarch
root@ip-172-31-16-156: ~ # ansible --version
ansible 2.4.3.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Feb 20 2018, 09:19:12) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]


How reproducible: Not sure.  Using non-default openshift_portal_net seems to trigger it.

Steps to Reproduce:
1.  Install cluster with an inventory similar to the one attached (redacted to remove keys/passwords).


Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Attached -vvv log, inventory and master-config.yaml

Comment 1 Mike Fiedler 2018-04-25 21:48:17 UTC
Created attachment 1426879 [details]
inventory, ansible log, master-config

Comment 2 Scott Dodson 2018-05-02 14:17:53 UTC
*** Bug 1566629 has been marked as a duplicate of this bug. ***

Comment 3 Michael Gugino 2018-05-07 20:41:09 UTC
This appears to be a problem with the openshift_facts module.

PR Created: https://github.com/openshift/openshift-ansible/pull/8291

Comment 4 Russell Teague 2018-05-08 18:12:25 UTC
*** Bug 1575919 has been marked as a duplicate of this bug. ***

Comment 6 Mike Fiedler 2018-05-16 17:10:30 UTC
Problem still occurs using openshift-ansible 3.10.0-0.47.0 from May 15th

openshift-ansible.noarch        3.10.0-0.47.0.git.0.c018c8f.el7
openshift-ansible-docs.noarch   3.10.0-0.47.0.git.0.c018c8f.el7
openshift-ansible-playbooks.noarch
openshift-ansible-roles.noarch  3.10.0-0.47.0.git.0.c018c8f.el7


Using the attached inventory file, master-config.yaml still gets serviceNetworkCIDR of  serviceNetworkCIDR: 172.30.0.0/16

Comment 7 Mike Fiedler 2018-05-16 17:11:08 UTC
Created attachment 1437487 [details]
inventory to reproduce on 3.10.0-0.47.0

Comment 8 Mike Fiedler 2018-05-16 17:11:45 UTC
Created attachment 1437488 [details]
resulting master-config from 3.10.0-0.47.0

Comment 9 Mike Fiedler 2018-05-16 18:33:00 UTC
I installed using latest master branch out of git and hit the same issue.

commit df2c352a98465fe28340680b19fb141f7567eea4
Merge: d27fb63 91f78b9

Comment 10 Michael Gugino 2018-05-16 19:06:15 UTC
Possible Fix: https://github.com/openshift/openshift-ansible/pull/8394

Comment 11 Michael Gugino 2018-05-21 18:34:25 UTC
Mike, please let me know if the latest resolves the issue.

Comment 12 Mike Fiedler 2018-05-22 14:53:36 UTC
Verified on 3.10.0-0.50.0 - serviceNetworkCIDR has the specified value.

Comment 14 errata-xmlrpc 2018-07-30 19:13:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.