Bug 1575919 - set ansible option openshift_portal_net but it always use default value
Summary: set ansible option openshift_portal_net but it always use default value
Keywords:
Status: CLOSED DUPLICATE of bug 1571992
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 09:54 UTC by Hongan Li
Modified: 2018-05-08 18:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 18:12:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
installation log with inventory file (4.08 MB, text/plain)
2018-05-08 09:54 UTC, Hongan Li
no flags Details

Description Hongan Li 2018-05-08 09:54:58 UTC
Created attachment 1433112 [details]
installation log with inventory file

Description of problem:
configure openshift-ansible option 'openshift_portal_net: "172.30.0.0/20"' when launch flexy job, but the serviceNetworkCIDR still use the default value "172.30.0.0/16" after installation.   

Version-Release number of the following components:
openshift-ansible-3.10.0-0.36.0.git.0.521f0ef.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Set openshift_portal_net: "172.30.0.0/20" then trigger installation
2.
3.

Actual results:
# oc get clusternetwork 
NAME      CLUSTER NETWORKS   SERVICE NETWORK   PLUGIN NAME
default   10.128.0.0/16:14   172.30.0.0/16     redhat/openshift-ovs-subnet


Expected results:
Service Network should use the pre-configured option: 172.30.0.0/20.

Additional info:
1. full installation log attached.
2. no this issue in 3.9.

Comment 1 Russell Teague 2018-05-08 18:12:25 UTC

*** This bug has been marked as a duplicate of bug 1571992 ***


Note You need to log in before you can comment on or make changes to this bug.