Bug 1572251 - Keystone::Resource::Authtoken[neutron_config]: has no parameter named 'www_authenticate_uri'
Summary: Keystone::Resource::Authtoken[neutron_config]: has no parameter named 'www_au...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-keystone
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 14.0 (Rocky)
Assignee: Alfredo Moralejo
QA Contact: Filip Hubík
URL:
Whiteboard:
: 1573964 (view as bug list)
Depends On:
Blocks: 1573964
TreeView+ depends on / blocked
 
Reported: 2018-04-26 14:04 UTC by Filip Hubík
Modified: 2019-01-11 11:49 UTC (History)
7 users (show)

Fixed In Version: puppet-keystone-13.0.1-0.20180430171302.88a9e79.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1573964 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:49:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
packstack answerfile (51.09 KB, text/plain)
2018-04-26 14:04 UTC, Filip Hubík
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:58 UTC

Description Filip Hubík 2018-04-26 14:04:55 UTC
Created attachment 1427250 [details]
packstack answerfile

Description of problem:
Packstack deployment of OSP14 fails during step "packstack --debug --answer-file=/root/packstack_config.txt":

2018-04-26 05:49:50.517 | Preparing Puppet manifests                           [ DONE ]
2018-04-26 05:49:50.519 | Copying Puppet modules and manifests                 [ DONE ]
2018-04-26 05:49:50.520 | Applying 172.16.1.22_controller.pp
2018-04-26 05:49:50.522 | 
172.16.1.22_controller.pp:                        [ ERROR ]
2018-04-26 05:49:50.524 | Applying Puppet manifests                         [ ERROR ]
2018-04-26 05:49:50.525 | 
2018-04-26 05:49:50.527 | ERROR : Error appeared during Puppet run: 172.16.1.22_controller.pp
2018-04-26 05:49:50.528 | Error: Evaluation Error: Error while evaluating a Resource Statement, Keystone::Resource::Authtoken[neutron_config]: has no parameter named 'www_authenticate_uri'  at /var/tmp/packstack/b84546fdd9e645b2bea00970e172965e/modules/neutron/manifests/keystone/authtoken.pp:237 on node 188171795f92aee14d2a4bb734d6786c-aio-0.openstacklocal
2018-04-26 05:49:50.530 | You will find full trace in log /var/tmp/packstack/20180426-054826-gRHgOA/manifests/172.16.1.22_controller.pp.log
2018-04-26 05:49:50.531 | Please check log file /var/tmp/packstack/20180426-054826-gRHgOA/openstack-setup.log for more information
2018-04-26 05:49:50.533 | Additional information:
2018-04-26 05:49:50.535 |  * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
2018-04-26 05:49:50.536 |  * Warning: NetworkManager is active on 172.16.1.22. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
2018-04-26 05:49:50.538 |  * File /root/keystonerc_admin has been created on OpenStack client host 172.16.1.22. To use the command line tools you need to source the file.
2018-04-26 05:49:50.540 |  * To access the OpenStack Dashboard browse to http://172.16.1.22/dashboard .
2018-04-26 05:49:50.541 | Please, find your login credentials stored in the keystonerc_admin in your home directory.
2018-04-26 05:49:50.543 |  * Note temporary directory /var/tmp/packstack/b84546fdd9e645b2bea00970e172965e on host 172.16.1.22 was not deleted for debugging purposes.

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP14 using packstack, neutron, vxlan, rabbitmq, e.g. using InfraRed:
$ infrared packstack -v     -o install.yml     --version=14     --build=2018-04-26.1     --network-service=neutron     --network-variant=neutron_ml2-vxlan     --messaging-variant=rabbitmq

Actual results:
Deployment fails

Additional info:
rpm -qa | grep -E '(stack)'
puppet-openstacklib-12.4.0-0.20180329042555.4b30e6f.el7ost.noarch
puppet-openstack_extras-12.4.0-0.20180329042116.4393da9.el7ost.noarch
openstack-packstack-puppet-13.0.0-0.20180413234313.e0dca01.el7ost.noarch
openstack-packstack-13.0.0-0.20180413234313.e0dca01.el7ost.noarch

packstack_config.txt attached

Comment 2 Filip Hubík 2018-04-30 13:05:04 UTC
Verified in CI as the same deployment passed with puppet-keystone-12.4.0-0.20180329034741.b6d2197.el7ost present.

Also, this issue appeared in early builds of OSP14 director deployments during undercloud install, I suspect it was resolved by correct re-import made there sooner.

Comment 6 Alex Schultz 2018-05-03 14:48:35 UTC
*** Bug 1573964 has been marked as a duplicate of this bug. ***

Comment 7 Alex Schultz 2018-05-03 14:58:33 UTC
Yea so it seems we got the queens package instead of the Rocky one. We need puppet-keystone-13.0.0 for osp14. That would be the Rocky m1 release which will have this fix

Comment 9 Filip Hubík 2018-05-18 13:13:54 UTC
Verified by CI since packstack and director jobs are passing undercloud install stage with package puppet-keystone-13.0.1-0.20180430171302.88a9e79.el7os is included in such deployments.

Comment 12 errata-xmlrpc 2019-01-11 11:49:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.