Bug 1573964 - Keystone::Resource::Authtoken[glance_api_config]: has no parameter named 'www_authenticate_uri'
Summary: Keystone::Resource::Authtoken[glance_api_config]: has no parameter named 'www...
Keywords:
Status: CLOSED DUPLICATE of bug 1572251
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-keystone
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: ---
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1572251
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 15:28 UTC by Filip Hubík
Modified: 2018-08-03 18:34 UTC (History)
11 users (show)

Fixed In Version: puppet-keystone-13.0.1-0.20180430171302.88a9e79.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1572251
Environment:
Last Closed: 2018-05-03 14:48:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Filip Hubík 2018-05-02 15:28:55 UTC
+++ This bug was initially created as a clone of Bug #1572251 +++

This issue also reproduced in director deployment during undercloud install stage (probably means that puppet-keystone-12.4.0-0.20180329034741.b6d2197.el7ost was not included in import, appeared since puddle 2018-04-30.2):

2018-05-02 17:25:56.018 | 2018-05-02 10:25:53,317 INFO: Warning: Unknown variable: '::mistral::database_retry_interval'. at /etc/puppet/modules/mistral/manifests/db.pp:66:40
2018-05-02 17:25:56.020 | 2018-05-02 10:25:53,318 INFO: Warning: Unknown variable: '::mistral::database_max_overflow'. at /etc/puppet/modules/mistral/manifests/db.pp:67:40
2018-05-02 17:25:56.022 | 2018-05-02 10:25:53,358 INFO: Warning: Scope(Class[Mistral::Keystone::Authtoken]): The auth_uri parameter is deprecated. Please use www_authenticate_uri instead.
2018-05-02 17:25:56.023 | 2018-05-02 10:25:53,361 INFO: Warning: Scope(Class[Mistral]): mistral::rabbit_host, mistral::rabbit_hosts, mistral::rabbit_password, mistral::rabbit_port, mistral::rabbit_userid, mistral::rabbit_virtual_host and mistral::rpc_backend are deprecated. Please use mistral::default_transport_url instead.
2018-05-02 17:25:56.025 | 2018-05-02 10:25:53,565 INFO: Warning: ModuleLoader: module 'zaqar' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules
2018-05-02 17:25:56.027 | 2018-05-02 10:25:53,565 INFO:    (file & line not available)
2018-05-02 17:25:56.029 | 2018-05-02 10:25:53,645 INFO: Warning: Scope(Class[Zaqar::Keystone::Authtoken]): The auth_uri parameter is deprecated. Please use www_authenticate_uri instead.
2018-05-02 17:25:56.031 | 2018-05-02 10:25:54,372 INFO: Warning: ModuleLoader: module 'oslo' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules
2018-05-02 17:25:56.032 | 2018-05-02 10:25:54,372 INFO:    (file & line not available)
2018-05-02 17:25:56.034 | 2018-05-02 10:25:54,440 INFO: Warning: Scope(Oslo::Messaging::Rabbit[keystone_config]): The oslo_messaging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
2018-05-02 17:25:56.036 | 2018-05-02 10:25:55,172 INFO: Error: Evaluation Error: Error while evaluating a Resource Statement, Keystone::Resource::Authtoken[glance_api_config]: has no parameter named 'www_authenticate_uri'  at /etc/puppet/modules/glance/manifests/api/authtoken.pp:237 on node undercloud-0.redhat.local
2018-05-02 17:25:56.038 | 2018-05-02 10:25:55,230 INFO: + rc=1
2018-05-02 17:25:56.039 | 2018-05-02 10:25:55,230 INFO: + set -e
2018-05-02 17:25:56.041 | 2018-05-02 10:25:55,230 INFO: + echo 'puppet apply exited with exit code 1'
2018-05-02 17:25:56.043 | 2018-05-02 10:25:55,230 INFO: puppet apply exited with exit code 1
2018-05-02 17:25:56.045 | 2018-05-02 10:25:55,230 INFO: + '[' 1 '!=' 2 -a 1 '!=' 0 ']'
2018-05-02 17:25:56.046 | 2018-05-02 10:25:55,230 INFO: + exit 1
2018-05-02 17:25:56.048 | 2018-05-02 10:25:55,236 INFO: [2018-05-02 10:25:55,230] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2018-05-02 17:25:56.050 | 2018-05-02 10:25:55,236 INFO: 
2018-05-02 17:25:56.052 | 2018-05-02 10:25:55,236 INFO: [2018-05-02 10:25:55,231] (os-refresh-config) [ERROR] Aborting...
2018-05-02 17:25:56.053 | 2018-05-02 10:25:55,238 DEBUG: An exception occurred
2018-05-02 17:25:56.055 | Traceback (most recent call last):
2018-05-02 17:25:56.057 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2330, in install
2018-05-02 17:25:56.059 |     _run_orc(instack_env)
2018-05-02 17:25:56.499 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1597, in _run_orc
2018-05-02 17:25:56.501 |     _run_live_command(args, instack_env, 'os-refresh-config')
2018-05-02 17:25:56.503 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 676, in _run_live_command
2018-05-02 17:25:56.505 |     raise RuntimeError('%s failed. See log for details.' % name)
2018-05-02 17:25:56.506 | RuntimeError: os-refresh-config failed. See log for details.
2018-05-02 17:25:56.508 | 2018-05-02 10:25:55,239 ERROR: 
2018-05-02 17:25:56.510 | #############################################################################
2018-05-02 17:25:56.512 | Undercloud install failed.


+++ This bug was initially created as a clone of Bug #1572251 +++
(since first it appeared in packstack deployment)

Description of problem:
Packstack deployment of OSP14 fails during step "packstack --debug --answer-file=/root/packstack_config.txt":

2018-04-26 05:49:50.517 | Preparing Puppet manifests                           [ DONE ]
2018-04-26 05:49:50.519 | Copying Puppet modules and manifests                 [ DONE ]
2018-04-26 05:49:50.520 | Applying 172.16.1.22_controller.pp
2018-04-26 05:49:50.522 | 
172.16.1.22_controller.pp:                        [ ERROR ]
2018-04-26 05:49:50.524 | Applying Puppet manifests                         [ ERROR ]
2018-04-26 05:49:50.525 | 
2018-04-26 05:49:50.527 | ERROR : Error appeared during Puppet run: 172.16.1.22_controller.pp
2018-04-26 05:49:50.528 | Error: Evaluation Error: Error while evaluating a Resource Statement, Keystone::Resource::Authtoken[neutron_config]: has no parameter named 'www_authenticate_uri'  at /var/tmp/packstack/b84546fdd9e645b2bea00970e172965e/modules/neutron/manifests/keystone/authtoken.pp:237 on node 188171795f92aee14d2a4bb734d6786c-aio-0.openstacklocal
2018-04-26 05:49:50.530 | You will find full trace in log /var/tmp/packstack/20180426-054826-gRHgOA/manifests/172.16.1.22_controller.pp.log
2018-04-26 05:49:50.531 | Please check log file /var/tmp/packstack/20180426-054826-gRHgOA/openstack-setup.log for more information
2018-04-26 05:49:50.533 | Additional information:
2018-04-26 05:49:50.535 |  * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
2018-04-26 05:49:50.536 |  * Warning: NetworkManager is active on 172.16.1.22. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
2018-04-26 05:49:50.538 |  * File /root/keystonerc_admin has been created on OpenStack client host 172.16.1.22. To use the command line tools you need to source the file.
2018-04-26 05:49:50.540 |  * To access the OpenStack Dashboard browse to http://172.16.1.22/dashboard .
2018-04-26 05:49:50.541 | Please, find your login credentials stored in the keystonerc_admin in your home directory.
2018-04-26 05:49:50.543 |  * Note temporary directory /var/tmp/packstack/b84546fdd9e645b2bea00970e172965e on host 172.16.1.22 was not deleted for debugging purposes.

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP14 using packstack, neutron, vxlan, rabbitmq, e.g. using InfraRed:
$ infrared packstack -v     -o install.yml     --version=14     --build=2018-04-26.1     --network-service=neutron     --network-variant=neutron_ml2-vxlan     --messaging-variant=rabbitmq

Actual results:
Deployment fails

Additional info:
rpm -qa | grep -E '(stack)'
puppet-openstacklib-12.4.0-0.20180329042555.4b30e6f.el7ost.noarch
puppet-openstack_extras-12.4.0-0.20180329042116.4393da9.el7ost.noarch
openstack-packstack-puppet-13.0.0-0.20180413234313.e0dca01.el7ost.noarch
openstack-packstack-13.0.0-0.20180413234313.e0dca01.el7ost.noarch

packstack_config.txt attached

Comment 3 Alex Schultz 2018-05-02 15:40:56 UTC
This should have been fixed with puppet-keystone-12.4.0-0.20180329034741.b6d2197.el7ost as it's the same error

Comment 4 Filip Hubík 2018-05-03 11:00:22 UTC
(In reply to Alex Schultz from comment #3)
> This should have been fixed with
> puppet-keystone-12.4.0-0.20180329034741.b6d2197.el7ost as it's the same error

As my colleagues pointed out, looks like it is not fixed by this package as puppet-keystone-12.4.0-0.20180329034741.b6d2197.el7ost is present in current deployments and deployments fail with same issue.

Comment 7 Alex Schultz 2018-05-03 14:48:35 UTC
It's a dupe, let's deal with the original bug

*** This bug has been marked as a duplicate of bug 1572251 ***


Note You need to log in before you can comment on or make changes to this bug.