Bug 1572557 - The dropdown for hosts under create volume(gluster deployment) in day two operations contain a single host name.
Summary: The dropdown for hosts under create volume(gluster deployment) in day two ope...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: Mugdha Soni
URL:
Whiteboard:
Depends On: 1572558
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-04-27 10:21 UTC by Mugdha Soni
Modified: 2018-11-13 09:32 UTC (History)
3 users (show)

Fixed In Version: cockpit-ovirt-0.11.25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1572558 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:38:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of host drop down (124.42 KB, image/png)
2018-04-27 10:21 UTC, Mugdha Soni
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 0 None None None 2018-11-08 05:39:26 UTC

Description Mugdha Soni 2018-04-27 10:21:48 UTC
Created attachment 1427609 [details]
screenshot of host drop down

Description of problem:
----------------------------------------------
In day two operations of cockpit while creating extra volume , user cannot configure the hosts properly in gluster deployment. The host tab was a dropdown with only one hostname where as the host name cannot be same for the three hosts.

Version-Release number of selected component (if applicable):
------------------------------------------------
cockpit-ovirt-dashboard-0.11.21-1.el7ev.noarch

How reproducible:
-----------------------------------------------
Everytime

Steps to Reproduce:
-----------------------------------------------
1.Login to the cockpit UI and configure all the tabs required for gluster deployment.

2.After the successful gluster deployment,configure all the tabs for hosted engine deployment.

3.After the hostedengine deployment is successful ,in the cockpit UI under the hosted engine tab there is a button to manage gluster .

4.Click on manage gluster button and then 'create volume'.

5.When clicked on ' create volume ' , under the hosts tab in gluster deployment the drop down contains only one host name.


Actual results:
----------------------------------------------
The host drop down has a single host name .
Expected results:
----------------------------------------------
The host drop down in hosts tab under gluster deployment should have another two host name as well.


Additional info:
-----------------------------------------------
The host name should be taken as the IP rather than the host name.

Comment 2 SATHEESARAN 2018-06-01 07:54:42 UTC
@Gobind, could you provide devel_ack on this bug ?

Comment 3 Mugdha Soni 2018-06-01 10:33:42 UTC
Tested with following :-

(i) redhat-release-virtualization-host-4.2-3.0.el7.x86_64
(ii) gdeploy-2.0.2-27.el7rhgs.noarch
(iii) cockpit-ovirt-dashboard-0.11.999-0.0.master.el7.noarch.rpm

Following are the steps performed for testing:-
(i) Successfully deployed gluster and hosted engine.

(ii)Reached out to gluster manaegement wizard via hosted engine and clicked on 
    create volume button.

(iii)After clicking on create volume button ,under the hosts tab in gluster 
     deployment ,user can find dropdown with all the host names which is             
     editable.

Comment 8 errata-xmlrpc 2018-11-08 05:38:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.