Bug 1572558 - The dropdown for hosts under create volume(gluster deployment) in day two operations contain a single host name.
Summary: The dropdown for hosts under create volume(gluster deployment) in day two ope...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.20
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Gobinda Das
QA Contact: Mugdha Soni
URL:
Whiteboard:
Depends On:
Blocks: 1572557 cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-04-27 10:23 UTC by Mugdha Soni
Modified: 2018-06-26 08:38 UTC (History)
6 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1572557
Environment:
Last Closed: 2018-06-26 08:38:01 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
rule-engine: blocker?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90766 0 master MERGED Showing all hosts in dropdown for create volume 2018-05-17 12:09:00 UTC
oVirt gerrit 91348 0 ovirt-4.2 MERGED Showing all hosts in dropdown for create volume 2018-05-17 12:09:16 UTC

Comment 1 Sahina Bose 2018-04-27 10:46:20 UTC
Description of problem:
----------------------------------------------
In day two operations of cockpit while creating extra volume , user cannot configure the hosts properly in gluster deployment. The host tab was a dropdown with only one hostname where as the host name cannot be same for the three hosts.

Version-Release number of selected component (if applicable):
------------------------------------------------
cockpit-ovirt-dashboard-0.11.21-1.el7ev.noarch

How reproducible:
-----------------------------------------------
Everytime

Steps to Reproduce:
-----------------------------------------------
1.Login to the cockpit UI and configure all the tabs required for gluster deployment.

2.After the successful gluster deployment,configure all the tabs for hosted engine deployment.

3.After the hostedengine deployment is successful ,in the cockpit UI under the hosted engine tab there is a button to manage gluster .

4.Click on manage gluster button and then 'create volume'.

5.When clicked on ' create volume ' , under the hosts tab in gluster deployment the drop down contains only one host name.


Actual results:
----------------------------------------------
The host drop down has a single host name .
Expected results:
----------------------------------------------
The host drop down in hosts tab under gluster deployment should have another two host name as well.

Comment 2 SATHEESARAN 2018-04-27 13:04:53 UTC
This prevents us testing creation of new volume from cockpit

Comment 3 Red Hat Bugzilla Rules Engine 2018-04-27 13:04:59 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 4 Red Hat Bugzilla Rules Engine 2018-05-31 12:55:23 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Mugdha Soni 2018-06-01 10:34:20 UTC
Tested with following :-

(i) redhat-release-virtualization-host-4.2-3.0.el7.x86_64
(ii) gdeploy-2.0.2-27.el7rhgs.noarch
(iii) cockpit-ovirt-dashboard-0.11.999-0.0.master.el7.noarch.rpm

Following are the steps performed for testing:-
(i) Successfully deployed gluster and hosted engine.

(ii)Reached out to gluster manaegement wizard via hosted engine and clicked on 
    create volume button.

(iii)After clicking on create volume button ,under the hosts tab in gluster 
     deployment ,user can find dropdown with all the host names which is             
     editable.

Comment 6 Sandro Bonazzola 2018-06-26 08:38:01 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.