Bug 1572800 - Python-TroveClient causes Horizon to throw error 500
Summary: Python-TroveClient causes Horizon to throw error 500
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-trove-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: ---
Assignee: Beth White
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 22:09 UTC by Jason E. Rist
Modified: 2018-05-04 09:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 09:49:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1767520 0 None None None 2018-04-27 22:09:04 UTC

Description Jason E. Rist 2018-04-27 22:09:02 UTC
Cloned from launchpad bug 1767520.

Description:

Description
===========
In a vanilla installation of TripleO Queens using Docker horizon will return with error 500 after a "successful" deployment.

Steps to reproduce
==================
1. Deploy undercloud according to the documentation at https://docs.openstack.org/tripleo-docs/latest/install/index.html
2. Create environment files: http://paste.openstack.org/show/720052/
3. Run the following command to deploy overcloud:

/bin/openstack overcloud deploy --templates /home/stack/tripleo-heat-templates -e /home/stack/tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/tripleo-heat-templates/environments/net-bond-with-vlans.yaml -e /home/stack/bond-with-vlans.yaml  -e tripleo-heat-templates/environments/docker.yaml -e tripleo-heat-templates/environments/docker-ha.yaml --ntp-server 172.18.0.2 --control-scale 3 --compute-scale 1  --control-flavor control --compute-flavor compute --swift-storage-flavor swift-storage
4. ssh to the controller which has the external VIP
5. View the logs at /var/log/containers/horizon/horizon.log

Expected result
===============
The dashboard presents a login screen

Actual result
=============
The dashboard returned an error 500 when browsing to the external VIP

Environment
===========
1. Exact version of OpenStack you are running. See the following
  Queens

2. Which storage type did you use?
   Ceph

3. Which networking type did you use?
   Neutron with Openvswitch

Logs & Configs
==============
/var/log/containers/horizon/horizon.log
http://paste.openstack.org/show/720050/

Specification URL (additional information):

https://bugs.launchpad.net/tripleo/+bug/1767520

Comment 1 Jason E. Rist 2018-04-27 22:14:38 UTC
This looks like it might be a blocker for 13.  Requesting analysis.

Comment 4 Radomir Dopieralski 2018-05-04 09:13:55 UTC
When I try to install packstack with trove enabled, I get:

    Package openstack-trove-ui has not been found in enabled Yum repos.

Do we even support it?

Comment 5 Luigi Toscano 2018-05-04 09:44:59 UTC
Trove is not supported on Red Hat OpenStack Platform.

https://bugzilla.redhat.com/show_bug.cgi?id=1346936
https://bugzilla.redhat.com/show_bug.cgi?id=1346395

Comment 6 Radomir Dopieralski 2018-05-04 09:49:16 UTC
Thanks, I'm closing this bug then.


Note You need to log in before you can comment on or make changes to this bug.