Bug 1572805 - [abrt] systemd-udev: socket(): systemd-udevd killed by SIGABRT
Summary: [abrt] systemd-udev: socket(): systemd-udevd killed by SIGABRT
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:529a2cf1d5fc9bd062df0e83291...
: 1572915 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 22:56 UTC by Paul DeStefano
Modified: 2018-07-18 14:09 UTC (History)
20 users (show)

Fixed In Version: 4.17.0-0.rc3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 11:04:57 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (8.47 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: cgroup (323 bytes, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: core_backtrace (1.92 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: cpuinfo (1.13 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: dso_list (3.58 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: environ (317 bytes, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: maps (16.02 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: mountinfo (4.03 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: open_fds (2.49 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details
File: proc_pid_status (1.20 KB, text/plain)
2018-04-27 22:56 UTC, Paul DeStefano
no flags Details

Description Paul DeStefano 2018-04-27 22:56:22 UTC
Description of problem:
Happend coming out of suspend.  I pressed a key to start login anticipating the lock screen, but I dont' think I ever saw the login screen.

Version-Release number of selected component:
systemd-udev-238-7.fc29.1

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-udevd
crash_function: socket
executable:     /usr/lib/systemd/systemd-udevd
journald_cursor: s=4f2735064a26480084f2f517b62dc1f1;i=8b;b=227f112d8a3547cf9a77afd248fa04b2;m=656d27fcbc;t=56adc25cbccb5;x=c5c774b7b883cfb8
kernel:         4.17.0-0.rc1.git3.1.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 socket at ../sysdeps/unix/syscall-template.S:78
 #1 sd_pid_notify_with_fds at ../src/libsystemd/sd-daemon/sd-daemon.c:508
 #2 sd_notify at ../src/libsystemd/sd-daemon/sd-daemon.c:595
 #3 process_watchdog at ../src/libsystemd/sd-event/sd-event.c:2479
 #4 sd_event_wait at ../src/libsystemd/sd-event/sd-event.c:2605
 #5 sd_event_run at ../src/libsystemd/sd-event/sd-event.c:2720
 #6 sd_event_loop at ../src/libsystemd/sd-event/sd-event.c:2748
 #7 run at ../src/udev/udevd.c:1633

Comment 1 Paul DeStefano 2018-04-27 22:56:28 UTC
Created attachment 1427875 [details]
File: backtrace

Comment 2 Paul DeStefano 2018-04-27 22:56:29 UTC
Created attachment 1427876 [details]
File: cgroup

Comment 3 Paul DeStefano 2018-04-27 22:56:30 UTC
Created attachment 1427877 [details]
File: core_backtrace

Comment 4 Paul DeStefano 2018-04-27 22:56:31 UTC
Created attachment 1427878 [details]
File: cpuinfo

Comment 5 Paul DeStefano 2018-04-27 22:56:32 UTC
Created attachment 1427879 [details]
File: dso_list

Comment 6 Paul DeStefano 2018-04-27 22:56:33 UTC
Created attachment 1427880 [details]
File: environ

Comment 7 Paul DeStefano 2018-04-27 22:56:34 UTC
Created attachment 1427881 [details]
File: limits

Comment 8 Paul DeStefano 2018-04-27 22:56:35 UTC
Created attachment 1427882 [details]
File: maps

Comment 9 Paul DeStefano 2018-04-27 22:56:36 UTC
Created attachment 1427883 [details]
File: mountinfo

Comment 10 Paul DeStefano 2018-04-27 22:56:37 UTC
Created attachment 1427884 [details]
File: open_fds

Comment 11 Paul DeStefano 2018-04-27 22:56:38 UTC
Created attachment 1427885 [details]
File: proc_pid_status

Comment 12 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:04:57 UTC
This is most likely a fake watchdog hit that resulted from a kernel change that was introduced in kernel 4.17-rc1 and reverted soon after that (https://github.com/torvalds/linux/commit/a3ed0e4393). Fixed by subsequent kernel updates.

Comment 13 Zbigniew Jędrzejewski-Szmek 2018-07-18 14:09:34 UTC
*** Bug 1572915 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.