Bug 1572915 - [abrt] systemd: __libc_openat64(): systemd-logind killed by SIGABRT
Summary: [abrt] systemd: __libc_openat64(): systemd-logind killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1572805
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bd3b25495c3b36f7982d2877bbd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 17:46 UTC by Paul DeStefano
Modified: 2018-07-18 14:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 11:20:15 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (14.86 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: cgroup (328 bytes, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: core_backtrace (4.08 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: cpuinfo (1.13 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: dso_list (3.34 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: environ (217 bytes, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: maps (14.65 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: mountinfo (4.03 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: open_fds (3.69 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: proc_pid_status (1.21 KB, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details
File: var_log_messages (941 bytes, text/plain)
2018-04-28 17:46 UTC, Paul DeStefano
no flags Details

Description Paul DeStefano 2018-04-28 17:46:28 UTC
Description of problem:
This occured after coming out of suspend.  I think I saw the lock screen but it crashed immediately after that.

Version-Release number of selected component:
systemd-238-7.fc29.1

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-logind
crash_function: __libc_openat64
executable:     /usr/lib/systemd/systemd-logind
journald_cursor: s=4f2735064a26480084f2f517b62dc1f1;i=8d;b=227f112d8a3547cf9a77afd248fa04b2;m=656d284f99;t=56adc25cc1f92;x=2e23220d763d47ad
kernel:         4.17.0-0.rc1.git3.1.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __libc_openat64 at ../sysdeps/unix/sysv/linux/openat64.c:45
 #1 openat64 at /usr/include/bits/fcntl2.h:129
 #2 chase_symlinks at ../src/basic/fs-util.c:720
 #3 device_set_syspath at ../src/libsystemd/sd-device/sd-device.c:169
 #4 sd_device_new_from_syspath at ../src/libsystemd/sd-device/sd-device.c:249
 #5 enumerator_scan_dir_and_add_devices at ../src/libsystemd/sd-device/device-enumerator.c:504
 #6 enumerator_scan_dir at ../src/libsystemd/sd-device/device-enumerator.c:612
 #7 enumerator_scan_devices_all at ../src/libsystemd/sd-device/device-enumerator.c:828
 #8 device_enumerator_scan_devices at ../src/libsystemd/sd-device/device-enumerator.c:860
 #9 udev_enumerate_scan_devices at ../src/libudev/libudev-enumerate.c:411

Comment 1 Paul DeStefano 2018-04-28 17:46:34 UTC
Created attachment 1428206 [details]
File: backtrace

Comment 2 Paul DeStefano 2018-04-28 17:46:35 UTC
Created attachment 1428207 [details]
File: cgroup

Comment 3 Paul DeStefano 2018-04-28 17:46:36 UTC
Created attachment 1428208 [details]
File: core_backtrace

Comment 4 Paul DeStefano 2018-04-28 17:46:37 UTC
Created attachment 1428209 [details]
File: cpuinfo

Comment 5 Paul DeStefano 2018-04-28 17:46:38 UTC
Created attachment 1428210 [details]
File: dso_list

Comment 6 Paul DeStefano 2018-04-28 17:46:39 UTC
Created attachment 1428211 [details]
File: environ

Comment 7 Paul DeStefano 2018-04-28 17:46:40 UTC
Created attachment 1428212 [details]
File: limits

Comment 8 Paul DeStefano 2018-04-28 17:46:41 UTC
Created attachment 1428213 [details]
File: maps

Comment 9 Paul DeStefano 2018-04-28 17:46:42 UTC
Created attachment 1428214 [details]
File: mountinfo

Comment 10 Paul DeStefano 2018-04-28 17:46:43 UTC
Created attachment 1428215 [details]
File: open_fds

Comment 11 Paul DeStefano 2018-04-28 17:46:44 UTC
Created attachment 1428216 [details]
File: proc_pid_status

Comment 12 Paul DeStefano 2018-04-28 17:46:45 UTC
Created attachment 1428217 [details]
File: var_log_messages

Comment 13 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:15 UTC
It seems to me that systemd-udevd is being killed by the watchdog.

*** This bug has been marked as a duplicate of bug 1510042 ***

Comment 14 Zbigniew Jędrzejewski-Szmek 2018-07-18 14:09:34 UTC
It's chasing symlinks here, opening "..", so most likely this is the same as the other bug.

*** This bug has been marked as a duplicate of bug 1572805 ***


Note You need to log in before you can comment on or make changes to this bug.