Bug 1572827 - FFU: openstack overcloud upgrade run outputs to stdout content which is not human readable and is not stored to a persistent location
Summary: FFU: openstack overcloud upgrade run outputs to stdout content which is not h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Lukas Bezdicka
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1561169
TreeView+ depends on / blocked
 
Reported: 2018-04-28 01:13 UTC by Marius Cornea
Modified: 2018-06-27 13:55 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-14.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:53:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
overcloud_upgrade_Controller.log (2.55 MB, text/plain)
2018-04-28 01:14 UTC, Marius Cornea
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 565853 0 None stable/queens: NEW tripleo-common: Persist package update ansible logs (I522acab84833b942865dc57156f3de99779d4f43) 2018-05-09 16:03:54 UTC
OpenStack gerrit 566018 0 None None None 2018-05-14 13:48:12 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:55:07 UTC

Description Marius Cornea 2018-04-28 01:13:17 UTC
Description of problem:

FFU: openstack overcloud upgrade run outputs to stdout content which is not human readable. To give a brief example the following tasks output a huge amount of data which should be stored on a persistent location instead of stdout output:

TASK [Upgrade Mysql database from the host] 
TASK [take new os-net-config parameters into account now] 
TASK [Update all packages] <= this one actually puts the entire output of yum update * in the Ansible task json output

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-4.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run upgrade commands.

Actual results:
A lot of information which is not human readable.

Expected results:

stdout should reflect information relevant and readable by the user and point to the error in case of failure. The verbose logging should be stored on a persistent location that can be used for later debug purposes.

Additional info:

I believe this applies to all ffu/upgrade/updates. I am attaching such example from running openstack overcloud upgrade run --roles Controller --skip-tags validation.

Comment 1 Marius Cornea 2018-04-28 01:14:22 UTC
Created attachment 1427901 [details]
overcloud_upgrade_Controller.log

Comment 2 Jose Luis Franco 2018-04-30 14:24:25 UTC
@Jirka, this BZ has been assigned to you during triage duty call. Please, feel free to reasign.

Comment 7 Carlos Camacho 2018-05-18 11:42:10 UTC
This is a cosmetic bug that we need to solve, but it does not affect the FFWD workflow, removing the blocker flag.

Comment 16 Marius Cornea 2018-05-22 23:58:36 UTC
Output of ansible playbook is available in /var/log/mistral/package_update.log

Comment 18 errata-xmlrpc 2018-06-27 13:53:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.