Bug 1573026 - FFU: After running openstack overcloud ffwd-upgrade converge the overcloudrc doesn't get updated and any post-upgrade calls fail because of missing /v2.0 enpoint
Summary: FFU: After running openstack overcloud ffwd-upgrade converge the overcloudrc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1561169
TreeView+ depends on / blocked
 
Reported: 2018-04-29 22:18 UTC by Marius Cornea
Modified: 2018-06-28 19:26 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-9.2.1-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:54:52 UTC
Target Upstream Version:
sgolovat: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1768036 None None None 2018-04-30 14:13:55 UTC
OpenStack gerrit 565339 None MERGED Regenerate overcloudrc on upgrade and ffwd-upgrade (prepare) 2020-08-01 10:09:54 UTC
OpenStack gerrit 566134 None MERGED Regenerate overcloudrc on upgrade and ffwd-upgrade (prepare) 2020-08-01 10:09:54 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:51 UTC

Description Marius Cornea 2018-04-29 22:18:32 UTC
Description of problem:
FFU: After running openstack overcloud  ffwd-upgrade converge the overcloudrc doesn't get updated and any post-upgrade calls fail because of missing /v2.0 enpoint. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-4.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. openstack overcloud ffwd-upgrade prepare
2. openstack overcloud ffwd-upgrade run
3. openstack overcloud upgrade run --roles Controller --skip-tags validation
4. openstack overcloud upgrade run --roles Compute --skip-tags validation
5. openstack overcloud  ffwd-upgrade converge
6. source overcloudrc; nova list

Actual results:
ERROR (NotFound): (http://10.0.0.109:5000/v2.0/tokens): The resource could not be found. (HTTP 404) (Request-ID: req-a6485d6b-31e0-40af-b006-5a4c5b2fa130)

Expected results:
API calls using the overcloudrc file works.

Additional info:
The overcloudrc should be automatically updated to use the v3 endpoint as v2.0 was removed.

Comment 1 Yurii Prokulevych 2018-05-02 10:37:09 UTC
Same happened during major upgrade from 12 -> 13

neutron l3-agent-list-hosting-router 1b404ae5-ca83-4ffa-998a-ea5ce5387bdf
neutron CLI is deprecated and will be removed in the future. Use openstack CLI instead.
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:344: SubjectAltNameWarning: Certificate for 10.0.0.101 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
(https://10.0.0.101:13000/v2.0/tokens): The resource could not be found. (HTTP 404) (Request-ID: req-32f0e0ef-2e52-445f-9cf8-e05227a6293e)

Comment 2 Yurii Prokulevych 2018-05-02 10:38:24 UTC
openstack endpoint list --service keystone
    +----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+
    | ID                               | Region    | Service Name | Service Type | Enabled | Interface | URL                       |
    +----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+
    | 19d6db64b7f7402cb977e2dde72d38be | regionOne | keystone     | identity     | True    | internal  | http://172.17.1.20:5000   |
    | 9ecec709c21a400d908a73ebdea25a67 | regionOne | keystone     | identity     | True    | public    | https://10.0.0.101:13000  |
    | dcfeb1ca0b98401594e9055fbd3956d3 | regionOne | keystone     | identity     | True    | admin     | http://192.168.24.8:35357 |
    +----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+

Comment 5 Carlos Camacho 2018-05-09 14:20:23 UTC
We can't create the package until this BZ have the blocker flag.

Comment 6 Carlos Camacho 2018-05-09 15:12:46 UTC
I'll move this BZ to modified after the package is generated correctly.

Comment 13 errata-xmlrpc 2018-06-27 13:54:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.