Bug 1573137 - Multiple Slabsize value for VDO volumes failing in gdeploy
Summary: Multiple Slabsize value for VDO volumes failing in gdeploy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1573138
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-04-30 10:16 UTC by bipin
Modified: 2018-11-08 05:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1573138 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:38:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 None None None 2018-11-08 05:39:26 UTC

Description bipin 2018-04-30 10:16:31 UTC
Description of problem:

While creating VDO volumes on different devices, the VDO section currently  takes multiple slabsize value. The gdeploy fails since it doesn't take 2 inputs or more. Providing one slab size value allows the gdeploy execution to proceed.

Ex: 2 VDO volumes on /dev/sda and /dev/sdb. The slabsize values contains 2 inputs in this case.

Version-Release number of selected component (if applicable):
gdeploy-2.0.2-26.el7rhgs.noarch
cockpit-ovirt-dashboard-0.11.23-1.el7ev.noarch
redhat-release-virtualization-host-4.2-3.0.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Login to cockpit UI
2. Create 2 VDO volumes on 2 different devices
3. In the gdeployConfig.conf file the slabsize will have 2 values

Actual results:
Failing for more than one value

Expected results:
It should work for multiple values

Additional info:

Current parameters:

[vdo1:10.x.x.x]
action=create
devices=sdb,sdd
names=vdo_sdb,vdo_sdd
logicalsize=164840G,2000G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=enabled
writepolicy=sync
ignore_vdo_errors=no
slabsize=32G,32G    <--- 2 values

Comment 6 errata-xmlrpc 2018-11-08 05:38:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.