Bug 1573138 - Multiple Slabsize value for VDO volumes failing in gdeploy
Summary: Multiple Slabsize value for VDO volumes failing in gdeploy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ovirt-4.2.4
: 0.11.25
Assignee: Gobinda Das
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1573137 1573762 cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-04-30 10:18 UTC by bipin
Modified: 2018-06-26 08:40 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1573137
Environment:
Last Closed: 2018-06-26 08:40:56 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
bshetty: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90890 0 ovirt-4.2 MERGED Adding slabsize for each device for vdo volume 2018-05-17 12:45:25 UTC
oVirt gerrit 91351 0 ovirt-4.2 MERGED Adding slabsize for each device for vdo volume 2018-05-17 12:45:34 UTC

Description bipin 2018-04-30 10:18:16 UTC
+++ This bug was initially created as a clone of Bug #1573137 +++

Description of problem:

While creating VDO volumes on different devices, the VDO section currently  takes multiple slabsize value. The gdeploy fails since it doesn't take 2 inputs or more. Providing one slab size value allows the gdeploy execution to proceed.

Ex: 2 VDO volumes on /dev/sda and /dev/sdb. The slabsize values contains 2 inputs in this case.

Version-Release number of selected component (if applicable):
gdeploy-2.0.2-26.el7rhgs.noarch
cockpit-ovirt-dashboard-0.11.23-1.el7ev.noarch
redhat-release-virtualization-host-4.2-3.0.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Login to cockpit UI
2. Create 2 VDO volumes on 2 different devices
3. In the gdeployConfig.conf file the slabsize will have 2 values

Actual results:
Failing for more than one value

Expected results:
It should work for multiple values

Additional info:

Current parameters:

[vdo1:10.x.x.x]
action=create
devices=sdb,sdd
names=vdo_sdb,vdo_sdd
logicalsize=164840G,2000G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=enabled
writepolicy=sync
ignore_vdo_errors=no
slabsize=32G,32G    <--- 2 values

Comment 2 Sandro Bonazzola 2018-06-26 08:40:56 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.