Bug 1573162 - Unable to launch qdigidocclient
Summary: Unable to launch qdigidocclient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdigidocpp
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1574251 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 11:49 UTC by Dmitri Smirnov
Modified: 2018-05-05 23:42 UTC (History)
3 users (show)

Fixed In Version: libdigidocpp-3.13.5-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-05 20:34:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Dmitri Smirnov 2018-04-30 11:49:42 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Attempting to run qdigidocclient results in following error:

qdigidocclient: symbol lookup error: /lib64/libdigidocpp.so.1: undefined symbol: _ZN11xalanc_1_1116XalanTransformer10initializeERN11xercesc_3_113MemoryManagerE

How reproducible:

Steps to Reproduce:
1. run qdigidocclient
2. witness an error

Actual results:

Error

Expected results:

Application is launched without issues.

Comment 1 Dmitri Smirnov 2018-04-30 13:19:40 UTC
Manual update to 3.13.5 seems to resolve the issue (but I had to manually build the package from source).

Comment 2 Dmitri Smirnov 2018-05-01 11:06:08 UTC
Don't know if it's of any help, but a build based off of your spec with updated source to 3.13.5 in COPR also seems to work just fine with qesteidutil and qdigidocclient,

https://copr.fedorainfracloud.org/coprs/cserpentis/open-eid/build/747750/

Comment 3 Germano Massullo 2018-05-02 22:26:25 UTC
*** Bug 1574251 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2018-05-02 22:36:41 UTC
libdigidocpp-3.13.5-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2d521831e

Comment 5 Germano Massullo 2018-05-02 22:40:55 UTC
(In reply to Fedora Update System from comment #4)
> libdigidocpp-3.13.5-1.fc28 has been submitted as an update to Fedora 28.
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2d521831e

Please login in the previous URL and leave karma feedback.
I am working also on upgrading qdigidoc to lastest upstream version, but meanwhile with this libdigidocpp update you can restore qdigidoc

Comment 6 Mario Aria 2018-05-02 23:01:08 UTC
(In reply to Germano Massullo from comment #5)
> (In reply to Fedora Update System from comment #4)
> > libdigidocpp-3.13.5-1.fc28 has been submitted as an update to Fedora 28.
> > https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2d521831e
> 
> Please login in the previous URL and leave karma feedback.
> I am working also on upgrading qdigidoc to lastest upstream version, but
> meanwhile with this libdigidocpp update you can restore qdigidoc

Sorry, all this is bit new to me. What's a karma feedback?

Comment 7 Germano Massullo 2018-05-02 23:10:46 UTC
(In reply to Mario Aria from comment #6)
> (In reply to Germano Massullo from comment #5)
> > (In reply to Fedora Update System from comment #4)
> > > libdigidocpp-3.13.5-1.fc28 has been submitted as an update to Fedora 28.
> > > https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2d521831e
> > 
> > Please login in the previous URL and leave karma feedback.
> > I am working also on upgrading qdigidoc to lastest upstream version, but
> > meanwhile with this libdigidocpp update you can restore qdigidoc
> 
> Sorry, all this is bit new to me. What's a karma feedback?

It is a feedback vote sent by users that will make the package going faster from updates-testing repository to updates (stable) repository.

To install the test package:
$ bodhi updates download --updateid FEDORA-2018-f2d521831e
# dnf install libdigidocpp*

Comment 8 Anatoli Babenia 2018-05-03 04:00:03 UTC
# dnf install ./libdigidocpp-3.13.5-1.fc28.x86_64.rpm
$ qdigidocclient

Launched okay under user. Bodhi automated tests page has some complaints. Maybe that's the reason update not pushed to testing?

Comment 9 Germano Massullo 2018-05-03 06:29:37 UTC
(In reply to Anatoli Babenia from comment #8)
> Bodhi automated tests page has some complaints.
> Maybe that's the reason update not pushed to testing?

No, every update takes ~1 day to get pushed into testing repository

Comment 10 Fedora Update System 2018-05-03 20:23:05 UTC
libdigidocpp-3.13.5-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2d521831e

Comment 11 Fedora Update System 2018-05-05 20:34:17 UTC
libdigidocpp-3.13.5-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Anatoli Babenia 2018-05-05 23:42:38 UTC
Good job, Germano.


Note You need to log in before you can comment on or make changes to this bug.