Bug 1573309 - xorg-x11-server-Xorg.x86_64 = 1.19.3 but 1.19.5 installed (RHEL 7.5)
Summary: xorg-x11-server-Xorg.x86_64 = 1.19.3 but 1.19.5 installed (RHEL 7.5)
Keywords:
Status: CLOSED DUPLICATE of bug 1565957
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xorgxrdp
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Pavel Roskin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 20:04 UTC by Giacomo G. Brussino
Modified: 2018-05-02 06:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 21:26:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Giacomo G. Brussino 2018-04-30 20:04:40 UTC
Description of problem: xorgxrdp.x86_64 0.2.6-1.el7 depends on xorg-x11-server-Xorg.x86_64 = 1.19.3 but 1.19.5 installed (RHEL 7.5)


Version-Release number of selected component (if applicable): 0.2.6-1.el7


How reproducible: install xrdp on RHEL 7.5


Steps to Reproduce:
1. Install xrdp on RHEL 7.5
2.
3.

Actual results:

Error: Package: xorgxrdp-0.2.6-1.el7.x86_64 (epel_rhel7_x86_64)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.3
           Installed: xorg-x11-server-Xorg-1.19.5-5.el7.x86_64 (@rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7_0.3.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7_0.3
           Available: xorg-x11-server-Xorg-1.15.0-32.el7.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-32.el7
           Available: xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-33.el7_1
           Available: xorg-x11-server-Xorg-1.17.2-10.el7.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-10.el7
           Available: xorg-x11-server-Xorg-1.17.2-22.el7.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-22.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (rhel-x86_64-workstation-7)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2



Expected results: xrdp installed correctly with xorgxrdp


Additional info:

Comment 1 Bojan Smojver 2018-04-30 21:26:21 UTC

*** This bug has been marked as a duplicate of bug 1565957 ***

Comment 2 jimezdoesit 2018-05-02 06:19:39 UTC
I am running CentOS 7.4 and there seems to be a problem with either EPEL or the version of XORG as shown below.

[root@centos74 ~]# yum install xrdp
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.ndchost.com
 * epel: mirror.sjc02.svwh.net
 * extras: repos-tx.psychz.net
 * updates: repos-lax.psychz.net
Resolving Dependencies
--> Running transaction check
---> Package xrdp.x86_64 1:0.9.6-1.el7 will be installed
--> Processing Dependency: xorgxrdp for package: 1:xrdp-0.9.6-1.el7.x86_64
--> Running transaction check
---> Package xorgxrdp.x86_64 0:0.2.6-2.el7 will be installed
--> Processing Dependency: xorg-x11-server-Xorg(x86-64) = 1.19.5 for package: xorgxrdp-0.2.6-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xorgxrdp-0.2.6-2.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.5
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (base)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Note You need to log in before you can comment on or make changes to this bug.