Bug 1565957 - xorgxrdp needs to be rebuilt against new Xorg in RHEL7.5
Summary: xorgxrdp needs to be rebuilt against new Xorg in RHEL7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xorgxrdp
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Roskin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1573309 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 07:34 UTC by Dominik Mierzejewski
Modified: 2018-11-19 21:52 UTC (History)
11 users (show)

Fixed In Version: xorgxrdp-0.2.6-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 21:34:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik Mierzejewski 2018-04-11 07:34:45 UTC
Description of problem:
With RHEL7.5 released, there's a broken dependency in xorgxrdp.

Version-Release number of selected component (if applicable):
xorgxrdp-0.2.6-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum update xorg-x11-server-Xorg

Actual results:
[...]
Error: Package: xorgxrdp-0.2.6-1.el7.x86_64 (@epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.3
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (@rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
           Updated By: xorg-x11-server-Xorg-1.19.5-5.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7_0.3.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7_0.3
           Available: xorg-x11-server-Xorg-1.15.0-32.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-32.el7
           Available: xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-33.el7_1
           Available: xorg-x11-server-Xorg-1.17.2-10.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-10.el7
           Available: xorg-x11-server-Xorg-1.17.2-22.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-22.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (rhel7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Successful dependency resolution and update.

Comment 1 Bojan Smojver 2018-04-11 07:36:16 UTC
OK, I will rebuild.

Comment 2 Fedora Update System 2018-04-14 00:31:05 UTC
xorgxrdp-0.2.6-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0b4d2d939e

Comment 3 Fedora Update System 2018-04-15 15:18:25 UTC
xorgxrdp-0.2.6-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0b4d2d939e

Comment 4 Bojan Smojver 2018-04-30 21:26:21 UTC
*** Bug 1573309 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2018-04-30 21:34:47 UTC
xorgxrdp-0.2.6-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 jimezdoesit 2018-05-02 06:16:24 UTC
Hi.. I see a bug report here. Installing xrdp has never been a problem but now it is. Running CentOS 7.4 & below are the results of my problem.

[root@centos74 ~]# yum install xrdp
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.ndchost.com
 * epel: mirror.sjc02.svwh.net
 * extras: repos-tx.psychz.net
 * updates: repos-lax.psychz.net
Resolving Dependencies
--> Running transaction check
---> Package xrdp.x86_64 1:0.9.6-1.el7 will be installed
--> Processing Dependency: xorgxrdp for package: 1:xrdp-0.9.6-1.el7.x86_64
--> Running transaction check
---> Package xorgxrdp.x86_64 0:0.2.6-2.el7 will be installed
--> Processing Dependency: xorg-x11-server-Xorg(x86-64) = 1.19.5 for package: xorgxrdp-0.2.6-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xorgxrdp-0.2.6-2.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.5
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (base)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 7 Dominik Mierzejewski 2018-05-02 08:36:28 UTC
(In reply to jimezdoesit from comment #6)
> Hi.. I see a bug report here. Installing xrdp has never been a problem but
> now it is. Running CentOS 7.4 & below are the results of my problem.

Using EPEL with older point releases is not supported. You need to upgrade to the latest (7.5) or manually install older xorgxrdp package.

Comment 8 alan.dennis 2018-05-02 09:17:17 UTC
At the moment, CentOS 7.4 *is* the latest, there is no 7.5 (yet).

Comment 9 Dominik Mierzejewski 2018-05-02 09:24:51 UTC
Like I said, installing an older build (xorgxrdp-0.2.6-1.el7) manually will work fine. You can fetch it from koji (https://koji.fedoraproject.org/koji/buildinfo?buildID=1062201) if it's not in the repos anymore.

Comment 10 alan.dennis 2018-05-02 10:37:49 UTC
The real question is surely, why does it need to be so tightly bound to a specific dependency version anyway? Doing so has caused weeks of pain, first for folks updating to RHEL 7.5 and now they're fixed, folks installing CentOS 7.4 have the pain instead, having to mess around with an old version workaround until CentOS 7.5 hits the streets. 

Can't it get away with a dependency on 1.19, rather than 1.19.3/1.19.5?

Comment 11 Bojan Smojver 2018-05-02 10:49:12 UTC
It some kind of xorg binary compatibility thing, I believe.

Comment 12 jimezdoesit 2018-05-02 18:40:51 UTC
(In reply to alan.dennis from comment #10)
> The real question is surely, why does it need to be so tightly bound to a
> specific dependency version anyway? Doing so has caused weeks of pain, first
> for folks updating to RHEL 7.5 and now they're fixed, folks installing
> CentOS 7.4 have the pain instead, having to mess around with an old version
> workaround until CentOS 7.5 hits the streets. 
> 
> Can't it get away with a dependency on 1.19, rather than 1.19.3/1.19.5?

Thanks Alan!

Comment 13 alan.dennis 2018-05-03 07:15:55 UTC
Ok, so how about making this a virtual package and create version specific "provides: xorgxrdp" sub packages, e.g. xorgxrdp_1_19_3, xorgxrdp_1_19_5 each with a dependency on their respective xorg-x11-server-Xorg version? That way it just works, and nobody has to mess about with old/broken/fixed/new rpms?

Comment 14 Martes G Wigglesworth 2018-05-03 12:51:20 UTC
Why has this issue been closed?

The issue is still an active problem as of last evening while attempting to run a yum update. (the only package that was picked up whas xrdp from epel, and it basically broke my ability to have a functional xrdp install, after I removed the current xrdp thinking that I had a mismatch issue again.)

Also the answer given by  Dominik Mierzejewski 2018-05-02 04:36:28 EDT makes absolutely no sense at all.  

If I take my car to my mechanic for a quarterly preventive maintenance session, and he installs an ECU that only works with a 2019 model that has not come out yet, he is not then able to tell me that "installing ECU versions prior to 2019 is not supported."  

Is anyone actually going to fix this mistake?

Comment 15 Bojan Smojver 2018-05-03 13:03:36 UTC
(In reply to Martes G Wigglesworth from comment #14)

> Is anyone actually going to fix this mistake?

It's not a mistake. To see why, see original bug #1482107.

Feel free to install the older build from koji, of course. We can only keep one version of the package in EPEL and that's against the latest RHEL.

PS. The car analogy doesn't quite work. You didn't pay anything for this package. :-)

Comment 16 alan.dennis 2018-05-03 13:46:28 UTC
xorg-x11-server-Xorg 'provides:' these ...

xserver-abi(ansic-0) = 4
xserver-abi(extension-10) = 0
xserver-abi(videodrv-23) = 0
xserver-abi(xinput-24) = 1

As it's an ABI dependency thing, instead of specifying ...

requires: xorg-x11-server-Xorg(x86-64) = 1.19.3

... shouldn't xorgxrdp 'requires:' one or more of those 'provides:' instead of the version number? Would that have eliminated these 7.4/7.5 problems?

Comment 17 Bojan Smojver 2018-05-03 14:12:00 UTC
(In reply to alan.dennis from comment #16)

> ... shouldn't xorgxrdp 'requires:' one or more of those 'provides:' instead
> of the version number? Would that have eliminated these 7.4/7.5 problems?

It would definitely be more correct, but as you can see from that old bug where upgrade from 7.3 to 7.4 got broken, it would still create a problem. Xorg would simply refuse to run and the installation would fail because there would be nothing to satisfy the new abi dependencies.

I already opened a bug against xrog-x11-server to build xorgxrdp together with it. But, that can only apply to Fedora anyway.

Comment 18 Martes G Wigglesworth 2018-05-03 18:40:53 UTC
(In reply to Bojan Smojver from comment #15)
> (In reply to Martes G Wigglesworth from comment #14)
> 
> > Is anyone actually going to fix this mistake?
> 
> It's not a mistake. To see why, see original bug #1482107.
> 
> Feel free to install the older build from koji, of course. We can only keep
> one version of the package in EPEL and that's against the latest RHEL.
> 
> PS. The car analogy doesn't quite work. You didn't pay anything for this
> package. :-)


Would the incompetence have been more directly identifiable, within the scope of my automotive update scenario, if I had included some nonsense about "Makers" or "HackSpace" enthusiasts doing the work in a back alley with rain coming down as I failed to gather enough change for my nightly meal?

Common sense and good stewardship works if you are poor or rich and the implication that somehow my reference makes absolutely no sense because you assume I am talking about paid services from a dealership mechanic or otherwise, is beyond dubious in its logical sourcing.

Comment 19 Steven Bennett 2018-05-03 21:09:39 UTC
(In reply to alan.dennis from comment #8)
> At the moment, CentOS 7.4 *is* the latest, there is no 7.5 (yet).

Just update the yum configuration to use the CR (Continuous Release) Repo:

yum-config-manager --enable cr

Then update from there:

yum update

The remote desktop protocol installation should run just fine after that:

yum install xrdp tigervnc-server

Comment 20 Bojan Smojver 2018-05-03 21:52:41 UTC
(In reply to Martes G Wigglesworth from comment #18)
> (In reply to Bojan Smojver from comment #15)

> Would the incompetence have been more directly identifiable, within the
> scope of my automotive update scenario, if I had included some nonsense
> about "Makers" or "HackSpace" enthusiasts doing the work in a back alley
> with rain coming down as I failed to gather enough change for my nightly
> meal?

If you think you're more competent than folks that contribute to EPEL, which may as well be the case, just create you own repo and run it for everyone.

> Common sense and good stewardship works if you are poor or rich and the
> implication that somehow my reference makes absolutely no sense because you
> assume I am talking about paid services from a dealership mechanic or
> otherwise, is beyond dubious in its logical sourcing.

EPEL is free software, created by volunteers to help you. The package that runs in your scenario already exists and multiple people pointed out how to use it.

Comment 21 alan.dennis 2018-05-04 09:12:09 UTC
(In reply to Steven Bennett from comment #19)

> Just update the yum configuration to use the CR (Continuous Release) Repo:

Thanks. Yes, that's an option, it's just that we'd prefer to stick to the "stability" (!) of the formal releases. Would be useful as a "one time" source of the required v7.5 xorg-x11-server-Xorg v1.19.3 in this case though.

Comment 22 alan.dennis 2018-05-04 09:15:19 UTC
(In reply to alan.dennis from comment #21)

> required v7.5 xorg-x11-server-Xorg v1.19.3 

doh! correction: v1.19.5

Comment 23 terrawide 2018-11-19 21:52:44 UTC
If it helps anyone, based on the above information, here's a quick step by step that I did;

yum clean all
rm -rf /var/cache/yum
yum-config-manager --enable cr (you might need to install yum-utils)
yum update xorgxrdp-0.2.8-3.el7.x86_64 (answer yes)
yum-config-manager --disable cr (put it back the way it was)
yum clean all

...and after that, just do a 'regular' yum update


Note You need to log in before you can comment on or make changes to this bug.