Bug 1573491 - [Test] Unable to execute unit tests
Summary: [Test] Unable to execute unit tests
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 14:10 UTC by Arie Bregman
Modified: 2019-09-10 14:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 15:52:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arie Bregman 2018-05-01 14:10:58 UTC
Description of problem:

Unable to execute unit tests on RHEL VM:

No handlers could be found for logger "openstack_dashboard.settings"
nosetests --verbosity=1
xdpyinfo:  unable to open display "".
E.
======================================================================
ERROR: Failure: CalledProcessError (Command 'xdpyinfo | grep dimensions' returned non-zero exit status 1)
----------------------------------------------------------------------


Version-Release number of selected component (if applicable): OSP 13 Latest


How reproducible: 100%


Steps to Reproduce:
1. Clone openstack-octavia-ui
2. Run unit tests with 'tox -e py27'

Comment 1 Carlos Goncalves 2018-05-02 15:50:18 UTC
Octavia dashboard is Angular and not Django (Python). We should be running the spec files (which are the unit test code) in https://github.com/openstack/octavia-dashboard/tree/master/octavia_dashboard/static/dashboard/project/lbaasv2/loadbalancers.

Please run 'karma' and 'eslint' test environments. Package npm needs to be installed.


(.venv) [cgoncalves@codfish octavia-dashboard] $ tox -e eslint
eslint create: /home/cgoncalves/dev/repos/openstack/octavia-dashboard/.tox/eslint
eslint installdeps: -chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/requirements.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/test-requirements.txt
eslint develop-inst: /home/cgoncalves/dev/repos/openstack/octavia-dashboard
eslint installed: appdirs==1.4.3,asn1crypto==0.24.0,Babel==2.5.3,certifi==2018.1.18,cffi==1.11.5,chardet==3.0.4,cliff==2.11.0,cmd2==0.8.2,contextlib2==0.5.5,coverage==4.5.1,cryptography==2.2.2,debtcollector==1.19.0,decorator==4.2.1,deprecation==2.0,Django==1.11.11,django-appconf==1.0.2,django-babel==0.6.2,django-compressor==2.2,django-nose==1.4.5,django-pyscss==2.0.2,dogpile.cache==0.6.5,enum34==1.1.6,extras==1.0.0,fasteners==0.14.1,fixtures==3.0.0,flake8==2.5.5,funcsigs==1.0.2,functools32==3.2.3.post2,futures==3.2.0,futurist==1.7.0,hacking==0.12.0,horizon==13.0.0,idna==2.6,ipaddress==1.0.19,iso8601==0.1.12,jmespath==0.9.3,jsonpatch==1.21,jsonpointer==2.0,jsonschema==2.6.0,keystoneauth1==3.5.0,linecache2==1.0.0,mccabe==0.2.1,mock==2.0.0,monotonic==1.4,mox3==0.25.0,msgpack==0.5.6,munch==2.2.0,netaddr==0.7.19,netifaces==0.10.6,nose==1.3.7,nose-exclude==0.5.0,-e git+https://github.com/openstack/octavia-dashboard@e9eb5bbbf801b017821d91662d643c9a46f44124#egg=octavia_dashboard,openstacksdk==0.13.0,os-client-config==1.29.0,os-service-types==1.2.0,osc-lib==1.10.0,oslo.concurrency==3.27.0,oslo.config==6.2.0,oslo.context==2.20.0,oslo.i18n==3.20.0,oslo.log==3.38.0,oslo.policy==1.34.0,oslo.serialization==2.25.0,oslo.utils==3.36.0,oslotest==3.4.1,osprofiler==2.0.0,packaging==17.1,pathlib==1.0.1,pbr==4.0.2,pep8==1.5.7,Pint==0.8.1,prettytable==0.7.2,pycparser==2.18,pyflakes==0.8.1,pyinotify==0.9.6,pymongo==3.6.1,pyOpenSSL==17.5.0,pyparsing==2.2.0,pyperclip==1.6.0,pyScss==1.3.4,python-barbicanclient==4.6.0,python-cinderclient==3.5.0,python-dateutil==2.7.2,python-glanceclient==2.11.0,python-keystoneclient==3.16.0,python-mimeparse==1.6.0,python-neutronclient==6.8.0,python-novaclient==10.2.0,python-subunit==1.2.0,python-swiftclient==3.5.0,pytz==2018.3,PyYAML==3.12,rcssmin==1.0.6,requests==2.18.4,requestsexceptions==1.4.0,rfc3986==1.1.0,rjsmin==1.0.12,selenium==3.11.0,semantic-version==2.6.0,simplejson==3.13.2,six==1.11.0,stevedore==1.28.0,subprocess32==3.2.7,testrepository==0.0.20,testscenarios==0.5.0,testtools==2.3.0,traceback2==1.4.0,unicodecsv==0.14.1,unittest2==1.1.0,urllib3==1.22,warlock==1.3.0,WebOb==1.7.4,wrapt==1.10.11,XStatic==1.0.1,XStatic-Angular==1.5.8.0,XStatic-Angular-Bootstrap==2.2.0.0,XStatic-Angular-FileUpload==12.0.4.0,XStatic-Angular-Gettext==2.3.8.0,XStatic-Angular-lrdragndrop==1.0.2.2,XStatic-Angular-Schema-Form==0.8.13.0,XStatic-Bootstrap-Datepicker==1.3.1.0,XStatic-Bootstrap-SCSS==3.3.7.1,XStatic-bootswatch==3.3.7.0,XStatic-D3==3.5.17.0,XStatic-Font-Awesome==4.7.0.0,XStatic-Hogan==2.0.0.2,XStatic-Jasmine==2.4.1.1,XStatic-jQuery==1.10.2.1,XStatic-JQuery-Migrate==1.2.1.1,XStatic-jquery-ui==1.12.0.1,XStatic-JQuery.quicksearch==2.0.3.1,XStatic-JQuery.TableSorter==2.14.5.1,XStatic-JSEncrypt==2.3.1.1,XStatic-mdi==1.4.57.0,XStatic-objectpath==1.2.1.0,XStatic-Rickshaw==1.5.0.0,XStatic-roboto-fontface==0.5.0.0,XStatic-smart-table==1.4.13.2,XStatic-Spin==1.2.5.2,XStatic-term.js==0.0.7.0,XStatic-tv4==1.2.7.0,xvfbwrapper==0.2.9
eslint runtests: PYTHONHASHSEED='1332703803'
eslint runtests: commands[0] | npm install

> octavia-dashboard@1.0.0 postinstall /home/cgoncalves/dev/repos/openstack/octavia-dashboard
> octavia_dashboard/post_install.sh

+ '[' '!' -f test-shim.js ']'
+ echo 'Creating a tox env which will contain xStatic libraries, horizon, and openstack_dashboard'
Creating a tox env which will contain xStatic libraries, horizon, and openstack_dashboard
+ tox -epy27 --notest
py27 recreate: /home/cgoncalves/dev/repos/openstack/octavia-dashboard/.tox/py27
py27 installdeps: -chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/requirements.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/test-requirements.txt
py27 develop-inst: /home/cgoncalves/dev/repos/openstack/octavia-dashboard
py27 installed: appdirs==1.4.3,asn1crypto==0.24.0,Babel==2.5.3,certifi==2018.1.18,cffi==1.11.5,chardet==3.0.4,cliff==2.11.0,cmd2==0.8.2,contextlib2==0.5.5,coverage==4.5.1,cryptography==2.2.2,debtcollector==1.19.0,decorator==4.2.1,deprecation==2.0,Django==1.11.11,django-appconf==1.0.2,django-babel==0.6.2,django-compressor==2.2,django-nose==1.4.5,django-pyscss==2.0.2,dogpile.cache==0.6.5,enum34==1.1.6,extras==1.0.0,fasteners==0.14.1,fixtures==3.0.0,flake8==2.5.5,funcsigs==1.0.2,functools32==3.2.3.post2,futures==3.2.0,futurist==1.7.0,hacking==0.12.0,horizon==13.0.0,idna==2.6,ipaddress==1.0.19,iso8601==0.1.12,jmespath==0.9.3,jsonpatch==1.21,jsonpointer==2.0,jsonschema==2.6.0,keystoneauth1==3.5.0,linecache2==1.0.0,mccabe==0.2.1,mock==2.0.0,monotonic==1.4,mox3==0.25.0,msgpack==0.5.6,munch==2.2.0,netaddr==0.7.19,netifaces==0.10.6,nose==1.3.7,nose-exclude==0.5.0,-e git+https://github.com/openstack/octavia-dashboard@e9eb5bbbf801b017821d91662d643c9a46f44124#egg=octavia_dashboard,openstacksdk==0.13.0,os-client-config==1.29.0,os-service-types==1.2.0,osc-lib==1.10.0,oslo.concurrency==3.27.0,oslo.config==6.2.0,oslo.context==2.20.0,oslo.i18n==3.20.0,oslo.log==3.38.0,oslo.policy==1.34.0,oslo.serialization==2.25.0,oslo.utils==3.36.0,oslotest==3.4.1,osprofiler==2.0.0,packaging==17.1,pathlib==1.0.1,pbr==4.0.2,pep8==1.5.7,Pint==0.8.1,prettytable==0.7.2,pycparser==2.18,pyflakes==0.8.1,pyinotify==0.9.6,pymongo==3.6.1,pyOpenSSL==17.5.0,pyparsing==2.2.0,pyperclip==1.6.0,pyScss==1.3.4,python-barbicanclient==4.6.0,python-cinderclient==3.5.0,python-dateutil==2.7.2,python-glanceclient==2.11.0,python-keystoneclient==3.16.0,python-mimeparse==1.6.0,python-neutronclient==6.8.0,python-novaclient==10.2.0,python-subunit==1.2.0,python-swiftclient==3.5.0,pytz==2018.3,PyYAML==3.12,rcssmin==1.0.6,requests==2.18.4,requestsexceptions==1.4.0,rfc3986==1.1.0,rjsmin==1.0.12,selenium==3.11.0,semantic-version==2.6.0,simplejson==3.13.2,six==1.11.0,stevedore==1.28.0,subprocess32==3.2.7,testrepository==0.0.20,testscenarios==0.5.0,testtools==2.3.0,traceback2==1.4.0,unicodecsv==0.14.1,unittest2==1.1.0,urllib3==1.22,warlock==1.3.0,WebOb==1.7.4,wrapt==1.10.11,XStatic==1.0.1,XStatic-Angular==1.5.8.0,XStatic-Angular-Bootstrap==2.2.0.0,XStatic-Angular-FileUpload==12.0.4.0,XStatic-Angular-Gettext==2.3.8.0,XStatic-Angular-lrdragndrop==1.0.2.2,XStatic-Angular-Schema-Form==0.8.13.0,XStatic-Bootstrap-Datepicker==1.3.1.0,XStatic-Bootstrap-SCSS==3.3.7.1,XStatic-bootswatch==3.3.7.0,XStatic-D3==3.5.17.0,XStatic-Font-Awesome==4.7.0.0,XStatic-Hogan==2.0.0.2,XStatic-Jasmine==2.4.1.1,XStatic-jQuery==1.10.2.1,XStatic-JQuery-Migrate==1.2.1.1,XStatic-jquery-ui==1.12.0.1,XStatic-JQuery.quicksearch==2.0.3.1,XStatic-JQuery.TableSorter==2.14.5.1,XStatic-JSEncrypt==2.3.1.1,XStatic-mdi==1.4.57.0,XStatic-objectpath==1.2.1.0,XStatic-Rickshaw==1.5.0.0,XStatic-roboto-fontface==0.5.0.0,XStatic-smart-table==1.4.13.2,XStatic-Spin==1.2.5.2,XStatic-term.js==0.0.7.0,XStatic-tv4==1.2.7.0,xvfbwrapper==0.2.9
_____________________________________________________________________________________________________ summary _____________________________________________________________________________________________________
  py27: skipped tests
  congratulations :)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 36.243s
eslint runtests: commands[1] | npm run lint

> octavia-dashboard@1.0.0 lint /home/cgoncalves/dev/repos/openstack/octavia-dashboard
> eslint --no-color octavia_dashboard/static

_____________________________________________________________________________________________________ summary _____________________________________________________________________________________________________
  eslint: commands succeeded
  congratulations :)


(.venv) [cgoncalves@codfish octavia-dashboard] $ tox -e karma
karma develop-inst-nodeps: /home/cgoncalves/dev/repos/openstack/octavia-dashboard
karma installed: appdirs==1.4.3,asn1crypto==0.24.0,Babel==2.5.3,certifi==2018.1.18,cffi==1.11.5,chardet==3.0.4,cliff==2.11.0,cmd2==0.8.2,contextlib2==0.5.5,coverage==4.5.1,cryptography==2.2.2,debtcollector==1.19.0,decorator==4.2.1,deprecation==2.0,Django==1.11.11,django-appconf==1.0.2,django-babel==0.6.2,django-compressor==2.2,django-nose==1.4.5,django-pyscss==2.0.2,dogpile.cache==0.6.5,enum34==1.1.6,extras==1.0.0,fasteners==0.14.1,fixtures==3.0.0,flake8==2.5.5,funcsigs==1.0.2,functools32==3.2.3.post2,futures==3.2.0,futurist==1.7.0,hacking==0.12.0,horizon==13.0.0,idna==2.6,ipaddress==1.0.19,iso8601==0.1.12,jmespath==0.9.3,jsonpatch==1.21,jsonpointer==2.0,jsonschema==2.6.0,keystoneauth1==3.5.0,linecache2==1.0.0,mccabe==0.2.1,mock==2.0.0,monotonic==1.4,mox3==0.25.0,msgpack==0.5.6,munch==2.2.0,netaddr==0.7.19,netifaces==0.10.6,nose==1.3.7,nose-exclude==0.5.0,-e git+https://github.com/openstack/octavia-dashboard@e9eb5bbbf801b017821d91662d643c9a46f44124#egg=octavia_dashboard,openstacksdk==0.13.0,os-client-config==1.29.0,os-service-types==1.2.0,osc-lib==1.10.0,oslo.concurrency==3.27.0,oslo.config==6.2.0,oslo.context==2.20.0,oslo.i18n==3.20.0,oslo.log==3.38.0,oslo.policy==1.34.0,oslo.serialization==2.25.0,oslo.utils==3.36.0,oslotest==3.4.1,osprofiler==2.0.0,packaging==17.1,pathlib==1.0.1,pbr==4.0.2,pep8==1.5.7,Pint==0.8.1,prettytable==0.7.2,pycparser==2.18,pyflakes==0.8.1,pyinotify==0.9.6,pymongo==3.6.1,pyOpenSSL==17.5.0,pyparsing==2.2.0,pyperclip==1.6.0,pyScss==1.3.4,python-barbicanclient==4.6.0,python-cinderclient==3.5.0,python-dateutil==2.7.2,python-glanceclient==2.11.0,python-keystoneclient==3.16.0,python-mimeparse==1.6.0,python-neutronclient==6.8.0,python-novaclient==10.2.0,python-subunit==1.2.0,python-swiftclient==3.5.0,pytz==2018.3,PyYAML==3.12,rcssmin==1.0.6,requests==2.18.4,requestsexceptions==1.4.0,rfc3986==1.1.0,rjsmin==1.0.12,selenium==3.11.0,semantic-version==2.6.0,simplejson==3.13.2,six==1.11.0,stevedore==1.28.0,subprocess32==3.2.7,testrepository==0.0.20,testscenarios==0.5.0,testtools==2.3.0,traceback2==1.4.0,unicodecsv==0.14.1,unittest2==1.1.0,urllib3==1.22,warlock==1.3.0,WebOb==1.7.4,wrapt==1.10.11,XStatic==1.0.1,XStatic-Angular==1.5.8.0,XStatic-Angular-Bootstrap==2.2.0.0,XStatic-Angular-FileUpload==12.0.4.0,XStatic-Angular-Gettext==2.3.8.0,XStatic-Angular-lrdragndrop==1.0.2.2,XStatic-Angular-Schema-Form==0.8.13.0,XStatic-Bootstrap-Datepicker==1.3.1.0,XStatic-Bootstrap-SCSS==3.3.7.1,XStatic-bootswatch==3.3.7.0,XStatic-D3==3.5.17.0,XStatic-Font-Awesome==4.7.0.0,XStatic-Hogan==2.0.0.2,XStatic-Jasmine==2.4.1.1,XStatic-jQuery==1.10.2.1,XStatic-JQuery-Migrate==1.2.1.1,XStatic-jquery-ui==1.12.0.1,XStatic-JQuery.quicksearch==2.0.3.1,XStatic-JQuery.TableSorter==2.14.5.1,XStatic-JSEncrypt==2.3.1.1,XStatic-mdi==1.4.57.0,XStatic-objectpath==1.2.1.0,XStatic-Rickshaw==1.5.0.0,XStatic-roboto-fontface==0.5.0.0,XStatic-smart-table==1.4.13.2,XStatic-Spin==1.2.5.2,XStatic-term.js==0.0.7.0,XStatic-tv4==1.2.7.0,xvfbwrapper==0.2.9
karma runtests: PYTHONHASHSEED='4166655353'
karma runtests: commands[0] | npm install

> phantomjs-prebuilt@2.1.14 install /home/cgoncalves/dev/repos/openstack/octavia-dashboard/node_modules/phantomjs-prebuilt
> node install.js

PhantomJS not found on PATH
Downloading https://github.com/Medium/phantomjs/releases/download/v2.1.1/phantomjs-2.1.1-linux-x86_64.tar.bz2
Saving to /tmp/phantomjs/phantomjs-2.1.1-linux-x86_64.tar.bz2
Receiving...
  [========================================] 99%
Received 22866K total.
Extracting tar contents (via spawned process)
Removing /home/cgoncalves/dev/repos/openstack/octavia-dashboard/node_modules/phantomjs-prebuilt/lib/phantom
Copying extracted folder /tmp/phantomjs/phantomjs-2.1.1-linux-x86_64.tar.bz2-extract-1525274438736/phantomjs-2.1.1-linux-x86_64 -> /home/cgoncalves/dev/repos/openstack/octavia-dashboard/node_modules/phantomjs-prebuilt/lib/phantom
Writing location.js file
Done. Phantomjs binary available at /home/cgoncalves/dev/repos/openstack/octavia-dashboard/node_modules/phantomjs-prebuilt/lib/phantom/bin/phantomjs

> octavia-dashboard@1.0.0 postinstall /home/cgoncalves/dev/repos/openstack/octavia-dashboard
> octavia_dashboard/post_install.sh

+ '[' '!' -f test-shim.js ']'
+ wget -nv -t 3 https://raw.githubusercontent.com/openstack/horizon/master/test-shim.js
2018-05-02 17:20:41 URL:https://raw.githubusercontent.com/openstack/horizon/master/test-shim.js [3198/3198] -> "test-shim.js" [1]
+ echo 'Creating a tox env which will contain xStatic libraries, horizon, and openstack_dashboard'
Creating a tox env which will contain xStatic libraries, horizon, and openstack_dashboard
+ tox -epy27 --notest
py27 recreate: /home/cgoncalves/dev/repos/openstack/octavia-dashboard/.tox/py27
py27 installdeps: -chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/requirements.txt, -r/home/cgoncalves/dev/repos/openstack/octavia-dashboard/test-requirements.txt
py27 develop-inst: /home/cgoncalves/dev/repos/openstack/octavia-dashboard
py27 installed: appdirs==1.4.3,asn1crypto==0.24.0,Babel==2.5.3,certifi==2018.1.18,cffi==1.11.5,chardet==3.0.4,cliff==2.11.0,cmd2==0.8.2,contextlib2==0.5.5,coverage==4.5.1,cryptography==2.2.2,debtcollector==1.19.0,decorator==4.2.1,deprecation==2.0,Django==1.11.11,django-appconf==1.0.2,django-babel==0.6.2,django-compressor==2.2,django-nose==1.4.5,django-pyscss==2.0.2,dogpile.cache==0.6.5,enum34==1.1.6,extras==1.0.0,fasteners==0.14.1,fixtures==3.0.0,flake8==2.5.5,funcsigs==1.0.2,functools32==3.2.3.post2,futures==3.2.0,futurist==1.7.0,hacking==0.12.0,horizon==13.0.0,idna==2.6,ipaddress==1.0.19,iso8601==0.1.12,jmespath==0.9.3,jsonpatch==1.21,jsonpointer==2.0,jsonschema==2.6.0,keystoneauth1==3.5.0,linecache2==1.0.0,mccabe==0.2.1,mock==2.0.0,monotonic==1.4,mox3==0.25.0,msgpack==0.5.6,munch==2.2.0,netaddr==0.7.19,netifaces==0.10.6,nose==1.3.7,nose-exclude==0.5.0,-e git+https://github.com/openstack/octavia-dashboard@e9eb5bbbf801b017821d91662d643c9a46f44124#egg=octavia_dashboard,openstacksdk==0.13.0,os-client-config==1.29.0,os-service-types==1.2.0,osc-lib==1.10.0,oslo.concurrency==3.27.0,oslo.config==6.2.0,oslo.context==2.20.0,oslo.i18n==3.20.0,oslo.log==3.38.0,oslo.policy==1.34.0,oslo.serialization==2.25.0,oslo.utils==3.36.0,oslotest==3.4.1,osprofiler==2.0.0,packaging==17.1,pathlib==1.0.1,pbr==4.0.2,pep8==1.5.7,Pint==0.8.1,prettytable==0.7.2,pycparser==2.18,pyflakes==0.8.1,pyinotify==0.9.6,pymongo==3.6.1,pyOpenSSL==17.5.0,pyparsing==2.2.0,pyperclip==1.6.0,pyScss==1.3.4,python-barbicanclient==4.6.0,python-cinderclient==3.5.0,python-dateutil==2.7.2,python-glanceclient==2.11.0,python-keystoneclient==3.16.0,python-mimeparse==1.6.0,python-neutronclient==6.8.0,python-novaclient==10.2.0,python-subunit==1.2.0,python-swiftclient==3.5.0,pytz==2018.3,PyYAML==3.12,rcssmin==1.0.6,requests==2.18.4,requestsexceptions==1.4.0,rfc3986==1.1.0,rjsmin==1.0.12,selenium==3.11.0,semantic-version==2.6.0,simplejson==3.13.2,six==1.11.0,stevedore==1.28.0,subprocess32==3.2.7,testrepository==0.0.20,testscenarios==0.5.0,testtools==2.3.0,traceback2==1.4.0,unicodecsv==0.14.1,unittest2==1.1.0,urllib3==1.22,warlock==1.3.0,WebOb==1.7.4,wrapt==1.10.11,XStatic==1.0.1,XStatic-Angular==1.5.8.0,XStatic-Angular-Bootstrap==2.2.0.0,XStatic-Angular-FileUpload==12.0.4.0,XStatic-Angular-Gettext==2.3.8.0,XStatic-Angular-lrdragndrop==1.0.2.2,XStatic-Angular-Schema-Form==0.8.13.0,XStatic-Bootstrap-Datepicker==1.3.1.0,XStatic-Bootstrap-SCSS==3.3.7.1,XStatic-bootswatch==3.3.7.0,XStatic-D3==3.5.17.0,XStatic-Font-Awesome==4.7.0.0,XStatic-Hogan==2.0.0.2,XStatic-Jasmine==2.4.1.1,XStatic-jQuery==1.10.2.1,XStatic-JQuery-Migrate==1.2.1.1,XStatic-jquery-ui==1.12.0.1,XStatic-JQuery.quicksearch==2.0.3.1,XStatic-JQuery.TableSorter==2.14.5.1,XStatic-JSEncrypt==2.3.1.1,XStatic-mdi==1.4.57.0,XStatic-objectpath==1.2.1.0,XStatic-Rickshaw==1.5.0.0,XStatic-roboto-fontface==0.5.0.0,XStatic-smart-table==1.4.13.2,XStatic-Spin==1.2.5.2,XStatic-term.js==0.0.7.0,XStatic-tv4==1.2.7.0,xvfbwrapper==0.2.9
_____________________________________________________________________________________________________ summary _____________________________________________________________________________________________________
  py27: skipped tests
  congratulations :)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 485 packages in 51.138s
karma runtests: commands[1] | npm test

> octavia-dashboard@1.0.0 test /home/cgoncalves/dev/repos/openstack/octavia-dashboard
> karma start octavia_dashboard/karma.conf.js --single-run

02 05 2018 17:21:12.965:INFO [karma]: Karma v1.1.2 server started at http://localhost:9876/
02 05 2018 17:21:12.967:INFO [launcher]: Launching browser PhantomJS with unlimited concurrency
02 05 2018 17:21:12.973:INFO [launcher]: Starting browser PhantomJS
02 05 2018 17:21:13.146:INFO [PhantomJS 2.1.1 (Linux 0.0.0)]: Connected on socket /#nyyRQmQvflZPV1uQAAAA with id 52815251
PhantomJS 2.1.1 (Linux 0.0.0): Executed 537 of 537 SUCCESS (3.329 secs / 3.206 secs)

==================== Coverage / Threshold summary =============================
Statements   : 100% ( 1882/1882 ) Threshold : 100%
Branches     : 100% ( 296/296 ) Threshold : 100%
Functions    : 100% ( 582/582 ) Threshold : 100%
Lines        : 100% ( 1882/1882 ) Threshold : 100%
================================================================================
_____________________________________________________________________________________________________ summary _____________________________________________________________________________________________________
  karma: commands succeeded
  congratulations :)

Comment 2 Carlos Goncalves 2018-05-02 15:52:18 UTC
Please reopen if needed.


Note You need to log in before you can comment on or make changes to this bug.