Bug 1573683 - Can't login to Desktop after upgrade to Fedora 28
Summary: Can't login to Desktop after upgrade to Fedora 28
Keywords:
Status: CLOSED DUPLICATE of bug 1573546
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rui Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 00:06 UTC by Zdenek Chmelar
Modified: 2018-07-07 16:04 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 21:39:47 UTC
Type: Bug


Attachments (Terms of Use)
example of the error (8.91 KB, text/plain)
2018-05-02 00:06 UTC, Zdenek Chmelar
no flags Details
One more log (5.79 KB, text/plain)
2018-05-02 00:07 UTC, Zdenek Chmelar
no flags Details
New log file (19.82 KB, text/plain)
2018-05-02 14:34 UTC, Zdenek Chmelar
no flags Details
GNOME crash right after login (17.61 KB, text/plain)
2018-05-02 17:05 UTC, František Zatloukal
no flags Details
dnf update log (23.30 KB, text/plain)
2018-05-02 17:08 UTC, František Zatloukal
no flags Details

Description Zdenek Chmelar 2018-05-02 00:06:16 UTC
Created attachment 1429606 [details]
example of the error

Description of problem:
I just did an upgrade from Fedora 27 to 28 (via gnome-software). After the upgrade was completed, laptop rebooted and reached login screen. Now, if I enter the password, the screen jumps back to login screen each time (no matter what desktop session I choose). I cannot login to desktop.

Version-Release number of selected component (if applicable):
gnome-shell-3.28.1-3.x86_64

How reproducible:
Always

Additional info:
This is the error I get each login attempt

gnome-session-binary[3972]: Unrecoverable failure in required component org.gnome.Shell.desktop

I attached 2 examples of the journal problem report

Comment 1 Zdenek Chmelar 2018-05-02 00:07:04 UTC
Created attachment 1429607 [details]
One more log

Comment 2 Matthew Saltzman 2018-05-02 12:04:57 UTC
Me, too. 

In my case, the problem turned out to be related to extensions installed from http://extensions.gnome.org. I had caffeine and system-monitor installed in F27 and after upgrade to F28 I couldn't log in on the desktop. Logs showed gnome-shell crashing with signal 5. I removed the ${HOME}/.local/share/gnome-shell/extensions directory (took me a while to figure that out, by the process of elimination) and was able to log in, reinstall the extensions, and everything is working so far.

Comment 3 Jiri Eischmann 2018-05-02 13:11:26 UTC
The crash data points to code that is not part of standard GNOME Shell, it must have been brought in by some extension that is not compatible with the new version of GNOME Shell.
You don't have to remove the extensions, you can disable them by this command:
gsettings set org.gnome.shell disable-user-extensions true

Comment 4 Zdenek Chmelar 2018-05-02 13:29:45 UTC
I have got a hint the extensions could be the root cause of my issue as well:
 - All default Fedora extensions were disabled in my previous installation. 
 - The only active extension was "internet-radio". I disabled and deleted this one.
Still I wasn't able to login to desktop.

Next, I renamed whole ".local" directory and let the system to create new one during new login. No success, login still failed.

Next, I renamed whole ".config" and let the system to create new one. 
This time, I was able to login to the desktop but an error "On no! Something has gone wrong." appeared. I tried new login, login with system restarts but I'm getting the same error.

Strange is I'm able to browse all apps (via "Win" key), start them or start Settings from Activities menu. But once I leave the Activities by clicking on the opened application, I see just and only the "Oh no" error message. I can't get rid of it.

Comment 5 Zdenek Chmelar 2018-05-02 14:34:55 UTC
Created attachment 1430091 [details]
New log file

Attaching actual errors in journal.

Comment 6 Zdenek Chmelar 2018-05-02 15:29:53 UTC
I just updated my virtual test system (F28) and ended with the same error like above. 
This test system is default Fedora installation (no extensions, no 3rd party repos, etc).
This issue is not caused with extensions or obsolete configuration in the home directory.
Seems there are some crashes in gnome-settings-daemon-3.28.0-1.fc28.x86_64

Comment 7 dsp3 2018-05-02 16:20:35 UTC
Same issue. I can login to Plasma, but not to any version of Gnome.

Comment 8 Jiri Eischmann 2018-05-02 16:27:11 UTC
(In reply to Zdenek Chmelar from comment #6)
> I just updated my virtual test system (F28) and ended with the same error
> like above. 
> This test system is default Fedora installation (no extensions, no 3rd party
> repos, etc).
> This issue is not caused with extensions or obsolete configuration in the
> home directory.
> Seems there are some crashes in gnome-settings-daemon-3.28.0-1.fc28.x86_64

How come you have 3.28.0-1 on your upgraded system? Fedora 28 already includes update to GNOME 3.28.1, is it available to you in updates, can you confirm the issue with the update?

Comment 9 Zdenek Chmelar 2018-05-02 16:37:45 UTC
(In reply to Jiri Eischmann from comment #8)

> How come you have 3.28.0-1 on your upgraded system? Fedora 28 already
> includes update to GNOME 3.28.1, is it available to you in updates, can you
> confirm the issue with the update?

My apologies - copy/paste mistake. 
Virtual machine as well as laptop have both the same version: 
gnome-settings-daemon-3.28.1-1.fc28.x86_64

Comment 10 Jiri Eischmann 2018-05-02 16:50:36 UTC
I'm reassigning this issue to Florian Muellner as the current GS maintainer in Fedora.
I'll also ask the QA team if it's something they can reproduce.

Comment 11 Kamil Páral 2018-05-02 16:54:43 UTC
This is the actual problem:

May 02 14:55:37 infinity gsd-xsettings[2007]: Settings schema 'org.cinnamon.desktop.a11y.applications' is not installed
May 02 14:55:38 infinity systemd-coredump[2201]: Process 2007 (gsd-xsettings) of user 1000 dumped core.

After installing cinnamon-desktop the problem is resolved and you can log in. Lukas Brabec and Frantisek Zatloukal debugged the same issue today. I have no idea why gnome-settings-daemon is looking for cinnamon schema, because on both system only GNOME was installed, nothing else. I couldn't reproduce on my system or in a VM, though.

Comment 12 František Zatloukal 2018-05-02 17:05:06 UTC
Created attachment 1430225 [details]
GNOME crash right after login

Comment 13 František Zatloukal 2018-05-02 17:08:11 UTC
Created attachment 1430226 [details]
dnf update log

Comment 14 Lukas Brabec 2018-05-02 17:53:43 UTC
This seems to be related: https://bugzilla.redhat.com/show_bug.cgi?id=1573546

Comment 15 Matthew Saltzman 2018-05-02 18:28:24 UTC
I have

caribou.x86_64                             0.4.21-5.fc27                 @fedora
caribou-gtk2-module.x86_64                 0.4.21-5.fc27                 @fedora
caribou-gtk3-module.x86_64                 0.4.21-5.fc27                 @fedora
python3-caribou.noarch                     0.4.21-5.fc27                 @fedora

and no cinnamon packages installed. After deleting and reinstalling extensions, I can log in to regular gnome-shell. Maybe my issue is different?

Comment 16 Kamil Páral 2018-05-02 18:37:44 UTC
Matthew, if you have

gsd-xsettings: Settings schema 'org.cinnamon.desktop.a11y.applications' is not installed

in your journal, then it is the same issue I'm talking about (Zdenek has it there as well in commen 5, as well as Lukas and Frantisek), otherwise it's a different one.

As another piece of information, the problem didn't occur on my computers, however I removed all orphaned packages (including caribou) directly after upgrade. Might be related.

Comment 17 Zdenek Chmelar 2018-05-02 19:43:44 UTC
I found those 4 caribou packages installed on my system. 
After their removal, I was able to login to the desktop (Wayland) and complete the upgrade settings.
This bug update is being written from Fedora 28 desktop :-)
Thank you all for excellent support and help!

Comment 18 todd.vernick 2018-05-02 20:17:24 UTC
I couldn't login with my user, but root worked. It likely had something to do with extensions because after deleting .local dir I was able to login. The problem I still have is gdm login still crashes on boot. I have to use startx to login to my desktop so something is still crashing.

Comment 19 Matthew Miller 2018-05-02 21:39:47 UTC
Let's not mix this bug up with a lot of different problems. I'm going to go ahead and close this as a duplicate of the bug that the original report matches. If you have other upgrade-and-can't-login issues, please file them separately.

*** This bug has been marked as a duplicate of bug 1573546 ***

Comment 20 shobhitagarwal122 2018-05-04 23:02:03 UTC
Hello, whoever made this post. I was facing a similar problem and was going nuts. The root of the issue for me was that after upgrading, I was on the default GNOME theme that I think runs on Wayland. Before you login, click on the settings button and change it to the GNOME-Xorg theme. Hope this works!

Comment 21 Herald van der Breggen 2018-05-06 13:12:48 UTC
(In reply to Matthew Saltzman from comment #2)
> 
> In my case, the problem turned out to be related to extensions installed
> from http://extensions.gnome.org. I had caffeine and system-monitor
> installed in F27 and after upgrade to F28 I couldn't log in on the desktop.
> Logs showed gnome-shell crashing with signal 5. I removed the
> ${HOME}/.local/share/gnome-shell/extensions directory (took me a while to
> figure that out, by the process of elimination) and was able to log in,
> reinstall the extensions, and everything is working so far.

Thanks, this helped me out!

Comment 22 Pavel Studeník 2018-05-06 13:35:31 UTC
Hello, I can't login to my account after upgrade as well. And it looks like some different issue.

I received following traceback:

kvě 06 15:33:37 localhost.localdomain gnome-shell[2104]: Object Clutter.Clone (0x56332635b4d0), has been already finalized. Impossible to get any property from it.
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: == Stack trace for context 0x563324cbb200 ==
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #0 0x7ffd0422da10 b   resource:///org/gnome/shell/ui/tweener.js:73 (0x7feea45c7cd0 @ 9)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #1 0x7ffd0422dab0 b   resource:///org/gnome/shell/ui/tweener.js:105 (0x7feea45c7f78 @ 36)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #2 0x7ffd0422db50 b   resource:///org/gnome/shell/ui/tweener.js:92 (0x7feea45c7de0 @ 52)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #3 0x7ffd0422e730 I   resource:///org/gnome/gjs/modules/tweener/tweener.js:208 (0x7feea45d2918 @ 54)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #4 0x7ffd0422e880 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:337 (0x7feea45d29a0 @ 1626)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #5 0x7ffd0422e930 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:350 (0x7feea45d2a28 @ 100)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #6 0x7ffd0422e9c0 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:365 (0x7feea45d2ab0 @ 10)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #7 0x7ffd0422ea40 I   resource:///org/gnome/gjs/modules/signals.js:128 (0x7feea45cff78 @ 386)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #8 0x7ffd0422ea90 I   resource:///org/gnome/shell/ui/tweener.js:207 (0x7feea45cf5e8 @ 159)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #9 0x7ffd0422eb00 I   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7feea45b5de0 @ 71)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #10 0x7ffd0422eb00 I   resource:///org/gnome/shell/ui/tweener.js:182 (0x7feea45cf560 @ 15)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: == Stack trace for context 0x563324cbb200 ==
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #0 0x7ffd0422da10 b   resource:///org/gnome/shell/ui/tweener.js:80 (0x7feea45c7cd0 @ 82)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #1 0x7ffd0422dab0 b   resource:///org/gnome/shell/ui/tweener.js:105 (0x7feea45c7f78 @ 36)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #2 0x7ffd0422db50 b   resource:///org/gnome/shell/ui/tweener.js:92 (0x7feea45c7de0 @ 52)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #3 0x7ffd0422e730 I   resource:///org/gnome/gjs/modules/tweener/tweener.js:208 (0x7feea45d2918 @ 54)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #4 0x7ffd0422e880 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:337 (0x7feea45d29a0 @ 1626)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #5 0x7ffd0422e930 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:350 (0x7feea45d2a28 @ 100)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #6 0x7ffd0422e9c0 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:365 (0x7feea45d2ab0 @ 10)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #7 0x7ffd0422ea40 I   resource:///org/gnome/gjs/modules/signals.js:128 (0x7feea45cff78 @ 386)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #8 0x7ffd0422ea90 I   resource:///org/gnome/shell/ui/tweener.js:207 (0x7feea45cf5e8 @ 159)
kvě 06 15:33:37 localhost.localdomain gnome-shell[2104]: Object Clutter.Clone (0x56332635b4d0), has been already finalized. Impossible to set any property to it.
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #9 0x7ffd0422eb00 I   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7feea45b5de0 @ 71)
kvě 06 15:33:37 localhost.localdomain org.gnome.Shell.desktop[2104]: #10 0x7ffd0422eb00 I   resource:///org/gnome/shell/ui/tweener.js:182 (0x7feea45cf560 @ 15)
kvě 06 15:33:40 localhost.localdomain unix_chkpwd[4557]: password check failed for user (pavel)

Comment 23 Pavel Studeník 2018-05-06 13:57:07 UTC
Resolved. The extensions is possible disable by shell and second problem is that the keyboard in gdm doesn't show correct keyboard code (cs/en) .

Comment 24 EnricoD 2018-05-26 14:53:50 UTC
Hi Guys,

I had the same issue. After the update of my desktop computer (Octa Core AMD system) I couldn't login via GDM to a Gnome-Session with my "normal" user.

If I logged in as ROOT everything works except the terminal. After I renamed the home directory of my "normal" user and create an new empty one, I could loggin successful. But the interface was mostly in english (before it was German).

I read this thread and tried to install the "cinnamon-desktop" but this wasn't the solution of my problem. Because this packages was already installed.

So I shoutout some foul-mouthed word, because I believed, that I had to resetup my Desktop to my wishes. ... But by the way the terminal wasn't still working. That's an real issue for me. So I looked for a solution to solve my terminal problem and I found a german solution (http://www.hack23.de/blog/2018/05/fedora-28-upgrade-problem-mit-locale-settings/) ...

The solution is to install the local glibc package ... for Germany ... "dnf install glibc-langpack-de" ... THIS SOLUTION SOLVES ALSO MY LOGIN PROBLEM! Now everythink works fine again.

Comment 25 Matthew Saltzman 2018-05-26 16:33:09 UTC
In case anyone lands here with the plugin issue, the plugin causing the problem is System-Monitor. There is an update at https://extensions.gnome.org and if you update the extension before upgrading Fedora, you should be fine, AFAIK.

Comment 26 Steeve McCauley 2018-05-28 12:42:58 UTC
There seems to be an issue with locales after upgrade.  My wife uses LANG=fr_CA.UTF-8 and we had problems with login and running gnome-terminal on her account, from xterm I managed to run gnome terminal with,

$ LANG=en_CA.UTF-8 gnome-terminal

after installing the glibc langpack I was able to run gnome-terminal from her account,

glibc-langpack-en-2.27-15.fc28.x86_64
glibc-langpack-fr-2.27-15.fc28.x86_64

But I still have trouble logging in from the lock screen or from gdm with multiple users (more than two).  If I login both users, and then switch users (switch user menu is missing but that's another issue) by locking the screen and choosing swtich users from there, it will almost always require a reboot because I am not able to authenticate and get back to any session, often it just locks up the system.

I'm still not sure what the issue is that is causing the auth failure, and haven't found anything definitive in the journal.

This is not a duplicate of bug 1573546, which has to do with cinnamon/caribou, and do not believe this bug should be closed yet.

Comment 27 Artem Gromov 2018-07-07 16:04:32 UTC
I ran into that problem too.

gnome-shell-3.28.2-1.fc28.x86_64

I have following locale settings:

LANG=en_US.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8

I had just been flying by the seat of my pants when I installed following packages:

langpacks-en-1.0-12.fc28.noarch
langpacks-ru-1.0-12.fc28.noarch

And I became able to login again!=)


Note You need to log in before you can comment on or make changes to this bug.