Bug 1573546 - GNOME crashes (including during the update transaction) if caribou is installed and cinnamon-settings-daemon is not (with caribou-0.4.21-8.fc28)
Summary: GNOME crashes (including during the update transaction) if caribou is install...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: caribou
Version: 28
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1573337 1573683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 16:23 UTC by Giovanni Campagna
Modified: 2018-05-03 15:26 UTC (History)
15 users (show)

Fixed In Version: caribou-0.4.21-9.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 15:26:37 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1568670 None CLOSED gnome-shell should obsolete caribou in F28+ 2019-05-21 21:14:50 UTC

Internal Links: 1568670

Description Giovanni Campagna 2018-05-01 16:23:54 UTC
Description of problem:
Upgrading to F28 leaves caribuou installed (from F27).

The F28 version of caribou is incompatible with GNOME (because GNOME replaced the OSK) and refers to the Cinnamon GSettings schema instead.
The GSettings reference is made in a file read by gnome-settings-daemon (specifically, in /usr/lib64/gnome-settings-daemon-3.0/gtk-modules/caribou-gtk-daemon.desktop ), which then tries to load a GSettings key that does not exist and crashes.

In turn this makes logging into GNOME impossible until caribou is manually uninstalled.

Version-Release number of selected component (if applicable):
caribou-0.4.21-8.fc28.x86_64
gnome-settings-daemon-3.28.1-1.fc28.x86_64

How reproducible:
Not sure, maybe it's a weird configuration.

Steps to Reproduce:
1. Upgrade to F28
2. Log out/log in again

Actual results:
Crash of gnome-settings-daemon
( https://retrace.fedoraproject.org/faf/reports/bthash/d32eb328a235a77d8c5f9a79f55b2acb2d880d70 )

Expected results:
No crash

Comment 1 Jason Tibbitts 2018-05-01 16:36:24 UTC
I do not understand why you have reported your bug against fedora-obsolete-packages.  Reassigning to caribou.

Comment 2 Giovanni Campagna 2018-05-01 22:06:56 UTC
I have reported the bug against fedora-obsolete-packages because that's the vehicle to remove a package on distro upgrade: the newer version of fedora-obsolete-packages should Conflict/Obsoletes the old version of caribou, causing it to go away during upgrades.

Comment 3 Kevin Fenzi 2018-05-01 23:15:52 UTC
*** Bug 1573337 has been marked as a duplicate of this bug. ***

Comment 4 Kevin Fenzi 2018-05-01 23:16:46 UTC
(In reply to Giovanni Campagna from comment #2)
> I have reported the bug against fedora-obsolete-packages because that's the
> vehicle to remove a package on distro upgrade: the newer version of
> fedora-obsolete-packages should Conflict/Obsoletes the old version of
> caribou, causing it to go away during upgrades.

But caribou is not obsolete, it's not being used/still used by cinnamon.

Comment 5 Adam Williamson 2018-05-01 23:21:00 UTC
Right. If we still need caribou around, we need to change this caribou/cinnamon stuff such that GNOME systems without cinnamon installed don't suddenly start crashing.

Comment 6 Matthew Miller 2018-05-01 23:22:55 UTC
This caribou version (caribou-0.4.21-8.fc28.x86_64) is in updates-testing. It does not seem to happen with the previous version.

In fact, simply installing this package from without cinnamon installed crashes gnome shell immediately.

Comment 7 Matthew Miller 2018-05-01 23:24:13 UTC
specifically gsd-xsettings[22355]: Settings schema 'org.cinnamon.desktop.a11y.applications' is not installed

Comment 8 Fedora Update System 2018-05-01 23:50:31 UTC
cinnamon-3.8.1-1.fc28 caribou-0.4.21-9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4c9e1c937c

Comment 9 Mirek Svoboda 2018-05-02 08:17:06 UTC
I am affected too.
Trying to test caribou-0.4.21-9.fc28 downloaded from Koji, but cannot find required python3-caribou dependency neither on Koji nor Bodhi: 
Error: 
 Problem 1: conflicting requests
  - nothing provides python3-caribou = 0.4.21-9.fc28 needed by caribou-0.4.21-9.fc28.x86_64

Comment 10 leigh scott 2018-05-02 08:28:55 UTC
(In reply to Mirek Svoboda from comment #9)
> I am affected too.
> Trying to test caribou-0.4.21-9.fc28 downloaded from Koji, but cannot find
> required python3-caribou dependency neither on Koji nor Bodhi: 
> Error: 
>  Problem 1: conflicting requests
>   - nothing provides python3-caribou = 0.4.21-9.fc28 needed by
> caribou-0.4.21-9.fc28.x86_64

Look under noarch for python3-caribou

https://koji.fedoraproject.org/koji/buildinfo?buildID=1078272

Comment 11 Robin Stocker 2018-05-02 09:12:39 UTC
Landed here after some Googling. Maybe this would have helped find it quicker:

gnome-session[3000]: gnome-session-binary[3000]: WARNING: Application 'org.gnome.SettingsDaemon.XSettings.desktop' killed by si
gnal 5
gnome-session-binary[3000]: WARNING: Application 'org.gnome.SettingsDaemon.XSettings.desktop' killed by signal 5
systemd-coredump[3510]: Process 3298 (gsd-xsettings) of user 1000 dumped core.

And as others have noted, until the update is available a "sudo dnf remove caribou" fixes it.

Comment 12 Bojan Smojver 2018-05-02 09:51:16 UTC
(In reply to Robin Stocker from comment #11)

> And as others have noted, until the update is available a "sudo dnf remove
> caribou" fixes it.

Yeah, took me the whole morning to land here as well, after which I did the above and got my session back. At one point I was even running xfce that I just installed and scratching my head about what happened to my laptop v. Gnome. :-)

Comment 13 aappddeevv 2018-05-02 12:09:23 UTC
Same issue. gnome-shell was crashing upon login after the F27->F28 upgrade. Sometimes, I could login on the 2nd attempt. Removing caribou fixed that. I was also getting an issue with unlocking some secrets password that my password was not sufficient if I was able to login at all (with that secrets issue).

Comment 14 aappddeevv 2018-05-02 12:10:30 UTC
Note that I was not running cinnanmon.

Comment 15 Milan Zink 2018-05-02 12:50:26 UTC
Exactly the same issue here. Happened after upgrade F27->F28. Never used cinnamon.

Comment 16 Fedora Update System 2018-05-02 13:13:47 UTC
caribou-0.4.21-9.fc28, cinnamon-3.8.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4c9e1c937c

Comment 17 Peter Zagar 2018-05-02 16:34:16 UTC
Problem persists even after upgrading the mentioned pacakges.

Installed Packages
caribou.x86_64                                                                                      0.4.21-9.fc28                                                             @updates-testing
caribou-gtk2-module.x86_64                                                                          0.4.21-9.fc28                                                             @updates-testing
caribou-gtk3-module.x86_64                                                                          0.4.21-9.fc28                                                             @updates-testing
cinnamon.x86_64                                                                                     3.8.1-1.fc28                                                              @updates-testing
cinnamon-applet-blueberry.noarch                                                                    1.1.20-6.fc28                                                             @fedora         
cinnamon-control-center.x86_64                                                                      3.8.0-1.fc28                                                              @updates        
cinnamon-control-center-filesystem.x86_64                                                           3.8.0-1.fc28                                                              @updates        
cinnamon-desktop.x86_64                                                                             3.8.0-1.fc28                                                              @updates        
cinnamon-menus.x86_64                                                                               3.8.0-1.fc28                                                              @updates        
cinnamon-screensaver.x86_64                                                                         3.8.0-1.fc28                                                              @updates        
cinnamon-session.x86_64                                                                             3.8.1-1.fc28                                                              @updates        
cinnamon-settings-daemon.x86_64                                                                     3.8.0-1.fc28                                                              @updates        
cinnamon-themes.noarch                                                                              1:1.6.2-1.fc28                                                            @updates        
cinnamon-translations.noarch                                                                        3.8.0-1.fc28                                                              @updates        
python2-caribou.noarch                                                                              0.4.21-9.fc28                                                             @@commandline   
python3-caribou.noarch                                                                              0.4.21-9.fc28                                                             @updates-testingInstalled Packages
caribou.x86_64                                                                                      0.4.21-9.fc28                                                             @updates-testing
caribou-gtk2-module.x86_64                                                                          0.4.21-9.fc28                                                             @updates-testing
caribou-gtk3-module.x86_64                                                                          0.4.21-9.fc28                                                             @updates-testing
cinnamon.x86_64                                                                                     3.8.1-1.fc28                                                              @updates-testing
cinnamon-applet-blueberry.noarch                                                                    1.1.20-6.fc28                                                             @fedora         
cinnamon-control-center.x86_64                                                                      3.8.0-1.fc28                                                              @updates        
cinnamon-control-center-filesystem.x86_64                                                           3.8.0-1.fc28                                                              @updates        
cinnamon-desktop.x86_64                                                                             3.8.0-1.fc28                                                              @updates        
cinnamon-menus.x86_64                                                                               3.8.0-1.fc28                                                              @updates        
cinnamon-screensaver.x86_64                                                                         3.8.0-1.fc28                                                              @updates        
cinnamon-session.x86_64                                                                             3.8.1-1.fc28                                                              @updates        
cinnamon-settings-daemon.x86_64                                                                     3.8.0-1.fc28                                                              @updates        
cinnamon-themes.noarch                                                                              1:1.6.2-1.fc28                                                            @updates        
cinnamon-translations.noarch                                                                        3.8.0-1.fc28                                                              @updates        
python2-caribou.noarch                                                                              0.4.21-9.fc28                                                             @@commandline   
python3-caribou.noarch                                                                              0.4.21-9.fc28                                                             @updates-testing

Comment 18 Matthew Miller 2018-05-02 16:43:29 UTC
(In reply to Peter Zagar from comment #17)
> Problem persists even after upgrading the mentioned pacakges.


Hmmm, that's strange -- the problem is solved for me by installing cinnamon-settings-daemon even without the updated caribou. I haven't tried the new update yet, though.

Comment 19 Peter Zagar 2018-05-02 16:44:58 UTC
I am using Cinnamon, contrary to some earlier posters.

When i try to restart crashed Cinnamon i catch this in journal.

abrt-notification[12253]: Process 12160 (cinnamon) crashed in _GLOBAL__sub_I_Unified_cpp_js_src12.cpp()

Comment 20 leigh scott 2018-05-02 16:59:45 UTC
(In reply to Peter Zagar from comment #17)
> Problem persists even after upgrading the mentioned pacakges.
> 
> Installed Packages
> caribou.x86_64                                                              
> 0.4.21-9.fc28                                                            
> cinnamon-desktop.x86_64                                                     
> cinnamon-settings-daemon.x86_64    

You will need to look elsewhere for you issue as it isn't this!
If the cinnamon packages were installed the broken caribou package wouldn't generate the missing schema error.
The fixed caribou package use the original gnome schema so wont generate the missing schema error.

Comment 21 leigh scott 2018-05-02 17:05:46 UTC
(In reply to Matthew Miller from comment #18)
> (In reply to Peter Zagar from comment #17)
> > Problem persists even after upgrading the mentioned pacakges.
> 
> 
> Hmmm, that's strange -- the problem is solved for me by installing
> cinnamon-settings-daemon even without the updated caribou. I haven't tried
> the new update yet, though.

This was the commit that broke it


https://src.fedoraproject.org/cgit/rpms/caribou.git/commit/?id=36dbd49a89d75be3a76bb43c88b8f69954a7de29


and this is the revert to fix


https://src.fedoraproject.org/cgit/rpms/caribou.git/commit/?id=27f944bb0b3c9c746e9eb37db10ee36a77a75587

Comment 22 Peter Zagar 2018-05-02 17:26:33 UTC
I reverted to 0.4.21-8 packages but cinnamon still crashes.
I guess i'll try to provide some more detail to Cinnamon bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=1573643

Thanks for all the help!

Comment 23 Adam Williamson 2018-05-02 20:38:16 UTC
aappddeevv / Milan: "not running cinnamon" was basically the *problem* - if you *did* have Cinnamon installed, the crash didn't happen. The crash occurred if you had caribou and GNOME installed, but not Cinnamon (and you updated to the problematic caribou from updates-testing). The bad update was unpushed yesterday and a new update submitted that doesn't have the problem. The bad update never reached stable, it was only in updates-testing for 9 hours, you just got unlucky :/

Peter, you definitely have a different issue, as Leigh said.

Comment 24 Matthew Miller 2018-05-02 21:39:47 UTC
*** Bug 1573683 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2018-05-03 15:26:37 UTC
caribou-0.4.21-9.fc28, cinnamon-3.8.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.