Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573762 - Multiple Slabsize value for VDO volumes not supported by Gdeploy
Summary: Multiple Slabsize value for VDO volumes not supported by Gdeploy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Sachidananda Urs
QA Contact: bipin
URL:
Whiteboard:
Depends On: 1573138
Blocks: 1581561
TreeView+ depends on / blocked
 
Reported: 2018-05-02 08:26 UTC by Gobinda Das
Modified: 2018-06-21 03:34 UTC (History)
11 users (show)

Fixed In Version: gdeploy-2.0.2-27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-21 03:33:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1958 0 None None None 2018-06-21 03:34:48 UTC

Description Gobinda Das 2018-05-02 08:26:56 UTC
Description of problem:
Currently cockpit generates conf file with multiple slabsizes for multiple devices, but gdeploy does not support slabsizes with comma separated

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Fails with multiple slabsizes

Expected results:
Should work for multiple slab sizes for multiple devices 

Additional info:

Comment 1 Sachidananda Urs 2018-05-03 06:11:45 UTC
Commit: https://github.com/gluster/gdeploy/pull/509/commits/b4624b7ccfd30 fixes the issue.

Comment 5 SATHEESARAN 2018-06-06 10:52:21 UTC
Verfied by the bug with the latest cockpit-dashboard-0.11.25. Now adding multiple slab size seems working.

Output:
[vdo1:10.70.45.29]
action=create
devices=sdb,sde
names=vdo_sdb,vdo_sde
logicalsize=164840G,3000G
blockmapcachesize=128M
readcache=enabled
readcachesize=20M
emulate512=on
writepolicy=auto
ignore_vdo_errors=no
slabsize=32G,32G

Comment 7 errata-xmlrpc 2018-06-21 03:33:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1958


Note You need to log in before you can comment on or make changes to this bug.