Bug 1573789 - Come up with new FQDN wizard which will allow user to enter fqdn for all hosts during Gluster deployment in Cockpit
Summary: Come up with new FQDN wizard which will allow user to enter fqdn for all host...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.5
: ---
Assignee: Gobinda Das
QA Contact: bipin
URL:
Whiteboard:
Depends On: 1574881
Blocks: cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-05-02 09:41 UTC by Gobinda Das
Modified: 2018-07-31 15:27 UTC (History)
6 users (show)

Fixed In Version: cockpit-ovirt-0.11.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:27:16 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2?
sasundar: planning_ack?
rule-engine: devel_ack+
bshetty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90921 0 master MERGED FQDN wizard to enter 2nd and 3rd host front end ip 2018-05-17 12:03:34 UTC
oVirt gerrit 91345 0 ovirt-4.2 MERGED FQDN wizard to enter 2nd and 3rd host front end ip 2018-05-17 12:03:46 UTC
oVirt gerrit 91463 0 ovirt-4.2 MERGED Show FQDN wizard only when gdeploy supported 2018-05-23 11:38:23 UTC
oVirt gerrit 91531 0 ovirt-4.2 MERGED Show FQDN wizard only when gdeploy supported 2018-05-23 11:38:29 UTC

Description Gobinda Das 2018-05-02 09:41:16 UTC
Description of problem:
Currently we are doing HE deployment by giving IP.So to auto create other Storage Domain, if will use IP then creation may fail because the gluster ip and HE ip may belongs to different networks and both may not be reachable from each other.So in deployment wizard we need to ask user to enter fqdn if auto add 2nd and 3rd hosts and SD needed.
This is optional to user. 

Version-Release number of selected component (if applicable):


How reproducible:
100% if both ips not reachable with each other.

Steps to Reproduce:
1.
2.
3.

Actual results:
Fails if both ips not reachable with each other

Expected results:
Auto create other SD should work

Additional info:

Comment 2 bipin 2018-05-31 13:15:52 UTC
Could verify the bug in the latest cockpit-ovirt-dashboard-0.11.25-1.
Adding the screeshot for the newly added FQDN wizard.

Comment 4 Red Hat Bugzilla Rules Engine 2018-06-18 16:14:47 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 7 Sandro Bonazzola 2018-07-31 15:27:16 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.