Bug 1574881 - During HE deployment auto add 2nd and 3rd Hosts is failing due to ansible error
Summary: During HE deployment auto add 2nd and 3rd Hosts is failing due to ansible error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Gluster
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.5
: 2.2.21
Assignee: Simone Tiraboschi
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1466132 1523568 1573789
TreeView+ depends on / blocked
 
Reported: 2018-05-04 09:10 UTC by Gobinda Das
Modified: 2018-07-31 15:28 UTC (History)
15 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.21
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-31 15:28:47 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90916 0 master MERGED During HE deployment auto add 2nd and 3rd Hosts 2018-09-03 09:33:14 UTC
oVirt gerrit 91048 0 ovirt-hosted-engine-setup-2.2 MERGED During HE deployment auto add 2nd and 3rd Hosts 2018-05-15 14:00:23 UTC
oVirt gerrit 91384 0 master MERGED Executing add 2nd and 3rd host tasks asynchronously 2018-09-03 09:32:54 UTC
oVirt gerrit 91536 0 ovirt-hosted-engine-setup-2.2 MERGED Executing add 2nd and 3rd host tasks asynchronously 2018-05-23 12:15:45 UTC

Description Gobinda Das 2018-05-04 09:10:56 UTC
Description of problem:
During dev test functionality was working in ansible-2.5
But now in ansible-2.5.2 it's failing.

Below is the error:

[ ERROR ]  [WARNING]: The loop variable 'item' is already in use. You should set the       
[ ERROR ] `loop_var` value in the `loop_control` option for the task to something else to        
[ ERROR ] avoid variable collisions and unexpected behavior.        
[ ERROR ] Failed to execute stage 'Closing up': Failed executing ansible-playbook 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Failing to add other hosts and SD creation

Expected results:
Should auto add other 2 hosts and create other Storage Domains

Additional info:

Comment 1 Ryan Barry 2018-05-04 10:38:16 UTC
Sahina, is this a blocker?

Comment 2 Gobinda Das 2018-05-04 15:30:57 UTC
This should not be blocker.As only HE deployment working fine.
Only issue with gluster deployment + HE deployment.

Comment 3 Nikolai Sednev 2018-05-31 12:16:55 UTC
What do you mean by describing "During HE deployment auto add 2nd and 3rd Hosts is failing"?
What are reproduction steps?
During deployment there is no option to add second and third ha-host automatically in otopi, there is no such option.

Comment 4 Gobinda Das 2018-05-31 15:06:58 UTC
Hi Nikolai,
 We have new feature in RHHI-2.0 to auto add 2nd and 3rd hosts after HE deployment.

Here are the ralated bzs for feature.
https://bugzilla.redhat.com/show_bug.cgi?id=1573789
https://bugzilla.redhat.com/show_bug.cgi?id=1523568

Comment 5 SATHEESARAN 2018-06-21 06:39:20 UTC
This

Comment 6 SATHEESARAN 2018-06-21 06:42:33 UTC
This bug can't be verified as the automatic addition of hosts to the cluster is blocked with BZ 1466132

Moving the target milestone to 4.2.5 same as the dependent bug.

Comment 7 bipin 2018-07-12 08:25:00 UTC
Tested the bug on ovirt-hosted-engine-setup-2.2.23-1 and ansible-2.6.0-5. 
Could see the hosts 2 and 3 successfully added in the RHV-M. No sign of ansible error. So moving to verified

Logs of successfully HE deployment @http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1574881/

Comment 8 Sandro Bonazzola 2018-07-31 15:28:47 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.