Bug 1573798 - Fix setting tx_queue_size when rx_queue_size is not set
Summary: Fix setting tx_queue_size when rx_queue_size is not set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z2
: 13.0 (Queens)
Assignee: Lee Yarwood
QA Contact: nova-maint
URL:
Whiteboard:
Depends On: 1573795
Blocks: 1573799
TreeView+ depends on / blocked
 
Reported: 2018-05-02 09:48 UTC by Lee Yarwood
Modified: 2019-09-09 15:22 UTC (History)
14 users (show)

Fixed In Version: openstack-nova-17.0.5-2.d7864fbgit.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1573795
: 1573799 (view as bug list)
Environment:
Last Closed: 2018-08-29 16:40:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 565573 0 None master: MERGED nova: libvirt: fix setting tx_queue_size when rx_queue_size is not set (I0e33ffdcad839f685d7e88b55afaedaf2a2f3a00) 2018-07-19 01:44:44 UTC
Red Hat Product Errata RHBA-2018:2588 0 None None None 2018-08-29 16:41:08 UTC

Description Lee Yarwood 2018-05-02 09:48:28 UTC
+++ This bug was initially created as a clone of Bug #1573795 +++

Description of problem:
Caused by a typo in Ib6d4a2d6b9072db42d11ecdde0950cf7a7781944.

https://review.openstack.org/#/c/565573/

Version-Release number of selected component (if applicable):
18.0.0

How reproducible:
Always

Steps to Reproduce:
1. Use a vhostuser VIF with only tx_queue_size set.

Actual results:
vhost_tx_queue_size not set when rx_queue_size is not provided.

Expected results:
vhost_tx_queue_size set when rx_queue_size is not provided.

Additional info:

Comment 1 Eoghan Glynn 2018-05-02 10:47:04 UTC
https://review.openstack.org/565573 landed upstream, https://code.engineering.redhat.com/gerrit/137511 has one +2 so landing shortly.

Comment 9 Joanne O'Flynn 2018-08-13 10:07:55 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 10 Joe H. Rahme 2018-08-28 14:00:54 UTC
As seen agreed between devel and QE, this ticket will not require manual verification. Dropping the Severity.

Comment 12 errata-xmlrpc 2018-08-29 16:40:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2588


Note You need to log in before you can comment on or make changes to this bug.