Bug 1573913 - upload image dialog - test connection button should be displayed for any DC
Summary: upload image dialog - test connection button should be displayed for any DC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Daniel Erez
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
: 1573844 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 13:55 UTC by Daniel Erez
Modified: 2018-06-26 08:35 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:35:20 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90848 master MERGED webadmin: upload image dialog - test connection for any DC 2018-05-08 13:38:16 UTC
oVirt gerrit 91061 ovirt-engine-4.2 MERGED webadmin: upload image dialog - test connection for any DC 2018-05-14 14:41:30 UTC

Description Daniel Erez 2018-05-02 13:55:17 UTC
The 'Test Connection' button in upload image dialog is displayed only for DC level >= 4.2. However, we can display the 'Test Connection' button for any DC level, as we currently don't test connection to the daemon. I.e. test connection is done by invoking GET on '/info' resource to the proxy service (added in 4.2), which only returns the version of the proxy. (note: we currently require to update the proxy service when upgrading the engine, so we don't need the check if it supports '/info').

Comment 1 Daniel Erez 2018-05-02 15:03:38 UTC
*** Bug 1573844 has been marked as a duplicate of this bug. ***

Comment 2 Yosi Ben Shimon 2018-06-10 11:52:30 UTC
Tested using:
ovirt-engine-4.2.4.2-0.1.el7_3.noarch

The "Test Connection" button is displayed in both 4.2 and 4.1 DC compatibility version.

Moving to VERIFIED.

Comment 3 Sandro Bonazzola 2018-06-26 08:35:20 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.