Bug 1573922 - [UPGRADES] "overcloud upgrade converge" should update Heat stack to persist changes
Summary: [UPGRADES] "overcloud upgrade converge" should update Heat stack to persist c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Jiri Stransky
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1561169
TreeView+ depends on / blocked
 
Reported: 2018-05-02 14:11 UTC by Marios Andreou
Modified: 2018-06-27 13:55 UTC (History)
11 users (show)

Fixed In Version: python-tripleoclient-9.2.1-9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576480 1576482 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:54:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1768586 None None None 2018-05-02 16:10:26 UTC
OpenStack gerrit 565828 None MERGED Update Heat stack on update/upgrade/ffwd converge 2020-09-14 23:17:24 UTC
OpenStack gerrit 567243 None MERGED Update Heat stack on update/upgrade/ffwd converge 2020-09-14 23:17:27 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:51 UTC

Description Marios Andreou 2018-05-02 14:11:02 UTC
Description of problem:
The OSP 13 upgrade related clis that is (openstack overcloud...) "upgrade" "update" and "ffwd-upgrade" 
are all currently *not* running a heat stack update. Instead they update the stored deployment plan in swift, especially to unset all OS::Heat::None resources set during the upgrade/update/ffwd-upgrade. 

However, the deployment code [1] isn't consulting the stored plan meaning subsequent stack updates (e.g. for scaling to add nodes) will still be broken as the 'nooped' resources will continue to be set to OS::Heat::None. 

[1] https://github.com/openstack/python-tripleoclient/blob/c09f50f1ad7f79dae5c67e5f047b3217c357ee74/tripleoclient/v1/overcloud_deploy.py#L369-L377


Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. run upgrade or ffwd-upgrade or update converge as the last step in the workflow: openstack overcloud ffwd-upgrade converge
2. Try to perform a heat stack update on the overcloud, e.g. to scale
3. OS::TripleO::DeploymentSteps  and other resources will not be applied (they are still set to https://github.com/openstack/tripleo-heat-templates/blob/e24316c4ecb659d120a2d6288e8e1a992ce8e0ff/environments/lifecycle/upgrade-prepare.yaml#L4-L8)


We can use one BZ to track the fix here more can be filed if necessary

Comment 1 Marios Andreou 2018-05-03 06:38:55 UTC
adding the alternative proposal from jistr in trackers. The goal is to reach consensus today on which one and merge for end of week.

Comment 2 Jiri Stransky 2018-05-03 11:44:12 UTC
Just a heads up -- either of the patches is likely to break or timeout the gating update job. I posted 2 related patches, linked via depends-on on the patch. (No need to link them here as they are just for CI.)

Given this and the fact that we'll need to backport to stable/queens too, i think landing it this week is not certain.

Comment 3 Marios Andreou 2018-05-07 12:36:58 UTC
reassigning to jistr and removing the tripleo-common alternative

Comment 4 Marios Andreou 2018-05-07 12:38:01 UTC
can you please clone this for update/upgrade/ffwd-upgrade as the qe team needs to test/track independently

Comment 6 Jiri Stransky 2018-05-09 14:51:51 UTC
Ok let's keep this one for upgrade, will clone for update + ffwd

Comment 16 Yurii Prokulevych 2018-05-31 12:15:25 UTC
Successfully scaled up extra compute after upgrade from RHOS-12 to RHOS-13 with python-tripleoclient-9.2.1-12.el7ost.noarch

Comment 18 errata-xmlrpc 2018-06-27 13:54:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.