Bug 157426 - Kernel panic at shutdown or when disconnecting ieee1394 disk
Kernel panic at shutdown or when disconnecting ieee1394 disk
Status: CLOSED DUPLICATE of bug 155472
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-11 11:29 EDT by Per Steinar Iversen
Modified: 2015-01-04 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 02:37:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2005-05-11 11:29:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050418 Fedora/1.7.7-2

Description of problem:
Sometimes a machine used for backups onto ieee1394 disks locks up completely.

Usually this happens a few seconds after disconnecting the drives, the drives have been dismounted for a considerable time before that. There is a single message on the screen, written here from a note:

Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065 spin_is_locked on uninitialized spinlock ddd1e81c (Not tainted)

At this point only power off seems to help.

This happens at long intervals, one or two weeks. It has also happened at shutdown, some time after disconnecting a drive.

The backups are large, about 200-250GB each.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Use ieee1394 disks.
2. Dismount and remove them.
3. Sometimes the machine locks up completely.

Actual Results:  Lockup, a single line on the console.

Expected Results:  Nothing, the machine should not panic.

Additional info:

This did not happen with earlier kernels.
Comment 1 Steve 2005-05-11 21:19:04 EDT
hi

I have had a kernel panic when shutting down my laptop, 3 times over the last week.

I don't have a 1394 drive.

Kernel panic - not syncing: 
drivers/block/cfq-iosched.c:1065 spin_is_locked on uninitialized 
spinlock cda4a41c (Not tainted)

Steve
Comment 2 Dave Jones 2005-05-17 02:37:58 EDT

*** This bug has been marked as a duplicate of 155472 ***

Note You need to log in before you can comment on or make changes to this bug.