Bug 155472 - (CFQ) Unplugging USB key causes kernel panic (cfq-iosched.c:1065: spin_is_locked)
Unplugging USB key causes kernel panic (cfq-iosched.c:1065: spin_is_locked)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 154672 154690 155961 155979 156050 156593 156750 157016 157275 157426 158326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-20 13:58 EDT by Sitsofe Wheeler
Modified: 2015-01-04 17:19 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 20:55:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2005-04-20 13:58:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Plugging and unplugging a USB key in GNOME seems to cause untold damage in the latest released Fedora Core 3 kernel. (With nvidia binary drivers the system locks up as soon as X is quit) Without any binary drivers (tested on an Duron with the nvidia driver *not loaded* and on a K6-II with an ATI Rage card) the following appears on shutdown:
Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on unititialized spinlock c5551c1c. (Not tainted)
(that was the Duron, the K6 said nearly the same but the address was c54aa81c)

Older kernels (e.g. kernel-2.6.10-1.770_FC3) do not seem to have this problem.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. Start the machine.
2. Log in to GNOME.
3. Plug USB key in and wait for USB key icon to appear on the desktop.
4. Press the right mouse button over the icon and go to Unmount.
5. Wait for icon to disappear.
6. Go to Actions -> Log Out. Select "Restart the computer" and click OK.

Actual Results:  A few services are shutdown (the last being cups) and then the following is printed:
Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on unititialized spinlock c5551c1c. (Not tainted)

Expected Results:  System should have shut down cleanly.

Additional info:

Quite possibly related to / a dup of bug #154764 (although I'd like to avoid the nvidia binary driver controvesy) or bug #155381 (the line number is different but then so is the kernel version).
Comment 1 Sitsofe Wheeler 2005-04-20 14:02:05 EDT
Bug #154690 is also a good dup candidate.
Comment 2 Sitsofe Wheeler 2005-04-20 14:25:05 EDT
I forgot one key step:
4.5. Physically remove the key from the machine.
Without this step the problem will not manifest itself.

I have tested this on a newer kernel-2.6.11-1.1251_FC4 (PS this kernel seems to
have some extra selinux stuff that causes trouble on FC3 in enforcing mode due
to xyz producing denied errors) and this is the output:
Kernel panic - not syncing: drivers/block/cfq-iosched.c:1070: spin_is_locked on
unititialized spinlock c55b6348. (Not tainted)

[<c01201db>] panic+0x3b/0x1b0
[<c028ef37>] cfq_exit_io_context+0x127/0x3b0
[<c0287a2f>] exit_io_context+0x3f/0x50
[<c0123d72>] do_exit+0x42/0x4d0
[<c01242db>] do_group_exit+0x9b/0x1b0
[<c01039e9>] syscall_call+0x7/0xb
Comment 3 Dave Jones 2005-04-21 19:11:49 EDT
Can you try the test kernel from
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/

and see if that fixes it ?
Comment 4 Carlos Rodrigues 2005-04-22 18:26:07 EDT
I'm seeing the same problem with an external USB 2.0 Lacie hard-drive.

Steps to reproduce:

1. Plug the drive or boot the machine with it already plugged in
2. mount
3. unmount
4. turn off the drive
5. reboot
6. (kernel panic)
Comment 5 Carlos Rodrigues 2005-04-22 18:42:27 EDT
I tried with 2.6.11-1.19_FC3, looks fixed. :)
Comment 6 Sitsofe Wheeler 2005-04-26 13:06:28 EDT
(sorry for the sloth like response on this)
Tested with two different keys on 2.6.11-1.19_FC3 and the problem errors on
shutdown no longer appear. The smug people who have been locking up machines
with their USB keys have been thwarted and davej saves the day again. Thanks for
the fast turn around.

Let's see, how shall we resolve this...
Comment 7 Dave Jones 2005-04-28 17:04:29 EDT
*** Bug 156050 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2005-04-28 17:05:43 EDT
reopening until this gets pushed out as an update.
Comment 9 Dave Jones 2005-05-02 15:25:25 EDT
*** Bug 156593 has been marked as a duplicate of this bug. ***
Comment 10 Boris Glawe 2005-05-02 15:40:26 EDT
Dave Jone's Kernel works for me and for many others. Where's the problem to
release a fixed kernel? USB-Sticks/devices are  used very heavily. This bug
damages fedora's  reputation a lot!?
Comment 11 Tim Waugh 2005-05-04 05:06:38 EDT
2.6.11-1.21_FC3 fixees the problem I was seeing in bug #156593.
Comment 12 Srihari Vijayaraghavan 2005-05-06 18:59:53 EDT
*** Bug 157016 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2005-05-09 19:59:49 EDT
*** Bug 156750 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2005-05-10 17:29:34 EDT
*** Bug 155961 has been marked as a duplicate of this bug. ***
Comment 15 Dave Jones 2005-05-17 02:38:15 EDT
*** Bug 157426 has been marked as a duplicate of this bug. ***
Comment 16 Dave Jones 2005-05-21 03:29:37 EDT
*** Bug 158326 has been marked as a duplicate of this bug. ***
Comment 17 Joseph Shraibman 2005-05-21 21:41:34 EDT
I suggest that 'kernel panic' be put in the subject somewhere to avoid dups.
Comment 18 Boris Glawe 2005-05-22 16:21:41 EDT
(In reply to comment #17)
> I suggest that 'kernel panic' be put in the subject somewhere to avoid dups.

I'd suggest  releasing a working kernel. I don't have this problem anymore with
Dave Jones's kernel (see comment 3).
Comment 19 Sitsofe Wheeler 2005-05-22 16:54:57 EDT
I'm normally loathe to change subjects because it causes unecessary spam to the
people cc'd, makes subjects so long they don't fit neatly in the bug lists and
leads to subject tug of wars (plus I did include a bit of the error for people
to search on AND if you do a search on body text then the words kernel panic
will show up PLUS if you use the secret bugzilla technique of searching bugs
that were marked as DUPLICATE then you often find bugs with subjects you are
expecting which then point to an open bug).

I'm not that convinced that this change will stop the dups but I'll make an
exception this once and apologise for spamming people.
Comment 20 Dave Jones 2005-05-23 16:17:27 EDT
*** Bug 154690 has been marked as a duplicate of this bug. ***
Comment 21 Dave Jones 2005-05-24 20:31:13 EDT
*** Bug 155979 has been marked as a duplicate of this bug. ***
Comment 22 Dave Jones 2005-05-26 19:56:58 EDT
*** Bug 154672 has been marked as a duplicate of this bug. ***
Comment 23 Joseph Shraibman 2005-05-26 20:49:15 EDT
Was this fixed in  2.6.11-1.27_FC3 ?
Comment 24 Dave Jones 2005-05-26 20:55:29 EDT
yes
Comment 25 Dave Jones 2005-06-04 03:11:06 EDT
*** Bug 157275 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.