Bug 1574300 - dict object' has no attribute 'master' while configure proxy settings
Summary: dict object' has no attribute 'master' while configure proxy settings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 03:17 UTC by Gan Huang
Modified: 2018-07-30 19:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Nodes are installed before masters during node bootstrapping and therefore master facts are not available. The required facts are set as defaults or obtained from the user's inventory file.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:59 UTC

Description Gan Huang 2018-05-03 03:17:29 UTC
Description of problem:
Trigger installation with proxy settings, installer failed at:

TASK [openshift_node : Configure Proxy Settings] *******************************
Wednesday 02 May 2018  22:26:41 -0400 (0:00:00.928)       0:01:27.894 ********* 
fatal: [host-8-245-18.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"failed": true, "msg": "'dict object' has no attribute 'master'"}
fatal: [host-8-249-153.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"failed": true, "msg": "'dict object' has no attribute 'master'"}


Version-Release number of the following components:
openshift-ansible-3.10.0-0.32.0.git.0.bb50d68.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Trigger installation with proxy settings:
openshift_https_proxy=http://test.redhat.com:3128
openshift_http_proxy=http://test.redhat.com:3128
2.
3.

Actual results:
TASK [openshift_node : Configure Proxy Settings] *******************************
Wednesday 02 May 2018  22:26:41 -0400 (0:00:00.928)       0:01:27.894 ********* 
fatal: [host-8-245-18.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"failed": true, "msg": "'dict object' has no attribute 'master'"}
fatal: [host-8-249-153.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"failed": true, "msg": "'dict object' has no attribute 'master'"}

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Gan Huang 2018-05-03 03:18:22 UTC
Blocking proxy related testing.

Comment 3 Scott Dodson 2018-05-03 13:10:58 UTC
Russ's thoughts, re-ordering of playbooks means that we've lost ensuring that these facts are set before use as they were in the past.

Comment 4 Russell Teague 2018-05-04 20:41:40 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/8275

Comment 5 openshift-github-bot 2018-05-08 08:30:57 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/64921e8622d492db1e97676c6f40f058f55f9ee3
Convert SDN master facts to openshift_facts defaults

sdn_cluster_network_cidr
sdn_host_subnet_length

Due to bootstrapping, nodes are installed before masters so master facts
are not available.

Bug 1574300 | https://bugzilla.redhat.com/show_bug.cgi?id=1574300

Comment 6 Russell Teague 2018-05-09 14:46:57 UTC
Commit in build openshift-ansible-3.10.0-0.38.0

Comment 7 Gan Huang 2018-05-10 06:19:56 UTC
Tested in openshift-ansible-3.10.0-0.38.0.git.7.848b045.el7.noarch.rpm

The error is gone and installation can complete, but the proxy environment are missing in some places, tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1576669

Comment 9 errata-xmlrpc 2018-07-30 19:14:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.