SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1574392 - map AVCs for google-chrome after selinux-policy update
Summary: map AVCs for google-chrome after selinux-policy update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1574394 (view as bug list)
Depends On: 1574383 1574394
Blocks: 1574389
TreeView+ depends on / blocked
 
Reported: 2018-05-03 08:07 UTC by Tomas Pelka
Modified: 2018-10-30 10:04 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-199.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1574383
Environment:
Last Closed: 2018-10-30 10:03:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:04:28 UTC

Description Tomas Pelka 2018-05-03 08:07:45 UTC
Description of problem:
Seems that new map permissions added in -193 denies chrome process..

Version-Release number of selected component (if applicable):
kernel-3.10.0-878.el7
selinux-policy-targeted-3.13.1-193.el7
selinux-policy-3.13.1-193.el7

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:
May 03 08:21:13 placka kernel: type=1400 audit(1525328473.994:677): avc:  denied  { map } for  pid=31512 comm="chrome" path=2F6465762F73686D2F2E636F6D2E676F6F676C652E4368726F6D652E795965313133202864656C6574656429 dev="tmpfs" ino=176539 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=1
May 03 08:21:36 placka kernel: type=1400 audit(1525328496.608:679): avc:  denied  { map } for  pid=31996 comm="chrome" path=2F6465762F73686D2F2E636F6D2E676F6F676C652E4368726F6D652E653050476D71202864656C6574656429 dev="tmpfs" ino=202763 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=1



Expected results:


Additional info:
Wokaround:
either setenforce 0
or downgrading to selinux-policy-targeted-3.13.1-192.el7_5.3.noarch selinux-policy-3.13.1-192.el7_5.3

Full list of map related AVC's at https://bugzilla.redhat.com/attachment.cgi?id=1430552

Comment 1 Tomas Pelka 2018-05-03 08:15:23 UTC
Also these are related

May 03 08:24:51 placka kernel: type=1400 audit(1525328691.260:690): avc:  denied  { map } for  pid=1650 comm="CompositorTileW" path=2F6465762F73686D2F2E636F6D2E676F6F676C652E4368726F6D652E69706F4E5549202864656C6574656429 dev="tmpfs" ino=268099 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0
May 03 08:24:51 placka kernel: type=1400 audit(1525328691.261:691): avc:  denied  { map } for  pid=1650 comm="CompositorTileW" path=2F6465762F73686D2F2E636F6D2E676F6F676C652E4368726F6D652E637649427238202864656C6574656429 dev="tmpfs" ino=268100 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0

Comment 3 Lukas Vrabec 2018-05-20 23:09:13 UTC
*** Bug 1574394 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2018-10-30 10:03:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.