Bug 1574389 - map AVCs for policykit after selinux-policy update
Summary: map AVCs for policykit after selinux-policy update
Keywords:
Status: CLOSED DUPLICATE of bug 1583082
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On: 1574383 1574392 1574394
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 07:59 UTC by Tomas Pelka
Modified: 2019-03-15 08:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1574383
Environment:
Last Closed: 2018-06-03 16:05:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Pelka 2018-05-03 07:59:57 UTC
Description of problem:
Seems that new map permissions added in -193 denies pkla-check-auth porcess.

Version-Release number of selected component (if applicable):
kernel-3.10.0-878.el7
selinux-policy-targeted-3.13.1-193.el7
selinux-policy-3.13.1-193.el7

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:
May 03 08:06:58 placka kernel: type=1400 audit(1525327618.612:123): avc:  denied  { map } for  pid=2503 comm="pkla-check-auth" path="/usr/bin/pkla-check-authorization" dev="dm-4" ino=100666321 scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:object_r:policykit_auth_exec_t:s0 tclass=file permissive=0



Expected results:


Additional info:
Wokaround:
either setenforce 0
or downgrading to selinux-policy-targeted-3.13.1-192.el7_5.3.noarch selinux-policy-3.13.1-192.el7_5.3

Full list of map related AVC's attached at https://bugzilla.redhat.com/attachment.cgi?id=1430552

Comment 1 Tomas Pelka 2018-05-31 10:07:14 UTC
I can still see this issue with -201 version of selinux-policy.

Comment 2 Lukas Vrabec 2018-06-03 16:05:02 UTC

*** This bug has been marked as a duplicate of bug 1583082 ***


Note You need to log in before you can comment on or make changes to this bug.