Bug 1574458 - [ceph-ansible]: "clients" role fails to configure Tools repo through CDN install
Summary: [ceph-ansible]: "clients" role fails to configure Tools repo through CDN install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: z3
: 3.0
Assignee: Sébastien Han
QA Contact: ceph-qe-bugs
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 11:19 UTC by Tejas
Modified: 2018-05-15 18:21 UTC (History)
14 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.33-1.el7cp Ubuntu: ceph-ansible_3.0.33-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:20:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2564 0 None None None 2018-05-08 14:12:54 UTC
Red Hat Product Errata RHBA-2018:1563 0 None None None 2018-05-15 18:21:25 UTC

Description Tejas 2018-05-03 11:19:13 UTC
Description of problem:

   Trying to install a Client  through CDN install on a new ceph cluster installation. The Tools repo is not configured on those Client nodes.
The error seen is :

TASK [ceph-common : install redhat ceph-fuse package] ***************************************************************************************************************
fatal: [magna064]: FAILED! => {"changed": false, "msg": "No package matching 'ceph-fuse' found available, installed or updated", "rc": 126, "results": ["No package matching 'ceph-fuse' found available, installed or updated"]}
fatal: [magna068]: FAILED! => {"changed": false, "msg": "No package matching 'ceph-fuse' found available, installed or updated", "rc": 126, "results": ["No package matching 'ceph-fuse' found available, installed or updated"]}


'ceph-fuse' package is not found as Tools repo is not present.

The Tools should be configured on the Clients role.

Comment 7 Sébastien Han 2018-05-08 14:12:38 UTC
This on track for z3 I think.

Comment 9 Ken Dreyer (Red Hat) 2018-05-10 21:47:52 UTC
v3.0.33 upstream has the fix. That will ship in RHCEPH 3.0 z3 due to bz 1575859, so you can verify this bug now or in z4.

Comment 16 subhash 2018-05-14 10:06:52 UTC
Verified with the following parameters set in all.yml.Issue No longer reproducible. ceph-ansible enables the Tools repo on Client nodes before installing the necessary packages.

all.yml variables for cdn installation

fetch_directory: ~/ceph-ansible-keys
cluster: 'remote'
ceph_repository_type: cdn # "{{ 'cdn' if ceph_rhcs_cdn_install else 'iso' if ceph_rhcs_iso_install else 'dummy' }}" # backward compatibility with stable-2.2, will disappear in stable 3.1
ceph_origin: repository
ceph_repository: rhcs
ceph_rhcs_version: 3 # "{{ ceph_stable_rh_storage_version | default(2) }}"
monitor_interface: eno1
public_network: x.x.x.x/x 
radosgw_interface: eno1



Version-Release number of selected component (if applicable):
ceph-ansible-3.0.33-1.el7cp.noarch
ansible-2.4.2.0-2.el7.noarch

Comment 19 errata-xmlrpc 2018-05-15 18:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.