Bug 1574523 - Login keyboard forced to "en" after upgrade to Fedora 28
Summary: Login keyboard forced to "en" after upgrade to Fedora 28
Keywords:
Status: CLOSED DUPLICATE of bug 1573923
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1574839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 13:16 UTC by Jens Reimann
Modified: 2018-05-04 14:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 14:42:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Reimann 2018-05-03 13:16:26 UTC
Description of problem:

After the upgrade from Fedora 27 to 28 the login screen only uses "en" keyboard mapping, although configured otherwise.


Version-Release number of selected component (if applicable):

Fedora 28


How reproducible:

For me: Upgrade from 27 to 28.


Steps to Reproduce:
1.
2.
3.

Actual results:

Keyboard mapping is "en" when entering password or username.

Expected results:

Use configured keyboard mapping as with 27.

Additional info:

Comment 1 Helge 2018-05-04 07:30:39 UTC
*** Bug 1574839 has been marked as a duplicate of this bug. ***

Comment 2 Jens Reimann 2018-05-04 07:36:34 UTC
I am not sure this is a duplicate. As my password _does not_ start with an uppercase character.

Comment 3 Helge 2018-05-04 07:38:40 UTC
(In reply to Jens Reimann from comment #2)
> I am not sure this is a duplicate. As my password _does not_ start with an
> uppercase character.

I was wrong about that. The problem were special characters, not the uppercase start. If i type like the en layout suggests, everything works fine.

Comment 4 Jens Reimann 2018-05-04 07:44:22 UTC
(In reply to Helge from comment #3)
> (In reply to Jens Reimann from comment #2)
> > I am not sure this is a duplicate. As my password _does not_ start with an
> > uppercase character.
> 
> I was wrong about that. The problem were special characters, not the
> uppercase start. If i type like the en layout suggests, everything works
> fine.

That sounds like the problem which I have.

Comment 5 Jiri Eischmann 2018-05-04 14:26:10 UTC
This seems to be affecting all users with different keyboard layout than English. I experience it as well and it has been reported to me by quite a few other users.
It's definitely a different bug than the one previously suggested, that one has been already fixed.

Comment 6 Kamil Páral 2018-05-04 14:42:04 UTC
Let's track it in bug 1573923.

*** This bug has been marked as a duplicate of bug 1573923 ***


Note You need to log in before you can comment on or make changes to this bug.