Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574839 - Password check fails with uppercase password
Summary: Password check fails with uppercase password
Keywords:
Status: CLOSED DUPLICATE of bug 1574523
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 06:57 UTC by Helge
Modified: 2018-05-04 07:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 07:30:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Helge 2018-05-04 06:57:01 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gdm-1:3.28.1-1.fc28.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Change password to a password which starts with an uppercase letter (using GNOME User settings)

Actual results:
Login fails (wrong password)

Expected results:
Login

Additional info:
journalctl output:

Mai 04 08:49:08 helge-lan audit[6039]: USER_AUTH pid=6039 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:authentication grantors=? acct="helge" exe="/usr/libexec/gdm_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:authentication grantors=? acct="helge" exe="/usr/libexec/gdm-session-worker" hostname=helge-lan addr=? terminal=/dev/tty1 res=failed'
Mai 04 08:49:08 helge-lan gdm-password][6039]: pam_unix(gdm-password:auth): authentication failure; logname= uid=0 euid=0 tty=/dev/tty1 ruser= rhost=  user=helge
Mai 04 08:49:08 helge-lan unix_chkpwd[6043]: password check failed for user (helge)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #10 0x7fff41ffe420 I   resource:///org/gnome/shell/ui/tweener.js:182 (0x7f2fe15cf560 @ 15)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #9 0x7fff41ffe420 I   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7f2fe15b5de0 @ 71)
Mai 04 08:49:07 helge-lan gnome-shell[1188]: Object Clutter.Clone (0x55b3071aa9f0), has been already finalized. Impossible to set any property to it.
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #8 0x7fff41ffe3b0 b   resource:///org/gnome/shell/ui/tweener.js:207 (0x7f2fe15cf5e8 @ 159)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #7 0x7fff41ffe300 I   resource:///org/gnome/gjs/modules/signals.js:128 (0x7f2fe15cff78 @ 386)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #6 0x7fff41ffe280 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:365 (0x7f2fe15d2ab0 @ 10)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #5 0x7fff41ffe1f0 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:350 (0x7f2fe15d2a28 @ 100)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #4 0x7fff41ffe140 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:337 (0x7f2fe15d29a0 @ 1626)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #3 0x7fff41ffdff0 I   resource:///org/gnome/gjs/modules/tweener/tweener.js:208 (0x7f2fe15d2918 @ 54)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #2 0x55b30601bdb0 i   resource:///org/gnome/shell/ui/tweener.js:92 (0x7f2fe15c7de0 @ 52)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #1 0x55b30601be38 i   resource:///org/gnome/shell/ui/tweener.js:105 (0x7f2fe15c7f78 @ 36)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #0 0x55b30601beb8 i   resource:///org/gnome/shell/ui/tweener.js:80 (0x7f2fe15c7cd0 @ 82)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: == Stack trace for context 0x55b305be81f0 ==
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #10 0x7fff41ffe420 I   resource:///org/gnome/shell/ui/tweener.js:182 (0x7f2fe15cf560 @ 15)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #9 0x7fff41ffe420 I   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7f2fe15b5de0 @ 71)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #8 0x7fff41ffe3b0 b   resource:///org/gnome/shell/ui/tweener.js:207 (0x7f2fe15cf5e8 @ 159)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #7 0x7fff41ffe300 I   resource:///org/gnome/gjs/modules/signals.js:128 (0x7f2fe15cff78 @ 386)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #6 0x7fff41ffe280 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:365 (0x7f2fe15d2ab0 @ 10)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #5 0x7fff41ffe1f0 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:350 (0x7f2fe15d2a28 @ 100)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #4 0x7fff41ffe140 b   resource:///org/gnome/gjs/modules/tweener/tweener.js:337 (0x7f2fe15d29a0 @ 1626)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #3 0x7fff41ffdff0 I   resource:///org/gnome/gjs/modules/tweener/tweener.js:208 (0x7f2fe15d2918 @ 54)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #2 0x55b30601bdb0 i   resource:///org/gnome/shell/ui/tweener.js:92 (0x7f2fe15c7de0 @ 52)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #1 0x55b30601be38 i   resource:///org/gnome/shell/ui/tweener.js:105 (0x7f2fe15c7f78 @ 36)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: #0 0x55b30601beb8 i   resource:///org/gnome/shell/ui/tweener.js:73 (0x7f2fe15c7cd0 @ 9)
Mai 04 08:49:07 helge-lan org.gnome.Shell.desktop[1188]: == Stack trace for context 0x55b305be81f0 ==
Mai 04 08:49:07 helge-lan gnome-shell[1188]: Object Clutter.Clone (0x55b3071aa9f0), has been already finalized. Impossible to get any property from it.

Comment 1 Helge 2018-05-04 07:30:39 UTC

*** This bug has been marked as a duplicate of bug 1574523 ***


Note You need to log in before you can comment on or make changes to this bug.