Bug 1574814 - uploading iso to gluster fs failed [NEEDINFO]
Summary: uploading iso to gluster fs failed
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-iso-uploader
Classification: oVirt
Component: General
Version: 4.2.0
Hardware: x86_64
OS: Other
medium
high
Target Milestone: ovirt-4.2.7
: ---
Assignee: Denis Chaplygin
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 05:59 UTC by Arghya Adhya
Modified: 2018-08-31 09:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-31 09:10:17 UTC
oVirt Team: Gluster
sabose: needinfo? (arghya.coolit)
rule-engine: ovirt-4.2?
sasundar: planning_ack?
godas: devel_ack+
sasundar: testing_ack?


Attachments (Terms of Use)

Description Arghya Adhya 2018-05-04 05:59:53 UTC
Description of problem:

iso upload failed when I try to upload iso file form engine VM. Command is- engine-iso-uploader -vvv --iso-domain=iso upload /mnt/CentOS-7-x86_64-DVD-1503-01.iso 

Version-Release number of selected component (if applicable):

Version 4.2.2.6-1.el7.centos

Comment 1 Arghya Adhya 2018-05-04 06:07:43 UTC
#engine-iso-uploader -vvv --iso-domain=iso upload /mnt/CentOS-7-x86_64-DVD-1503-01.iso
DEBUG: API Vendor(None) API Version(4.2.0)
DEBUG: id=09466c6b-9ba7-4f41-8308-c1556fdb525c address=XXXX path=/iso
Uploading, please wait...
INFO: Start uploading /mnt/CentOS-7-x86_64-DVD-1503-01.iso
ERROR: Failed to create 09466c6b-9ba7-4f41-8308-c1556fdb525c/images/11111111-1111-1111-1111-111111111111//mnt/CentOS-7-x86_64-DVD-1503-01.iso: Success

This is the Error details. If anything more required please inform.

Comment 2 Denis Chaplygin 2018-05-04 12:10:19 UTC
I can't reproduce it locally. Are you sure, that you have access to your volume from that host?

Comment 3 Arghya Adhya 2018-05-04 12:55:54 UTC
I am new to gluster fs. I have install glusterfs and create iso brick and install hosted-engine using glusterfs. Also add iso domain to my cluster using GUI. So, I think my host is connected to the gluster fs. Also i am able to create virtual machine using glusterfs data storage domain. I have started gluster NFS service in my host server. 

[root@host3 ~]# df -h
Filesystem                                              Size  Used Avail Use% Mounted on
/dev/mapper/onn-ovirt--node--ng--4.2.2--0.20180405.0+1  970G  3.0G  917G   1% /
devtmpfs                                                126G     0  126G   0% /dev
tmpfs                                                   126G   20K  126G   1% /dev/shm
tmpfs                                                   126G   26M  126G   1% /run
tmpfs                                                   126G     0  126G   0% /sys/fs/cgroup
/dev/mapper/onn-var                                      15G  1.7G   13G  13% /var
/dev/mapper/onn-home                                    976M  2.6M  907M   1% /home
/dev/sda2                                               976M  344M  566M  38% /boot
/dev/mapper/onn-tmp                                     976M  3.1M  906M   1% /tmp
/dev/sda1                                               200M  9.8M  191M   5% /boot/efi
/dev/mapper/onn-var_log                                 7.8G  106M  7.3G   2% /var/log
/dev/mapper/gluster_vg_sdb-gluster_lv_engine            100G  2.7G   98G   3% /gluster_bricks/engine
/dev/mapper/gluster_vg_sdb-gluster_lv_iso               100G   39M  100G   1% /gluster_bricks/iso
/dev/mapper/onn-var_log_audit                           2.0G   41M  1.8G   3% /var/log/audit
/dev/mapper/onn-var_crash                               9.8G   37M  9.2G   1% /var/crash
/dev/mapper/gluster_vg_sdb-gluster_lv_data              500G   39M  500G   1% /gluster_bricks/data
/dev/mapper/gluster_vg_sdb-gluster_lv_vmstore           2.4T  2.0G  2.4T   1% /gluster_bricks/vmstore
host3.ndl.iitkgp.ac.in:/engine                          100G  2.7G   98G   3% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_engine
host3.ndl.iitkgp.ac.in:/data                            500G   39M  500G   1% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_data
host3.ndl.iitkgp.ac.in:/vmstore                         2.4T  2.0G  2.4T   1% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_vmstore
192.168.1.100:/gfsiso                                    25T  481G   24T   2% /rhev/data-center/mnt/192.168.1.100:_gfsiso
tmpfs                                                    26G     0   26G   0% /run/user/0

Comment 4 Arghya Adhya 2018-05-04 12:56:43 UTC
(In reply to Arghya Adhya from comment #3)
> I am new to gluster fs. I have install glusterfs and create iso brick and
> install hosted-engine using glusterfs. Also add iso domain to my cluster
> using GUI. So, I think my host is connected to the gluster fs. Also i am
> able to create virtual machine using glusterfs data storage domain. I have
> started gluster NFS service in my host server. 
> 
> [root@host3 ~]# df -h
> Filesystem                                              Size  Used Avail
> Use% Mounted on
> /dev/mapper/onn-ovirt--node--ng--4.2.2--0.20180405.0+1  970G  3.0G  917G  
> 1% /
> devtmpfs                                                126G     0  126G  
> 0% /dev
> tmpfs                                                   126G   20K  126G  
> 1% /dev/shm
> tmpfs                                                   126G   26M  126G  
> 1% /run
> tmpfs                                                   126G     0  126G  
> 0% /sys/fs/cgroup
> /dev/mapper/onn-var                                      15G  1.7G   13G 
> 13% /var
> /dev/mapper/onn-home                                    976M  2.6M  907M  
> 1% /home
> /dev/sda2                                               976M  344M  566M 
> 38% /boot
> /dev/mapper/onn-tmp                                     976M  3.1M  906M  
> 1% /tmp
> /dev/sda1                                               200M  9.8M  191M  
> 5% /boot/efi
> /dev/mapper/onn-var_log                                 7.8G  106M  7.3G  
> 2% /var/log
> /dev/mapper/gluster_vg_sdb-gluster_lv_engine            100G  2.7G   98G  
> 3% /gluster_bricks/engine
> /dev/mapper/gluster_vg_sdb-gluster_lv_iso               100G   39M  100G  
> 1% /gluster_bricks/iso
> /dev/mapper/onn-var_log_audit                           2.0G   41M  1.8G  
> 3% /var/log/audit
> /dev/mapper/onn-var_crash                               9.8G   37M  9.2G  
> 1% /var/crash
> /dev/mapper/gluster_vg_sdb-gluster_lv_data              500G   39M  500G  
> 1% /gluster_bricks/data
> /dev/mapper/gluster_vg_sdb-gluster_lv_vmstore           2.4T  2.0G  2.4T  
> 1% /gluster_bricks/vmstore
> host3.ndl.iitkgp.ac.in:/engine                          100G  2.7G   98G  
> 3% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_engine
> host3.ndl.iitkgp.ac.in:/data                            500G   39M  500G  
> 1% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_data
> host3.ndl.iitkgp.ac.in:/vmstore                         2.4T  2.0G  2.4T  
> 1% /rhev/data-center/mnt/glusterSD/host3.ndl.iitkgp.ac.in:_vmstore
> 192.168.1.100:/gfsiso                                    25T  481G   24T  
> 2% /rhev/data-center/mnt/192.168.1.100:_gfsiso

Comment 5 Denis Chaplygin 2018-05-04 13:46:09 UTC
Are you running ovirt-iso-uploader from the engine vm or host? 

Which exactly version you are using? Could you please give me output of the rpm -q ovirt-iso-uploader ?

Comment 6 Arghya Adhya 2018-05-04 14:02:07 UTC
command-- rpm -q ovirt-iso-uploader

output-- ovirt-iso-uploader-4.2.0-1.el7.centos.noarch

oVirt Node 4.2.2
OVirt Hosted-engine-- Version 4.2.2.6-1.el7.centos

Comment 7 Tal Nisan 2018-06-14 13:13:52 UTC
Arghya, since 4.2 you can upload now ISO images to Data domains directly through Webadmin/REST, this deprecates the ISO uploader, can you try this method instead?

Comment 8 Arghya Adhya 2018-06-26 12:21:16 UTC
I am getting error--Connection to ovirt-imageio-proxy service has failed. Make sure the service is installed, configured, and ovirt-engine certificate is registered as a valid CA in the browser.
Also when I try to install ovirt-imageio-proxy I am getting below error

yum list ovirt-imageio-proxy
Loaded plugins: enabled_repos_upload, fastestmirror, imgbased-persist, package_upload, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
 * ovirt-4.2-epel: del-mirrors.extreme-ix.org
Error: No matching Packages to list
Uploading Enabled Repositories Report
Loaded plugins: fastestmirror, product-id, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Cannot upload enabled repos report, is this client registered?

Comment 9 Sahina Bose 2018-08-16 10:34:57 UTC
Please see if you have the required info to test upload to data domains in Bug 1122970

Comment 10 Sahina Bose 2018-08-31 09:10:17 UTC
Please re-open once you have the requested data


Note You need to log in before you can comment on or make changes to this bug.