Bug 157497 - candidate window unable to display selective characters with iiimxcf
candidate window unable to display selective characters with iiimxcf
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qingyu Wang
: i18n
Depends On:
Blocks: IIIMF FC4Target
  Show dependency treegraph
 
Reported: 2005-05-11 21:26 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 00:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-05-11 21:26:57 EDT
Description of problem:
When iiimf-le-chinput is used with iiimxcf, not all the candidates in the
candidate window can be display. When that happens, it is displayed as blank.
However, if you press 1, the candidate actually gets committed to the apps.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-19
iiimf-x-12.2-3

How reproducible:
Always

Steps to Reproduce:
1.Log in as normal user into KDE at gdm with zh_CN locale
2.start kedit
3.enter hong
4.observe the candidate window
  
Actual results:
Blank, but if you press 1, it actually commits the right character

Expected results:
Should display the character in candidate window

Additional info:
If used with iiimqcf, the candidates will be displayed properly. However, cant
commit. Pls refer to bug 157496

Also, it does not happen with other LE.
Comment 2 Lawrence Lim 2005-10-12 00:39:21 EDT
We strive to work with the upstream community of open source projects. This
allows us to reduce the likelihood of regressions between releases as well as to
benefit from features and fixes as development moves forward. Since this change
would require a divergence from the upstream project, please report this issue
to IIIMF developers by filing a bug report in the OpenI18N bugzilla located at
http://openi18n.org/bugzilla/ in the "IIIMF" component.

We urge you to bring the information upstream, so that it can be incorporated in
the next release. Once you've filed your bug report to OpenI18N, if you paste
the new bug URL here, we will continue to track the issue in the centralized
OpenI18N bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.