Bug 1574997 - pulseaudio crash
Summary: pulseaudio crash
Keywords:
Status: CLOSED DUPLICATE of bug 1536356
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 13:50 UTC by free.r
Modified: 2018-05-06 13:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-06 13:01:42 UTC
Type: Bug


Attachments (Terms of Use)

Description free.r 2018-05-04 13:50:08 UTC
Description of problem:
pulseaudio crash

Version-Release number of selected component (if applicable):
pulseaudio 11.1-rebootstrapped

How reproducible:
I don't know, this issue appears in Fedora 28 but was not in Fedora 27.

Actual results:
· I can use my laptop speaker, no problem here.
But
· Can't use my bluetooth headphone.
· Wine crashes when I launch a game from playonlinux (not the last version of wine).
· Can't configure sound in winecfg with an old version of wine (winecfg crashes when you click on this tab).

Expected results:
Everything works again.

Additional info:

journalctl -r --grep=pulseaudio :

mai 04 01:04:27 FRPC systemd-coredump[5086]: Process 3951 (pulseaudio) of user 1000 dumped core.
                                             
                                             Stack trace of thread 3951:
                                             #0  0x00007f7bb1f80f4b raise (libc.so.6)
                                             #1  0x00007f7bb1f6b591 abort (libc.so.6)
                                             #2  0x00007f7b977e39b5 pa_bluetooth_discovery_get_enable_native_hfp_hf (libbluez5-util.so)
                                             #3  0x00007f7b977ead12 pa_bluetooth_native_backend_free (libbluez5-util.so)
                                             #4  0x00007f7b977e661e pa_bluetooth_discovery_unref (libbluez5-util.so)
                                             #5  0x00007f7b979f54af module_bluez5_discover_LTX_pa__done (module-bluez5-discover.so)
                                             #6  0x00007f7bb55e8495 pa_module_free (libpulsecore-11.1.so)
                                             #7  0x00007f7bb55e93a9 pa_module_unload_all (libpulsecore-11.1.so)
                                             #8  0x000055b0c69a787b main (pulseaudio)
                                             #9  0x00007f7bb1f6d1bb __libc_start_main (libc.so.6)
                                             #10 0x000055b0c69a8f1a _start (pulseaudio)
                                             
                                             Stack trace of thread 3954:
                                             #0  0x00007f7bb2039a26 ppoll (libc.so.6)
                                             #1  0x00007f7bb55f205f pa_rtpoll_run (libpulsecore-11.1.so)
                                             #2  0x00007f7b9d41042e thread_func (libalsa-util.so)
                                             #3  0x00007f7bb482b99c internal_thread_func (libpulsecommon-11.1.so)
                                             #4  0x00007f7bb2ab0564 start_thread (libpthread.so.0)
                                             #5  0x00007f7bb204431f __clone (libc.so.6)
                                             
                                             Stack trace of thread 3957:
                                             #0  0x00007f7bb2039a26 ppoll (libc.so.6)
                                             #1  0x00007f7bb55f205f pa_rtpoll_run (libpulsecore-11.1.so)
                                             #2  0x00007f7b9d416a92 thread_func (libalsa-util.so)
                                             #3  0x00007f7bb482b99c internal_thread_func (libpulsecommon-11.1.so)
                                             #4  0x00007f7bb2ab0564 start_thread (libpthread.so.0)
                                             #5  0x00007f7bb204431f __clone (libc.so.6)
mai 04 01:04:18 FRPC systemd[3766]: pulseaudio.service: Failed with result 'core-dump'.
mai 04 01:04:18 FRPC systemd[3766]: pulseaudio.service: Main process exited, code=dumped, status=6/ABRT
mai 04 01:04:16 FRPC pulseaudio[3951]: E: [pulseaudio] bluez5-util.c: Assertion 'pa_atomic_load(&(y)->_ref) > 0' failed at modules/bluetooth/bluez5-util.c:559, function pa_bluetooth_discovery_get_enable_native_hfp_hf(). Aborting.
mai 04 01:04:16 FRPC audit[3951]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=5 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=3951 comm="pulseaudio" exe="/usr/bin/pulseaudio" sig=6 res=1
mai 04 01:03:58 FRPC abrt-notification[4479]: Process 2040 (pulseaudio) crashed in ??()
mai 04 01:03:49 FRPC rtkit-daemon[721]: Successfully made thread 3957 of process 3951 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
mai 04 01:03:49 FRPC rtkit-daemon[721]: Successfully made thread 3954 of process 3951 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
mai 04 01:03:49 FRPC rtkit-daemon[721]: Successfully made thread 3951 of process 3951 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.
mai 04 01:03:42 FRPC systemd-coredump[3715]: Process 2040 (pulseaudio) of user 1000 dumped core.
                                             
                                             Stack trace of thread 2040:
                                             #0  0x00007fa6837e4f4b raise (libc.so.6)
                                             #1  0x00007fa6837cf591 abort (libc.so.6)
                                             #2  0x00007fa66d1299b5 pa_bluetooth_discovery_get_enable_native_hfp_hf (libbluez5-util.so)
                                             #3  0x00007fa66d130d12 pa_bluetooth_native_backend_free (libbluez5-util.so)
                                             #4  0x00007fa66d12c61e pa_bluetooth_discovery_unref (libbluez5-util.so)
                                             #5  0x00007fa66d33b4af module_bluez5_discover_LTX_pa__done (module-bluez5-discover.so)
                                             #6  0x00007fa686e4c495 pa_module_free (libpulsecore-11.1.so)
                                             #7  0x00007fa686e4d3a9 pa_module_unload_all (libpulsecore-11.1.so)
                                             #8  0x00005556f0c5487b main (pulseaudio)
                                             #9  0x00007fa6837d11bb __libc_start_main (libc.so.6)
                                             #10 0x00005556f0c55f1a _start (pulseaudio)
                                             
                                             Stack trace of thread 2043:
                                             #0  0x00007fa68389da26 ppoll (libc.so.6)
                                             #1  0x00007fa686e5605f pa_rtpoll_run (libpulsecore-11.1.so)
                                             #2  0x00007fa66ec7442e thread_func (libalsa-util.so)
                                             #3  0x00007fa68608f99c internal_thread_func (libpulsecommon-11.1.so)
                                             #4  0x00007fa684314564 start_thread (libpthread.so.0)
                                             #5  0x00007fa6838a831f __clone (libc.so.6)
                                             
                                             Stack trace of thread 2046:
                                             #0  0x00007fa68389da26 ppoll (libc.so.6)
                                             #1  0x00007fa686e5605f pa_rtpoll_run (libpulsecore-11.1.so)
                                             #2  0x00007fa66ec7aa92 thread_func (libalsa-util.so)
                                             #3  0x00007fa68608f99c internal_thread_func (libpulsecommon-11.1.so)
                                             #4  0x00007fa684314564 start_thread (libpthread.so.0)
                                             #5  0x00007fa6838a831f __clone (libc.so.6)
mai 04 01:03:41 FRPC systemd[1862]: pulseaudio.service: Failed with result 'core-dump'.
mai 04 01:03:41 FRPC systemd[1862]: pulseaudio.service: Main process exited, code=dumped, status=6/ABRT
mai 04 01:03:41 FRPC audit[2040]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=3 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=2040 comm="pulseaudio" exe="/usr/bin/pulseaudio" sig=6 res=1
mai 04 01:03:41 FRPC pulseaudio[2040]: E: [pulseaudio] bluez5-util.c: Assertion 'pa_atomic_load(&(y)->_ref) > 0' failed at modules/bluetooth/bluez5-util.c:559, function pa_bluetooth_discovery_get_enable_native_hfp_hf(). Aborting.
mai 04 00:51:33 FRPC rtkit-daemon[721]: Successfully made thread 2046 of process 2040 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
mai 04 00:51:33 FRPC rtkit-daemon[721]: Successfully made thread 2043 of process 2040 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
mai 04 00:51:33 FRPC rtkit-daemon[721]: Successfully made thread 2040 of process 2040 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.

Comment 1 Rex Dieter 2018-05-06 13:01:42 UTC

*** This bug has been marked as a duplicate of bug 1536356 ***


Note You need to log in before you can comment on or make changes to this bug.