Bug 1575087 - efi-filesystem-2-5.fc29.noarch conflicts with file from package shim-x64-15-3.x86_64
Summary: efi-filesystem-2-5.fc29.noarch conflicts with file from package shim-x64-15-3...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: shim
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Garrett
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1575030 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 17:56 UTC by Mikhail
Modified: 2019-11-27 23:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 23:07:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Mikhail 2018-05-04 17:56:55 UTC
Description of problem:
# dnf install fedora-packager
Last metadata expiration check: 3:02:29 ago on Fri 04 May 2018 07:49:58 PM +05.
Dependencies resolved.
================================================================================
 Package                   Arch   Version                         Repository
                                                                           Size
================================================================================
Installing:
 fedora-packager           noarch 0.6.0.2-1.fc29                  rawhide  48 k
Installing dependencies:
 annobin                   x86_64 5.6-2.fc29                      rawhide  85 k
 bodhi-client              noarch 3.6.1-1.fc29                    rawhide  25 k
 distribution-gpg-keys     noarch 1.21-1.fc29                     rawhide 181 k
 dwz                       x86_64 0.12-7.fc29                     rawhide 107 k
 efi-filesystem            noarch 2-5.fc29                        rawhide 7.3 k
 efi-srpm-macros           noarch 2-5.fc29                        rawhide  20 k
 fakeroot                  x86_64 1.22-1.fc28                     rawhide 102 k
 fakeroot-libs             x86_64 1.22-1.fc28                     rawhide  38 k
 fedora-cert               noarch 0.6.0.2-1.fc29                  rawhide  42 k
 fedpkg                    noarch 1.32-1.fc29                     rawhide  74 k
 fpc-srpm-macros           noarch 1.1-4.fc28                      rawhide 7.5 k
 ghc-srpm-macros           noarch 1.4.2-7.fc28                    rawhide 8.2 k
 gnat-srpm-macros          noarch 4-5.fc28                        rawhide 8.8 k
 go-srpm-macros            noarch 2-16.fc29                       rawhide  11 k
 koji                      noarch 1.15.1-1.fc29                   rawhide 118 k
 krb5-workstation          x86_64 1.16-24.fc29                    rawhide 913 k
 libkadm5                  x86_64 1.16-24.fc29                    rawhide 176 k
 libyubikey                x86_64 1.13-5.fc27                     rawhide  35 k
 mock                      noarch 1.4.9-1.fc28                    rawhide 156 k
 mock-core-configs         noarch 28.4-1.fc29                     rawhide  30 k
 nim-srpm-macros           noarch 1-1.fc28                        rawhide 7.6 k
 ocaml-srpm-macros         noarch 5-2.fc27                        rawhide 7.8 k
 openblas-srpm-macros      noarch 2-2.fc27                        rawhide 6.6 k
 packagedb-cli             noarch 2.14.1-5.fc29                   rawhide  68 k
 perl-srpm-macros          noarch 1-25.fc28                       rawhide 9.7 k
 python-bugzilla-cli       noarch 2.1.0-5.fc29                    rawhide  33 k
 python-srpm-macros        noarch 3-29.fc29                       rawhide  11 k
 python2-GitPython         noarch 2.1.9-1.fc29                    rawhide 566 k
 python2-asn1crypto        noarch 0.24.0-1.fc29                   rawhide 180 k
 python2-beautifulsoup4    noarch 4.6.0-6.fc29                    rawhide 176 k
 python2-bugzilla          noarch 2.1.0-5.fc29                    rawhide  75 k
 python2-cccolutils        x86_64 1.5-7.fc29                      rawhide  21 k
 python2-cffi              x86_64 1.11.2-1.fc28                   rawhide 233 k
 python2-cryptography      x86_64 2.2.1-1.fc29                    rawhide 519 k
 python2-dateutil          noarch 1:2.7.0-1.fc29                  rawhide 271 k
 python2-enum34            noarch 1.1.6-6.fc29                    rawhide  58 k
 python2-fedora            noarch 0.10.0-3.fc28                   rawhide 343 k
 python2-gitdb             noarch 2.0.3-2.fc28                    rawhide 111 k
 python2-kerberos          x86_64 1.3.0-1.fc29                    rawhide  35 k
 python2-kitchen           noarch 1.2.5-3.fc29                    rawhide 122 k
 python2-koji              noarch 1.15.1-1.fc29                   rawhide 294 k
 python2-krbv              x86_64 1.0.90-19.fc29                  rawhide  60 k
 python2-lockfile          noarch 1:0.11.0-10.fc28                rawhide  37 k
 python2-lxml              x86_64 4.2.1-1.fc29                    rawhide 1.3 M
 python2-magic             noarch 5.33-3.fc29                     rawhide  43 k
 python2-munch             noarch 2.2.0-4.fc29                    rawhide  20 k
 python2-offtrac           noarch 0.1.0-13.fc28                   rawhide  20 k
 python2-openidc-client    noarch 0.5.0-1.20180324git188c560.fc29 rawhide  23 k
 python2-ply               noarch 3.9-6.fc28                      rawhide 107 k
 python2-pyOpenSSL         noarch 17.3.0-4.fc29                   rawhide  96 k
 python2-pycparser         noarch 2.14-14.fc29                    rawhide 147 k
 python2-pycurl            x86_64 7.43.0-15.fc29                  rawhide 206 k
 python2-pyusb             noarch 1.0.0-8.fc28                    rawhide  86 k
 python2-requests-kerberos noarch 0.12.0-2.fc28                   rawhide  27 k
 python2-rpkg              noarch 1.53-2.fc29                     rawhide 149 k
 python2-rpm               x86_64 4.14.1-8.fc28                   rawhide 120 k
 python2-smmap             noarch 2.0.3-2.fc28                    rawhide  48 k
 python2-webencodings      noarch 0.5.1-4.fc28                    rawhide  26 k
 python2-yubico            noarch 1.3.2-8.fc28                    rawhide  61 k
 python3-asn1crypto        noarch 0.24.0-1.fc29                   rawhide 179 k
 python3-beautifulsoup4    noarch 4.6.0-6.fc29                    rawhide 177 k
 python3-bodhi             noarch 3.6.1-1.fc29                    rawhide  25 k
 python3-bodhi-client      noarch 3.6.1-1.fc29                    rawhide  50 k
 python3-bugzilla          noarch 2.1.0-5.fc29                    rawhide  76 k
 python3-cffi              x86_64 1.11.2-1.fc28                   rawhide 234 k
 python3-click             noarch 6.7-7.fc28                      rawhide 130 k
 python3-cryptography      x86_64 2.2.1-1.fc29                    rawhide 524 k
 python3-dateutil          noarch 1:2.7.0-1.fc29                  rawhide 272 k
 python3-distro            noarch 1.2.0-1.fc28                    rawhide  33 k
 python3-fedora            noarch 0.10.0-3.fc28                   rawhide 343 k
 python3-kerberos          x86_64 1.3.0-1.fc29                    rawhide  35 k
 python3-kitchen           noarch 1.2.5-3.fc29                    rawhide  94 k
 python3-koji              noarch 1.15.1-1.fc29                   rawhide 226 k
 python3-lockfile          noarch 1:0.11.0-10.fc28                rawhide  37 k
 python3-lxml              x86_64 4.2.1-1.fc29                    rawhide 1.3 M
 python3-magic             noarch 5.33-3.fc29                     rawhide  43 k
 python3-munch             noarch 2.2.0-4.fc29                    rawhide  20 k
 python3-openidc-client    noarch 0.5.0-1.20180324git188c560.fc29 rawhide  23 k
 python3-pyOpenSSL         noarch 17.3.0-4.fc29                   rawhide  97 k
 python3-pycparser         noarch 2.14-14.fc29                    rawhide 147 k
 python3-pyroute2          noarch 0.4.21-1.fc28                   rawhide 383 k
 python3-requests-kerberos noarch 0.12.0-2.fc28                   rawhide  27 k
 python3-webencodings      noarch 0.5.1-4.fc28                    rawhide  26 k
 qt5-srpm-macros           noarch 5.10.1-1.fc29                   rawhide 9.6 k
 redhat-rpm-config         noarch 111-1.fc29                      rawhide  78 k
 rpkg-common               noarch 1.53-2.fc29                     rawhide  46 k
 rpm-build                 x86_64 4.14.1-8.fc28                   rawhide 162 k
 rpmdevtools               noarch 8.10-4.fc28                     rawhide 105 k
 rpmlint                   noarch 1.10-11.fc29                    rawhide 191 k
 rust-srpm-macros          noarch 5-2.fc28                        rawhide 8.1 k
 xemacs-filesystem         noarch 21.5.34-29.20171230hg92757c2b8239.fc29
                                                                  rawhide  23 k
 ykpers                    x86_64 1.18.1-2.fc28                   rawhide 109 k
 zstd                      x86_64 1.3.4-1.fc29                    rawhide 333 k
Installing weak dependencies:
 python2-cssselect         noarch 0.9.2-7.fc29                    rawhide  39 k
 python2-html5lib          noarch 1:0.999999999-6.fc29            rawhide 216 k
 python3-cssselect         noarch 0.9.2-7.fc29                    rawhide  40 k
 python3-html5lib          noarch 1:0.999999999-6.fc29            rawhide 213 k

Transaction Summary
================================================================================
Install  98 Packages

Total size: 14 M
Installed size: 50 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] fedora-packager-0.6.0.2-1.fc29.noarch.rpm: Already downloaded        
[SKIPPED] bodhi-client-3.6.1-1.fc29.noarch.rpm: Already downloaded             
[SKIPPED] fedora-cert-0.6.0.2-1.fc29.noarch.rpm: Already downloaded            
[SKIPPED] fedpkg-1.32-1.fc29.noarch.rpm: Already downloaded                    
[SKIPPED] koji-1.15.1-1.fc29.noarch.rpm: Already downloaded                    
[SKIPPED] krb5-workstation-1.16-24.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] mock-1.4.9-1.fc28.noarch.rpm: Already downloaded                     
[SKIPPED] packagedb-cli-2.14.1-5.fc29.noarch.rpm: Already downloaded           
[SKIPPED] python2-offtrac-0.1.0-13.fc28.noarch.rpm: Already downloaded         
[SKIPPED] python2-pyOpenSSL-17.3.0-4.fc29.noarch.rpm: Already downloaded       
[SKIPPED] python2-yubico-1.3.2-8.fc28.noarch.rpm: Already downloaded           
[SKIPPED] redhat-rpm-config-111-1.fc29.noarch.rpm: Already downloaded          
[SKIPPED] rpm-build-4.14.1-8.fc28.x86_64.rpm: Already downloaded               
[SKIPPED] rpmdevtools-8.10-4.fc28.noarch.rpm: Already downloaded               
[SKIPPED] rpmlint-1.10-11.fc29.noarch.rpm: Already downloaded                  
[SKIPPED] python3-bodhi-client-3.6.1-1.fc29.noarch.rpm: Already downloaded     
[SKIPPED] python2-fedora-0.10.0-3.fc28.noarch.rpm: Already downloaded          
[SKIPPED] python2-pycurl-7.43.0-15.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] python2-bugzilla-2.1.0-5.fc29.noarch.rpm: Already downloaded         
[SKIPPED] python2-openidc-client-0.5.0-1.20180324git188c560.fc29.noarch.rpm: Already downloaded
[SKIPPED] python2-rpkg-1.53-2.fc29.noarch.rpm: Already downloaded              
[SKIPPED] python3-koji-1.15.1-1.fc29.noarch.rpm: Already downloaded            
[SKIPPED] libkadm5-1.16-24.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] mock-core-configs-28.4-1.fc29.noarch.rpm: Already downloaded         
[SKIPPED] python3-distro-1.2.0-1.fc28.noarch.rpm: Already downloaded           
[SKIPPED] python3-pyroute2-0.4.21-1.fc28.noarch.rpm: Already downloaded        
[SKIPPED] python2-beautifulsoup4-4.6.0-6.fc29.noarch.rpm: Already downloaded   
[SKIPPED] python2-cryptography-2.2.1-1.fc29.x86_64.rpm: Already downloaded     
[SKIPPED] python2-pyusb-1.0.0-8.fc28.noarch.rpm: Already downloaded            
[SKIPPED] dwz-0.12-7.fc29.x86_64.rpm: Already downloaded                       
[SKIPPED] efi-srpm-macros-2-5.fc29.noarch.rpm: Already downloaded              
[SKIPPED] fpc-srpm-macros-1.1-4.fc28.noarch.rpm: Already downloaded            
[SKIPPED] ghc-srpm-macros-1.4.2-7.fc28.noarch.rpm: Already downloaded          
[SKIPPED] gnat-srpm-macros-4-5.fc28.noarch.rpm: Already downloaded             
[SKIPPED] go-srpm-macros-2-16.fc29.noarch.rpm: Already downloaded              
[SKIPPED] nim-srpm-macros-1-1.fc28.noarch.rpm: Already downloaded              
[SKIPPED] ocaml-srpm-macros-5-2.fc27.noarch.rpm: Already downloaded            
[SKIPPED] openblas-srpm-macros-2-2.fc27.noarch.rpm: Already downloaded         
[SKIPPED] perl-srpm-macros-1-25.fc28.noarch.rpm: Already downloaded            
[SKIPPED] python-srpm-macros-3-29.fc29.noarch.rpm: Already downloaded          
[SKIPPED] qt5-srpm-macros-5.10.1-1.fc29.noarch.rpm: Already downloaded         
[SKIPPED] rust-srpm-macros-5-2.fc28.noarch.rpm: Already downloaded             
[SKIPPED] zstd-1.3.4-1.fc29.x86_64.rpm: Already downloaded                     
[SKIPPED] fakeroot-1.22-1.fc28.x86_64.rpm: Already downloaded                  
[SKIPPED] xemacs-filesystem-21.5.34-29.20171230hg92757c2b8239.fc29.noarch.rpm: Already downloaded
[SKIPPED] python3-magic-5.33-3.fc29.noarch.rpm: Already downloaded             
[SKIPPED] python3-bodhi-3.6.1-1.fc29.noarch.rpm: Already downloaded            
[SKIPPED] python3-click-6.7-7.fc28.noarch.rpm: Already downloaded              
[SKIPPED] python3-fedora-0.10.0-3.fc28.noarch.rpm: Already downloaded          
[SKIPPED] python3-kitchen-1.2.5-3.fc29.noarch.rpm: Already downloaded          
[SKIPPED] python2-kitchen-1.2.5-3.fc29.noarch.rpm: Already downloaded          
[SKIPPED] python2-lockfile-0.11.0-10.fc28.noarch.rpm: Already downloaded       
[SKIPPED] python2-munch-2.2.0-4.fc29.noarch.rpm: Already downloaded            
[SKIPPED] python-bugzilla-cli-2.1.0-5.fc29.noarch.rpm: Already downloaded      
[SKIPPED] python2-magic-5.33-3.fc29.noarch.rpm: Already downloaded             
[SKIPPED] python2-GitPython-2.1.9-1.fc29.noarch.rpm: Already downloaded        
[SKIPPED] python2-cccolutils-1.5-7.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] python2-koji-1.15.1-1.fc29.noarch.rpm: Already downloaded            
[SKIPPED] python2-rpm-4.14.1-8.fc28.x86_64.rpm: Already downloaded             
[SKIPPED] rpkg-common-1.53-2.fc29.noarch.rpm: Already downloaded               
[SKIPPED] python3-dateutil-2.7.0-1.fc29.noarch.rpm: Already downloaded         
[SKIPPED] python3-pyOpenSSL-17.3.0-4.fc29.noarch.rpm: Already downloaded       
[SKIPPED] python3-requests-kerberos-0.12.0-2.fc28.noarch.rpm: Already downloaded
[SKIPPED] distribution-gpg-keys-1.21-1.fc29.noarch.rpm: Already downloaded     
[SKIPPED] python2-lxml-4.2.1-1.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] python2-asn1crypto-0.24.0-1.fc29.noarch.rpm: Already downloaded      
[SKIPPED] python2-cffi-1.11.2-1.fc28.x86_64.rpm: Already downloaded            
[SKIPPED] python2-enum34-1.1.6-6.fc29.noarch.rpm: Already downloaded           
[SKIPPED] efi-filesystem-2-5.fc29.noarch.rpm: Already downloaded               
[SKIPPED] python3-beautifulsoup4-4.6.0-6.fc29.noarch.rpm: Already downloaded   
[SKIPPED] python3-lockfile-0.11.0-10.fc28.noarch.rpm: Already downloaded       
[SKIPPED] python3-munch-2.2.0-4.fc29.noarch.rpm: Already downloaded            
[SKIPPED] python3-openidc-client-0.5.0-1.20180324git188c560.fc29.noarch.rpm: Already downloaded
[SKIPPED] python3-bugzilla-2.1.0-5.fc29.noarch.rpm: Already downloaded         
[SKIPPED] python2-gitdb-2.0.3-2.fc28.noarch.rpm: Already downloaded            
[SKIPPED] python2-dateutil-2.7.0-1.fc29.noarch.rpm: Already downloaded         
[SKIPPED] python2-krbv-1.0.90-19.fc29.x86_64.rpm: Already downloaded           
[SKIPPED] python2-requests-kerberos-0.12.0-2.fc28.noarch.rpm: Already downloaded
[SKIPPED] python3-cryptography-2.2.1-1.fc29.x86_64.rpm: Already downloaded     
[SKIPPED] python3-kerberos-1.3.0-1.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] python2-pycparser-2.14-14.fc29.noarch.rpm: Already downloaded        
[SKIPPED] python3-lxml-4.2.1-1.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] python2-smmap-2.0.3-2.fc28.noarch.rpm: Already downloaded            
[SKIPPED] python2-kerberos-1.3.0-1.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] python3-asn1crypto-0.24.0-1.fc29.noarch.rpm: Already downloaded      
[SKIPPED] python3-cffi-1.11.2-1.fc28.x86_64.rpm: Already downloaded            
[SKIPPED] python2-ply-3.9-6.fc28.noarch.rpm: Already downloaded                
[SKIPPED] python3-pycparser-2.14-14.fc29.noarch.rpm: Already downloaded        
[SKIPPED] annobin-5.6-2.fc29.x86_64.rpm: Already downloaded                    
[SKIPPED] ykpers-1.18.1-2.fc28.x86_64.rpm: Already downloaded                  
[SKIPPED] libyubikey-1.13-5.fc27.x86_64.rpm: Already downloaded                
[SKIPPED] fakeroot-libs-1.22-1.fc28.x86_64.rpm: Already downloaded             
[SKIPPED] python2-cssselect-0.9.2-7.fc29.noarch.rpm: Already downloaded        
[SKIPPED] python2-html5lib-0.999999999-6.fc29.noarch.rpm: Already downloaded   
[SKIPPED] python2-webencodings-0.5.1-4.fc28.noarch.rpm: Already downloaded     
[SKIPPED] python3-cssselect-0.9.2-7.fc29.noarch.rpm: Already downloaded        
[SKIPPED] python3-html5lib-0.999999999-6.fc29.noarch.rpm: Already downloaded   
[SKIPPED] python3-webencodings-0.5.1-4.fc28.noarch.rpm: Already downloaded     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /boot/efi/EFI from install of efi-filesystem-2-5.fc29.noarch conflicts with file from package shim-x64-15-3.x86_64
  file /boot/efi/EFI from install of efi-filesystem-2-5.fc29.noarch conflicts with file from package shim-ia32-15-3.x86_64

Error Summary
-------------

Comment 1 Jan Kurik 2018-08-14 10:04:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Peter Robinson 2019-07-28 22:26:10 UTC
*** Bug 1575030 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2019-10-31 19:00:34 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Ben Cotton 2019-11-27 23:07:43 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.